N64 small screen to left



  • Running on intel i3 X64 laptop.
    Turned laptop screen off using xanda. Display via HDMI only.

    ES is correct and full screen. SNES works correctly and displays full. N64 does not display full and is on left hand side of screen.

    alt text

    Can i full screen or at least center N64?

    Thank you



  • Hello Scott, are you using the default emulator and core for n64 ? (should be if you have not changed it) I personally have no issues with the stock autoconfiguated setup. Is your laptop display resolution the same as your hdmi TV screen (ie 1080p) ?

    default emulator/core:
    n64.core=glide64mk2
    n64.emulator=mupen64plus

    You can check this in the via the main menu > advanced > advanced emulator configuration
    or in /recalbox/share/system/recalbox.conf if accessing the the file system via ssh/scp

    My [ Video-General] section of mupen64plus.cfg from /recalbox/share/system/configs/mupen64/mupen64plus.cfg looks like this:

    [Video-General]

    Fullscreen = False
    # Width of output window or fullscreen width
    ScreenWidth = 1920
    # Height of output window or fullscreen height
    ScreenHeight = 1080
    # If true, use correct aspect ratio, if false, stretch to fullscreen
    AspectRatio = True
    # If true, activate the SDL_GL_SWAP_CONTROL attribute
    VerticalSync = False
    # Rotate screen contents: 0=0 degree, 1=90 degree, 2 = 180 degree, 3=270 degree
    Rotate = 0
    


  • Thank you for your help. The latoptop screen is smaller than the HDMI TV.

    The TV is 1080 and the latop is 768.

    The recalbox install is stock default.

    So far i have turned off the laptop screen by creating a .xinitrc file and adding:
    Xrandr —output LVDS1 —off

    This seems to help because when the emulation station screen boots it loads full screen on the TV HDMI.

    I’ve checked the mupen64plus.cfg and the values are:
    ScreenWidth = 1366
    ScreenHeight = 768

    I changed these to 1920 and 1080 but i still had the same problem. However, on rechecking the file i noticed that they had been reset to 1366 and 768.

    I dont know why this happened, do you think this may be whats causing it? Do you think these values are getting reset bu something else (i.e because the laptop is reporting its screen size?)



  • @scottaii

    Possibly, but I`m not sure. You could try editing .xinitrc with:

    xrandr —output LVDS1 —off --output HDMI-1 --auto

    (The --auto option will turn the specified output on if it is off and set the preferred (maximum) resolution, assuming HDMI-1 is your external hdmi reported by xrandr, it may be HDMI-0 or another value.)

    In the unlikely event it does not auto detect the external display resolution you could set it by:

    xrandr —output LVDS1 —off --output HDMI-1 --mode 1920x1080

    Or force 720p:

    xrandr —output LVDS1 —off --output HDMI-1 --mode 1366x768

    https://wiki.archlinux.org/index.php/Xrandr is a good resource to find out more about xrandr. Hope it helps :)



  • Apologies, xrandr options should be -- (double hyphen, not single dash)



  • Thanks for your help with this. I also tried that but it didnt help.

    Incase this helps anyone in the future i gave up with Recalbox and installed LAKKA Retroarch onto a USB stick, this works perfectly and i had no issues with screen resoltions.

    Its a shame as i was hoping that it could solve it using Recalbox but hey, at least my retro project can continue 🙂👍


Log in to reply
 

Want to support us ?

Join us on :

179
Online

28784
Users

14635
Topics

110651
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.