2nd Controller not saving configuration



  • hellio there, i have 2 logitech f710 wireless controllers, the 2nd controller i map keys in game and it works, but right when i close the emulator and open again the 2nd controller stops working. i have to map everything again. I have set global config in recalbox.conf as retroarchconfig.cfg . i cannot see 2nd controller config in retroarchconfig.cfg. i made it read-only right after saving config but it resets again. what am i doing wrong?



  • @rocketbomb Hello! From what you're saying, you're not saving the settings ... So it works until you quit the game, but it does not work when you quit the game. Go to Main Menu->Settings->Configuration, and you'll find the "save configuration on exit" option that is OFF, and you should switch to ON.

    There is another way to do this: after changing, go back to the main menu, go to quick menu, and choose the option "Save game overrides" to save this setting only in the game you are playing, OR, choose the " Save core overrides "to save this setting for all games that use that same emulation core.



  • Thanks for yr methods . I had to remove semicolon in line next to global config in recalbox.conf and make changes inside emulator then put back the semicolon. Now its working.



  • @rocketbomb I'm glad that it worked, but I need to tell you that taking the semicolon from the global settings and adding it again may not have been what solved your problem.
    The semicolon indicates that a command is "commented", ie: the command is ready to be used, to facilitate if necessary, but is "deactivated".
    As you say you entered the semicolon again, then this option was disabled again, and if it was the one that solved your problem, the problem would reappear ...
    You probably did this while modifying something else, and related to this change, but that's not the case.
    I'm just leaving it clear for you to understand, and if someone else has the same problem.



  • I think i got confused. I meant. After commenting that use one config for all emu line in recalbox.conf. and then setting up my controller and saving it and uncommenting it. Did it for me ... that is all i did



  • @rocketbomb If you "put back the semicolon" as you said earlier, you left "commented", that is: you have disabled this option.

    Now you say "saving it and uncommenting it", if you saved without the semicolon at the beginning, then you actually "uncommented", and left the option active.

    As I said in my previous comment: If there is an option starting with ";" or "#" in the configuration file, this means that the option is inactive. (In the file recalbox.conf it is easy to see this, there are "explanations" starting with "#" not to be read by the settings, and some commands disabled with ";" in case the user has problem, he just need to take the semicolon from front, it is not necessary to look for the right code to use.


Log in to reply
 

Want to support us ?

Join us on :

268
Online

28860
Users

14652
Topics

110753
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.