Pc Engine CD games won't work for no reason now. Help please :(



  • Ok so for a while now i've been using a Clunky USB drive to store/play all my stuff. Recently with Micro SD card prices experiencing a drop, i thought it was time to finally go for a cleaner, more "internal solution", and bought a Sandisk 256GB Micro SD card for $60. I direct copied all my stuff from my USB drive onto the SD card and everything seems to work great but problem is.... now most of my Pc Engine CD games decided not to work! I'm using the exact SAME bios and SAME games copied directly from my USB drive. And some games do boot up and play fine but, now most won't. I go to start them, screen goes blank like it's loading, then it just returns back to the screen.

    And the thing is, if my plug in my USB drive with my all stuff back into the Pi and set the storage to that? ALL my Pc Engine CD games work beautifully! So i know the Bios and games themselves are fine. WTF. Why is this still happening? :(

    I even tried deleting everything and then reloading it all back on. Same problem. And other systems that require a bios like PSX or NeoGeo are not effected from the transfer. Just Pc Engine CD.

    Edit: And yes, i tried changing the core from the default to "PCE". Won't work. I've also tested my Sandisk SD card with programs to verify it's Quality and that it's not a fake before i even began loading stuff onto to it. All tests came back great.



  • Did you check if the rewind setting is enable? If so pls disable it, there are some incompatibilites between PCE CD games and taht setting.



Want to support us ?

Join us on :

170
Online

28821
Users

14643
Topics

110694
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.