LED w/ Momentary Switch



  • I've been successfully using a momentary switch with an LED for a while now, with config "system.power.switch=PIN356ONOFFRESET". I haven't updated since last year, and just ran an update last night.

    After the update, I can still switch the system on with the switch and the LED works, but I can't switch the system off with the switch. I tried replacing "system.power.switch=PIN356ONOFFRESET" with "system.power.switch=PIN56PUSH". This made the switch work perfectly for powering on/off, but now the LED doesn't turn on.

    Does anyone have a suggestion for this? Thanks so much!



  • @xtreemsurf most certainly you edited the script to get the led on ?



  • @substring

    Are you referring to the config file? If so, yes, I edited the config file. I tried "system.power.switch=PIN356ONOFFRESET" and then "system.power.switch=PIN56PUSH". Is there are different script?



  • @xtreemsurf no i'm referring to python files themselves



  • The method described on this page (https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)) has always worked up until this update. Is editing the Python scripts necessary? If so, is there a guide for this? Thanks again!


Log in to reply
 

Want to support us ?

Join us on :

273
Online

31040
Users

15112
Topics

113721
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.