Screenscaper issue

For information, Screenscraper website is currently down. All the Screenscraper staff is aware of this issue. Until it's solved, you won't be able to scrap from Recalbox or Skraper. We apologize for the inconvenience.

Pour information, le site internet de Screenscraper est actuellement en panne. Toute l'équipe de Screenscraper est consciente de ce problème. Tant qu'il ne sera pas résolu, vous ne pourrez pas scraper depuis Recalbox ou Skraper. Veuillez nous excuser pour le dérangement.

The Recalbox Team.

Dosbox doesn't start



  • Software: Recalbox version 18.07.13
    Hardware: Raspberry PI 1 Model B

    I'm having some trouble in getting Dosbox to work (I followed the instructions from https://github.com/recalbox/recalbox-os/wiki/How-to-use-DOSBox-to-emulate-DOS-games).

    I've put the files for the "Duke nukem 3D" game in /recalbox/share/roms/dos/duke.pc, and inside that folder I've created a file dosbox.bat, that contains just two lines:

    c:
    duke3d.exe
    

    When I try to open that Game in the emulationstation GUI, the DOSBOX logo appears for about 1 second (see below) and come back to the emulation station... Something is preventing DOSBOX from starting.

    0_1533134919497_dosbox_screen.jpg

    I've collected some logs just after I've tried to run the "Duke Nukem":

    ~/logs/es_launch_stderr.log:

    ALSA lib seq_hw.c:466:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
    

    ~/logs/es_launch_stdout.log:

    SDL_VIDEO_GL_DRIVER=/usr/lib/libGLESv2.so /usr/bin/dosbox -userconf -exit /recalbox/share/roms/dos/duke.pc/dosbox.bat -c set ROOT=/recalbox/share/roms/dos/duke.pc -vkeybd /usr/share/dosbox -conf /recalbox/share/system/configs/dosbox/dosbox.conf
    

    When I try to run the above command (exactly the contents of ~/logs/es_launch_stdout.log) from SSH, I got the following output:

    DOSBox version SVN
    Copyright 2002-2017 DOSBox Team, published under GNU GPL.
    ---
    CONFIG:Loading primary settings from config file /recalbox/share/system/.dosbox/dosbox-SVN.conf
    CONFIG:Loading additional settings from config file /recalbox/share/system/configs/dosbox/dosbox.conf
    Exit to error: Could not initialize video: Invalid window
    

    Besides Duke Nukem, I've tried to run another DOS program: an ancient DOS program called "visual player". Both works in my linux PC' dosbox but unfotunately dont work in recalbox.

    Questions:

    1. What I'm doing wrong?

    2. Is there something that I can do, some other log to collect?

    3. What "SDL_VIDEODRIVER" (https://wiki.libsdl.org/FAQUsingSDL) Recalbox's dosbox should use for RPi ? May be an issue related to this?

    Thanks in advance.



  • Your only hope would be @lmerckx if he's not in holidays


  • Banned

    @erbertmag change your dosbox.bat to

    c:
    dir
    pause
    duke3d.exe
    

    and do a screen capture to show us what appears on the screen


  • Banned

    @erbertmag

    I posted once my dosbox.cfg concerning DN3, you need a local dosbox.cfg, it will not run with the standard dosbox.conf.
    https://forum.recalbox.com/topic/9240/duke-nukem-3d



  • @voljega I changed my dosbox.bat, and nothing changed (the dosbox splashscreen appears for about 1 second and then it returns to emulation station).



  • @dragu I've tested with your dosbox.cfg, and nothing changed.

    I think that the problem may be related with the dosbox video driver not working ("Exit to error: Could not initialize video: Invalid window").


  • Banned

    Yes, but this error message

    CONFIG:Loading additional settings from config file /recalbox/share/system/configs/dosbox/dosbox.conf
    

    shows that you are not working with a local (inside duke.pc) dosbox.cfg but with the original dosbox.conf that will not work here.



  • @dragu That message was before your advice. I confirm here that the ~/logs/es_launch_stdout.log contains the part of command line -conf /recalbox/share/roms/dos/duke.pc/dosbox.cfg.



  • @erbertmag Which version are you using? I have 1.3D and it works without problems on Recalbox (18.07.13)

    alt text
    Loading - Duke Nukem 3D DOS VERSION (v1.3D)

    alt text
    Menu - Duke Nukem 3D DOS VERSION (v1.3D)

    My dosbox.bat:

    • duke3d.exe

    PS: Confirmed that the latest version of GoG also works without problems if you remove all "the additions"


  • Banned

    @erbertmag seems impossible so I suggest double checking everything, because your screen should be on pause.

    Pay attention to upper case in file and dir names, they shouldn't appear at all


  • Banned

    @ebertmag
    I just downloaded the dosbox version from 180713, easy with 7-Zip that also uncompress .img files, without necessary to install the OS.
    And I can also confirm, DN3D is working with this 180713 version. But, my jackrabbit I not. 🙂
    What shows that dosbox is not really a strait development over time. And the jackrabbit dosbox version is not usable for DN3D, 0 -1 framerates.



  • @substring said in Dosbox doesn't start:

    @lmerckx

    @lmerckx can you help me?


  • Banned

    @erbertmag
    Tu as bien défini une keymapper file xxxx.map au niveau de dosbox.cfg et qui existe dans ton répertoire ?


Log in to reply
 

Want to support us ?

232
Online

79.8k
Users

21.1k
Topics

154.5k
Posts