Problème sur le réglage de durée de vidéo d'intro



  • Salut à vous !

    Il me semble que l'option pour le temps des vidéos d'intro bug.

    J'ai fais les tests avec une vidéo de 50 secondes et voilà mon retour après modification du fichier recalbox.conf :

    Si on laisse sur 0 au bout de 20 secondes il y a un fade vers ES, comme prévu

    Si on règle sur -1, la vidéo ce termine sans fade avec une petite "secousse"

    Si on met une longueur en seconde, ça ira toujours jusqu'à la fin de la vidéo et ça ce termine avec une bonne secousse et ce, quelque soit le nombre de secondes indiquées.

    Il semble donc que cette durée ne soit pas prise en compte.

    Aussi, serait-il possible qu'à la place de ces secousses il y est un fading comme pour la première option ?

    Bonne journée :)


  • Moderator
    Moderator
    Team

    @gaetan ça dépend tu as testé avec quoi ? RPI ou autre chose ?



  • @oyyodams oups, oui avec Rpi3


  • Moderator
    Moderator
    Team

    @gaetan bizarre, c'est justement sur rpi que ça marche le mieux normalement.

    Je checkerai ce soir, mais j'avais fait l'evol en me basant sur l'intro de next-level ;)



  • @oyyodams
    Ok, de mon côté je referais encore un test tout à l'heure.
    Bon choix d'intro :p



  • @gaetan attention camarade, tu va avoir du mal à enfiler tes chaussures ! :p



  • @noktambule lol ahah, et puis il n'a pas dit qu'il l'aimait, juste qu'il l'avait utilisé pour les tests :D



  • @oyyodams j'ai réessayé et j'arrive aux mêmes résultats.



  • @gaetan si je comprends bien, il faut qu'on fasse nous-même le fading des vidéos si on les laisse jouer ? Si c'est ça, non, c'est aux vidéos de gérer une fin correcte. Le fade est sur la video, pas sur l'apparition de ES

    Ou c'est la "secousse" qui te gêne ?



  • @substring Le fade apparemment est déjà géré par ES, ce n'est pas quelque chose que je demande de faire :)
    Il ce fait lors de l'option 1 dans le recalbox.conf (au bout des 20 secondes il y a un fade) et ce faisait aussi dans les versions précédentes de Recalbox, en ajoutant la ligne "sleep + nb de secondes" dans le fichier splash02.
    Je voulais donc savoir si il était possible de l' appliqué sur les 2 autres options, juste comme c'était avant.



  • @gaetan le fade est fait avec la lecture de la video, pas ES



  • @substring tu veux dire la vidéo en elle même devient transparente ? Parce que la vidéo qu'a utilisé OyyoDams ne devient pas transparente par elle même, c'est Es qui s'ajoute par dessus en fading (avec le réglage 1 au bout de 20sec)



  • @gaetan mais qu'il est têtu ... Lis le code ! Par DBus, on ordonne à omxplayer de faire un fading. ES, lui, video ou pas, commence avec son gros pavé



  • @substring Mais, par toutatis :D

    Ok, alors je reprend et avec exemples vidéos. J'utilise pour l'exemple la même vidéo qu' @OyyoDams a utilisé pour ses tests, elle dure 60 secondes. Pour les exemples, j'ai juste filmé les fins de la vidéo.

    • Vidéo 1 : RB version 18.04.20, ajout dans le fichier splash02 de la ligne "sleep 20" pour avoir une vidéo qui s’arrête à 40 secondes avec un fade : OK :
      https://youtu.be/RT51FGVTYQw

    • Vidéo 2 : RB version 18.06.27 ajout de la ligne "system.splash.length=>40" ou "system.splash.length=40" dans le fichier recalbox.conf du webmanager : la vidéo continue jusqu’à la fin et s’arrête d'un coup (je n'ai pas eu de secousse cette fois-ci) :
      https://youtu.be/zYD9IpgmUd8

    Si je met system.splash.length=0 la video s’arrête au bout de 20 secondes avec un fade comme prévu
    Si je met system.splash.length=-1 la vidéo s’arrête quand elle est finie, d'un coup, comme prévu

    Je constate que sur la version 18.06.27, changer la durée de la vidéo ne change rien et que la vidéo s’arrête d'un coup. Sur la version précédente la durée était prise en compte et la vidéo s’arrêtait avec un fade.

    Ma question est donc de savoir si, comme sur la version de RB precedente, il est possible de faire que la durée soit prise en compte et qu'il y est un fade. Ce n'est rien de nouveau, c'était déjà possible avant :)



  • @OyyoDams ,tu as eu le temps de faire un essai ?
    Dans le message au dessus j'ai essayé d'expliquer plus clairement le problème, j'espère que ça aidera :)


  • Moderator
    Moderator
    Team

    @gaetan not yet :)



  • @gaetan est-ce que ca marche si system.splash.length=38 ?

    Au passage, system.splash.length=>40 ne marchera jamais hein, ce n'est pas un test mais une attribution



  • Salut @substring

    "Au passage, system.splash.length=>40 ne marchera jamais hein, ce n'est pas un test mais une attribution"
    Merci, je ne savais pas :)

    Donc j'ai testé avec :

    • system.splash.length=38 > la vidéo s’arrête en fading au bout de 10/15 secondes

    • system.splash.length=05 > la vidéo s’arrête en fading au bout de 10/15 secondes donc même résultat

    pareil si je met system.splash.length=60 ou une autre valeur.

    Il semblerait que quelque soit la longueur attribuée, la vidéo s’arrête quand ES à fini de charger.



  • @gaetan exact, si es est chargé, on stoppe la video. Le moyen passe partout, c'est mettre -1 et il n'y aura pas de fading



  • @substring @OyyoDams
    J'ai trouvé le moyen de pouvoir changer la durée de la vidéo et d'avoir un fading comme avant.

    Pour cela j'ai noté dans recalbox.conf la ligne comme ça :

    system.splash.length=

    et j'ai édité le dossier splash02 de cette manière :

    while [[ ! -f "/tmp/emulationstation.ready" && ! -e "/var/run/kodi.msg" && $count -lt $videolength ]]; do
            sleep 40
    

    Donc "sleep 40" pour 40 secondes au lieu de "sleep 1" comme il est à l'origine.

    C'est dommage que cette option dans le recalbox.conf ne fonctionne pas, mais le principale est que maintenant ça marche.

    Du coup je pense que l'on peut marquer le sujet comme résolu :)



Want to support us ?

Join us on :

229
Online

28804
Users

14639
Topics

110672
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.