Black screen when exiting a game



  • My problem sounds very similar to this issue, which was apparently fixed recently.

    Black screen when leaving a game

    Specs are as follows:

    Raspberry Pi model: Pi 1
    Recalbox version (build) :18.04.20
    I'm running from a 4GB SD Card, with an external 32GB SD card for Roms
    Controller : Xbox 360 Wireless

    Symptoms:
    Fresh Boot (e.g. pull power out and wait for boot to finish)
    Start a Game, I have tried both Master System and Mega Drive
    Game plays fine
    Exit with either:
    Hotkey + Start
    Or
    Hotkey + A (Brings up a menu)
    Navigate to 'Quit Retroarch'

    Screen goes black.
    System does not respond at all to any button presses or hotkeys

    Has this issue been reintroduced? Or is this a new issue?
    Is it possible to download the previous version where this was fixed to try?

    Thanks



  • I tried editing the recalbox.conf file so it has this line

    global.videomode=default

    I now don't get a black screen, I just see the screen that is shown before the emulator starts running. Mostly black, with the Build number and date of the build at the bottom left, and then a recalbox log in the centre of the bottom.

    It just stays there forever with input not doing anything.



  • Go to the recalbox webmanager, help tab, and tell me if you have the "Stop EmulationStation" button.

    Most probably es crashed due to a lack of RAM



  • @substring Thanks for the reply.

    Actually I've not been able to get to the webmanager, or SSH to the box. Thats not one I've looked at as I've not needed it really, I can see the Pi on the network, it has an IP and actually my Mac can see it shared as recalbox, but can't connect through any means for some reason.

    If it is memory, is there any settings I can try tweaking to fix it?

    Thanks



  • @dizzy i'd say wait for next update for some fixed memory leaks



  • I have the same problem. I use raspberry pi 3, and I have checked that if I restart ES from web manager, it solves the problem, but it's not practical.

    Here is my "Launch recalbox-support.sh"
    https://file.ac/PJWUz0-tyRc/

    Thank you in advance.


  • Moderator
    Moderator
    Team

    @kels012 please install a legacy version of Recalbox, directly from our website. Your custom version is not handled by our support.


Log in to reply
 

Want to support us ?

Join us on :

222
Online

28808
Users

14640
Topics

110678
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.