Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Connection Manager generates empty resolv.conf at boot, breaks cheevos



  • Hi,

    I'm running recalbox 4.1 with manual IP settings. I've got them written in a custom.sh file using connmanctl commands as written in the wiki.

    My problem is that regardless of me manually editing /etc/resolv.conf with opendns nameservers then running ifdown eth0 && ifup eth0, the system will ignore this and rewrite an empty resolv.conf file, which I've noticed breaks retroachievements/cheevos support. It's a major nag to have to log into the system every time over SSH to fix this, so there must be a better solution that I haven't found. I've never used this connman thing so it's quite confusing, am I missing something?

    Thanks in advance.



  • @webodan we're all missing how dns resokution is made in such case. No gateway problems ?



  • @substring I've been trying some more, let me explain the problem better:

    Typing in /usr/bin/connmanctl config ethernet_b827ebba8c1e_cable --ipv4 manual [IP] [netmask] [gateway] --nameservers 208.67.222.222 TWICE through the command line works (one changes the ip and the second time seems to get the nameserver to resolve properly) works, but when i put it in my /etc/init.d/S99custom file after #!/bin/bash it seems to ignore the nameserver part, as it does assign the IP properly but it will not resolve.

    edit: i've just tried putting in that command twice in my file, with sleep 5s in between but nope, it doesn't care i have to ssh every time to get the nameserver to work. and the file is being run fine on boot because i put in a touch command just to make sure it wasn't my fault setting this up.

    so to recap: after rebooting my machine with the custom file written like this:

    #!/bin/bash
    /usr/bin/connmanctl config ethernet_b827ebba8c1e_cable --ipv4 manual [IP] [netmask] [gateway] --nameservers 208.67.222.222
    sleep 5s
    /usr/bin/connmanctl config ethernet_b827ebba8c1e_cable --ipv4 manual [IP] [netmask] [gateway] --nameservers 208.67.222.222

    ... breaks the nameserver, and SSHing into the machine (which has the IP address i gave it with connmanctl properly set, so it's not entirely ignoring me) then running nslookup google.com returns 127.0.0.1 as the nameserver (????????).

    oh yeah, and also, if i put the aforementioned command in the custom file just once it also doesn't work. that's why I started experimenting with maybe putting it twice.

    THEN over ssh if I run the conmanctl command that i've put in the custom file, that's when it resolves nslookup perfectly and the achievements work.

    i'm confused as fuck right now

    and yeah i kinda have gateway problems that's why i set everything manually, but everything i have works after i've set static ip addresses.



  • @webodan using static dhcp would be so less less less painful



Want to support us ?

299
Online

56021
Users

18246
Topics

137287
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.