Recalbox 7.0

No d-pad during emulation



  • I'm on the latest beta and I've tried, wired ps4, wired xbox one, and wireless 360 (Chinese adapter), and the d-pad doesn't work when playing games. It  works fine while in ES though. I've tested with the default xbox driver and the other one with no luck.   I thought retroarch had an option to map the d-pad (in 3.2.11) but I couldn't find it.   What am I doing wrong?



  • I don't know how intertwined retroarch and recalbox are but I found this thread while searching on the issue.   https://github.com/RetroPie/RetroPie-Setup/issues/805   Is this related to the issue I'm having?



  • Anyone? Is this issue only happening with me? Is this a known issue? Do I need to find a fix on my own?


  • Developer
    Global moderator
    Team

    Hi, that should be corrected in 3.3.0 beta



  • I guess I should have said this but I'm using 3.3 beta now. On 3.2.11 I didn't have the issue.



  • Hummm I'm using xbox360 wireless controlers + cheap chinese dongle too, and don't have any d-pad problem 😕 I can use the default driver (xpad) or the second one via recalbox.conf (xboxdrv) and no problems. Do you map your controler using the emulationstation option menu (start or enter with a keyboard) ?



  • I've tried mapping in ES and leaving it at the default setting. I'm updating to beta 9 right now so I'll check to see if I still have the issue.



  • Ok tell us, I really don't see why it is working for everyone and not you 😕



  • Ok after updating to beta 9 I now have two player capability! D-pads work on all controllers however...now analog doesn't work.



  • D-pads work on all controllers however…now analog doesn’t work. <- Ingame or EmulationStation ?



  • Neither in game or in ES. I can configure the controllers in ES and the analog is recognized but they have no effect in ES or in game (I've only tested snes using snes9x).



  • Humm in ES it is normal but not ingame. From which beta version did you update to beta 9 ? For information, the recalbox.conf file is not updated when you update your system (to keep your configuration, wifi, etc... after an update) but the file recalbox.conf.template, in the same directory, is upgraded. So can you compare the recalbox.conf.template and your recalbox.conf and check than every new options are presents in your recalbox.conf.



  • I updated from beta 8. In beta 8 I had a ton of controller issues. In 3.2.11 I could use both d-pad and analog while in game. In beta 8 only analog worked and only one controller worked. In beta 9, no analog but all controllers work and they work at the same time.



  • hummm it is really strange, because we didn't modified controlers/inputs management since beta 5. Did you try to switch on xboxdrv in your recalbox.conf



  • I have NOT tried the xbox driver in this beta. Keep in mind I'm also using a wired PS4 controller as well as a wired xbox one controller and wireless xbox 360 controller with knock off adapter.



  • Yes indeed you are using different controllers. But I can't explain why your xbox360 wireless controllers (I'm not talking about xbox one or ps4, I never tested them) don't work on your recalbox, and work fine for other people (me included).



  • I reran the controller setup in ES again and all is working fine now:D   Any idea of when 3.3 will be out of beta and if kodi will be updated?



  • Hello, good news 😃 About Kodi, nope the update is planned to the 3.3.1 version. We tried it rapidly, and the update has broken kodi in recalbox, so this require work...


Log in to reply
 

Want to support us ?

101
Online

79.1k
Users

20.3k
Topics

149.1k
Posts