Recalbox 7.0

daemon(startup script) not executing what ssh does



  • Hello, my custom start script doesnt execute correctly what my ssh does... its about rclone (uses rsync) and even though it does the infinite and execute the echo and the recallog, the rclone's commands don't, while executing the same file over ssh allows me to do so.
    My daemon script works because it calls the other script with the command.
    the script that the daemon calls:

    #!/bin/bash
    rclone copy /recalbox/share/saves/ gdmedia:rpi > /dev/null
    

    edit: I tried without !/bin/bash too


  • Banned

    @minze Hello minze think it would be better if you used one subject for all your questions regarding your script.

    For rclone, don't know it enough to help, sorry



  • @voljega well the other posts' main problem are solved, but as the main thing is not, I haven put [solved] in the title



  • @minze solved is added through topic tools, you can't edit the title.

    Regarding your problem : put the full path to the rclone binary at least. How have you demonized it ?



  • @substring About the rclone, I haven't, I added the full path for rclone and still doesn't work like it does on ssh. The script that calls rclone I have done chmod u+x and it's in /etc/init.d/
    Is there someway to see the actual recalbox terminal without having to exit emulationstation and/or from the pc?



  • @minze plug a keyboard on the pi, press F4 then ALT+F2



  • @substring Thanks to that I've found that on the daemon, it searched for one .conf on another place. Now I've solved and it's fully working without problem.
    If I have time, this weekend I'll make the tutorial for recalbox. If I do it, it'll be at least for GDrive, maybe for onedrive too (can't promise anything as it should be almost the same).



Want to support us ?

191
Online

79.1k
Users

20.3k
Topics

149.1k
Posts