Buttons are pressed without touching them!!



  • Hello i am new here. I have a major problem. My set up: Bartop arcade cabinet - raspberry pi3b - XinMo 2 player arcade controller (18 buttons) - recalbox. Everything was ok until yesterday when my nephew while playing pressed all buttons together many times. After that the buttons are pressed without touching them. I have the same problem if i use only keyboard with the xinmo unplugged. Please can someone help me.



  • @saver reinstall ? I have no darn idea about what else to do



  • @substring i have already done but nothing changed. Maybe the problem is raspberry pi. Can i reboot or reprogramme or something like that the pi? Otherwise i can't think where is the problem



  • I also tried another sd card with another image but again the same problem. On the pi i have only the screen hdmi cable the power supply and the keybord


  • Themer

    @saver it's likely you have some autofire button and/or combination of your buttons on your xinmo if such thing exists, and your nephew activated it, check the doc

    or your connections were crappy and by pressing a bit violently on the buttons, your nephew created a shortcut, check connections of your buttons



  • @voljega but i have the same problem with xinmo buttons unplugged. Only with the keybord. I also tried ps3 controler and again the same problem. I am desperate. Maybe i have to buy a brand new raspberry pi



  • @saver with a bluetooth PS3 pad you mean ?



  • @substring sorry ps1 usb controler not bluetooth



  • @saver so you have a mad usb uh ? Does the same happen if you unplug ecerything but power supply, hdmi, and you try raspbian ?



  • The problem is solved fortunately. I tried to connect the hole system with my tv screen via hdmi and everything was OK. So i replaced the hdmi cable of the cabinet with the tv hdmi cable and everythik work perfect. Although i don t think this was the problem. Thank you very much for your time.



  • How can i upload a video to show you the problem? I am desperate. I have tried everything. I have replaced all the parts of my setup but i have the same problem.



  • @saver run evtest for each input and see which one is doing that mess



  • @substring can you please give me directions how to run evtest because i m not so familiar with this. Thanks in advance



  • @saver ssh to your recalbox, type evtest, then test input 0 to see if there are some events happening by themselves with no user action. Press CTRL+C, try then with input 1 etc ...

    In the end, give me the name of the input(s) that had ghost inputs



  • @substring thank you very much but i need additional help. I run evtest then i press 0 and then i don t know what to do. How can i understand if some events are happening by themselves with no user action?



  • @saver they'd just pop after the description of known events the input reports



  • @substring i run evtest via putty and i took a photo to show you the results. I couldn t copy the text. How can i upload a photo please?



  • @saver said in Buttons are pressed without touching them!!:

    @substring i run evtest via putty and i took a photo to show you the results. I couldn t copy the text. How can i upload a photo please?

    https://postimg.cc/image/iaejz53yd/



  • @saver nothing happens after the "Testing..." You should try events 2 and 3. By tthe way, are you using the GPIO controllers as you have a xinmo ?



  • I got the same problem but only in Kody, with "Zero delay" arcade joystick



Want to support us ?

Join us on :

313
Online

29813
Users

14885
Topics

112122
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.