Probleme avec les overlays



  • Bonjour
    pour la pluspart ca marche : nes, psx, neogeo, megadrive mais

    Pour la snes, les jeux ne s'affichent pas pourtant j'entends le son.
    0_1520334718501_snes.png
    J'ai bien mon overlay mais pas le jeu ni acces a retroarch
    Dans WinSCP j'ai retiré l'overlay et j'ai de nouveau le jeu qui apparait.

    Pour la master system, je ne sais pas pourquoi mais c'est l'overlay de la megadrive qui s'affiche
    et dans les menus de retroarch, j'ai ça
    0_1520334788382_IMG_20180306_120132.jpg
    comment le modifier ?

    Merci



  • @Misaki salut, as-tu bien respecté à la lettre ces consignes? : https://github.com/recalbox/recalbox-os/wiki/Retroarch-setup-overlays-(FR)

    Ou as-tu enregistré des modifs via retroarch?



  • Bonjour akh150 et merci d'essayer de m'aider

    j'ai telechargé un fichier d'overlay "prêt a installer" que j'ai glissé dans ma recalbox via WinSCP.
    Puis j'ai mis mes propres overlays en remplacant juste le fichier .png

    j'imagine que ca s'enregistre sur le rpi



  • @Misaki ok.
    Donc en partant du principe que tu n'as rien enregistré via l'interface de retroarch (en faisant hotkey+b), et que donc, seuls les fichiers que tu as téléchargé posent problème, je vois deux hypothèses :

    • pour la snes, je pense que les valeurs des viewports sont pas bonnes. Et que l'image du jeu est trop décalée par rapport à ton écran.
      Dans ton fichier "snes.cfg" se trouvant dans \system\configs\retroarch essaye de mettre ces valeurs
      custom_viewport_x = "190"
      custom_viewport_y = "20"
      custom_viewport_width = "902"
      custom_viewport_height = "673"
      Adapte ces valeurs pour voir si quelque chose apparait à l'écran.
    • pour la master system, je pense que tu dois checker du coté du fichier "mastersystem.cfg" dans \system\configs\retroarch et \system\configs\retroarch\overlays et voir si les chemins pointent bien vers les bons fichiers cfg et png.

    Essaye et dis moi.



  • pour la snes, les jeux apparaissent bien en ayant enlever l'overlay donc les valeurs devraient etre bonnes non ?

    Voici des screenshots des menus dans retroarch de Video et Onscreen Overlay pour la snes si vous voyez quelquechose qui va pas :

    0_1520362763192_IMG_20180306_195241.jpg

    0_1520362772425_IMG_20180306_195227.jpg

    0_1520362780292_IMG_20180306_195231.jpg
    pour la master system, j'ai regardé et voici ce que je trouve :

    0_1520362063755_Sans titre 1.jpg
    0_1520362073672_Sans titre 2.jpg

    Et en fait si, je suis allé dans retroarch via select + B, pour adapter l'ecran a chaque overlay mais je n'avais pas de probleme et la snes marchait au début avec l'overlay.



  • @Misaki pour la mastersystem on dirait que t'as fait un "save core..." dans retroarch et il ne faut pas. Pour revenir à une conf normal faut supprimer un fichier, je me rappelle plus lequel et je peux pas checker ce soir.
    Perso j'ai déjà eu le pb de l'overlay visible sans le jeu et c'était juste une valeur erronée qui faisait carrément sortir le jeu de l'écran.

    Sinon, la solution classique est de tout reprendre à zéro en copiant tes fichiers téléchargés au fur et à mesure.


  • Moderator

    Question con @Misaki : le PNG de la SNES est bien transparent au milieu ?! Il ne semble pas l'être là...
    Non parce que le pack que tu as pris semble être fait à l'arrache. Erreur entre la MD et la MS, ça me surprendrait pas qu'ils aient oublié de virer le centre de la TV lol



  • Bonjour,

    @Fab2Ris

    En fait l'overlay c'est moi qui l'ai fait et j'ai procédé de la même manière que ceux qui marchent que j'ai fait également.

    En fait j'ai telechargé tout un dossier overlay que j'ai glissé dans retroarch via WinSCP mais pour remplacer les png par les miens.

    Comment faire pour la mastersystem puisque dans le fichier .cfg, il conduit bien au fichier mastersystem.png et pourtant dans les photos ci dessus il est enregistré qu'il va chercher les megadrive.png ?
    Je suis perdu



  • Bonjour,

    @akh150

    Oui j'ai fait un save core dans chaque console dont j'ai modifié le .png pour avoir l'overlay sur chaque jeu de chaque console.
    ca marche pour la pluspart des overlay par console pourtant.



  • @misaki le problème se situe là. Sur recalbox ça ne fonctionne absolument pas comme ça. Comme certains émulateurs partagent le même core c'est pour ça qu'en enregistrant le core il est partagé par les autres systèmes.
    Donc tes chemins sont bons, mais il faut revenir à la configuration core d'origine.
    Je vais chercher le fichier à supprimer et je te tiens au courant ce soir normalement.
    Pour la parenthèse, t'as du suivre un tuto vidéo, sûrement de Mikooz, mais le mieux et de lire le forum officiel et le wiki recalbox.



  • @akh150

    Rebonjour et merci.

    oui c'est possible pour Mikooz car je suis déjà allé sur sa page youtube.
    Ok j'attends alors.

    merci à toi et aux autres d'aider les novices comme moi.



  • @misaki c'est bon j'ai trouvé.
    Voici ce que dit @acris :
    "dans /recalbox/share/systems/retroarch/ tu as deux fichiers retroarchcustom.cfg et retroarchcustom.cfg.old
    sauvegarde le cfg sur ton pc, et le cfg.old puis reboot, de mémoire ce fichier va se recréer tout seul.
    et si ça ne fonctionne pas, utilise retroarchcustom.cfg.old en virant l extension .old et retransfere le."
    Je te mets le lien où apparaît cette discussion, ça pourrait t'aider : https://forum.recalbox.com/topic/9276/pb-reglage-overlay/19

    Quand tu te remettras à la configuration de tes overlays, n'enregistre rien dans le menu de l'émulateur, tout se fait dans les fichiers via winscp ou l'explorateur windows.



  • je viens de faire la manip mais aucun changement malheureusement


  • Moderator
    Team

    Saturation de la vram ? Utilises tu le theme recalbox ou un autre ?
    Si un autre remet celui de recalbox et reteste



  • Bonsoir acris,

    je viens de tester pour voir mais ce n'est pas ça le soucis apparement



  • Salut,

    j'ai enlevé tous le fichier overlay via WinSCP et recommancer à zero mais rien n'a changé

    Puis pour la snes, j'ai enlevé mon .png et mis le .png prévu par Mikooz. Le sien marche pourquoi pas le mien ? Pourquoi quand je met le mien, le menu retroarch ne s'affiche pas ?

    Pour la mastersystem, en laissant comme tel le fichier overlay de Mikooz, l'overlay affiché reste celui de la megadrive.
    alors j'ai modifié les .cfg de mastersystem et megadrive
    au final l'overlay de la mastersystem s'affiche bien mais du coup il s'affiche aussi pour la megadrive comme si les deux sega étaient liées en prenant pour base le megadrive.cfg

    j'ai rien réussi à régler du coup.
    j’espère être compréhensible

    merci



  • @Misaki je pense que tu dois avoir un fichier de conf qui traine et qui garde les mauvaises infos.
    Refais un install propre de recalbox, sauvegarde tes roms etc... avant, et si tu veux je te file mes fichiers d'overlays. Et par la suite, il faudra que tu modifies juste les infos "viewport" dans les fichiers cfg, et ne surtout rien enregister dans le menu retrorch.
    Je peux pas t'aider plus.


  • Moderator
    Team

    @misaki si tu suis le wiki pour les overlays, ils n'ont aucune chance de se mélanger parce qu'ils sont triés par système et non par core



  • @akh150 @Substring @Fab2Ris et @acris
    Merci tout les 4.

    J'ai pas eu le temps mais des que je peux je réinstalle et je reviens vers vous.



  • @akh150 @Substring @acris @Fab2Ris

    Bonjour,
    je reviens vers vous car j'ai réinstallé Recalbox.
    J'ai formaté ma carte SD et réinstallé la dernière version de Recalbox via Etcher sur ma carte SD.
    Mais malheureusement, l'overlays master system est toujours remplacé par celui de Megadrive et pour celui de la Snes rien a changé.

    Je n'ai rien modifié au niveau de ma clé USB qui contient les roms et le theme.

    Merci de votre aide


Log in to reply
 

Want to support us ?

Join us on :

272
Online

25550
Users

13367
Topics

101279
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.