Pi3 Won't Pick Up 18.02.09 Update



  • Hello!

    Wondering if there is any way to force an update on Recalbox. I rebooted it multiple times, tried to swap the config on / off for updating, rebooting the device every time to make sure the configuration stuck, but it won't pick up the update. I am currently on the 17.12.02 release trying to get to the new 18.02.09 one.

    Sample below of Update section on my config.

    ------------ G - UPDATES ------------

    Automatically check for updates at start (0,1)

    updates.enabled=1

    Update type : default to stable

    updates.type=stable

    I know it's reachable cause I can hit it from my local network, and Kodi picks up PLEX over the internet, so thats working too, connectivity-wise. I have rebooted my router and modem trying to cover all the basics, not sure what is going on, never had an issue with picking up updates before.

    Also, I have left this overnight to ensure there was enough time to pick up a broadcast of an update if that was the issue...

    Thank you in advance for your help!


  • Moderator
    Team

    @miso117 can you ping archive.recalbox.com from your recalbox ?



  • Sure thing:

    login as: root
    root@192.168.2.126's password:

    ping -c 10 archive.recalbox.com

    PING archive.recalbox.com (51.15.201.222): 56 data bytes
    64 bytes from 51.15.201.222: seq=0 ttl=50 time=104.398 ms
    64 bytes from 51.15.201.222: seq=1 ttl=50 time=124.659 ms
    64 bytes from 51.15.201.222: seq=2 ttl=50 time=120.038 ms
    64 bytes from 51.15.201.222: seq=3 ttl=50 time=107.741 ms
    64 bytes from 51.15.201.222: seq=4 ttl=50 time=115.546 ms
    64 bytes from 51.15.201.222: seq=5 ttl=50 time=110.360 ms
    64 bytes from 51.15.201.222: seq=6 ttl=50 time=105.998 ms
    64 bytes from 51.15.201.222: seq=7 ttl=50 time=110.762 ms
    64 bytes from 51.15.201.222: seq=8 ttl=50 time=107.920 ms
    64 bytes from 51.15.201.222: seq=9 ttl=50 time=117.864 ms

    --- archive.recalbox.com ping statistics ---
    10 packets transmitted, 10 packets received, 0% packet loss
    round-trip min/avg/max = 104.398/112.528/124.659 ms


  • Moderator
    Team

    @miso117 what about /recalbox/scripts/upgrade/recalbox-upgrade.sh canupgrade ?



  • I tried that via Putty now... Looks like something is happening, but Putty screen hung, Checking monitoring page, I can see something happening, I will leave it alone for a few and let you know. I backed up my roms folder in case I had to do a fresh install, worst case, I do that.

    I will let you know, you're a saint with these lighting fast replies <3


  • Moderator
    Team

    @miso117 it's supposed to be lighning fast. The manager is a dirty liar regarding cpu load, one core is always at 100% for an unknown reason



  • Recalbox on the TV doesn't show anything... Should I just reboot at this point?



  • Well well...

    Rebooted, re-SSH'd and I got this:

    login as: root
    root@192.168.2.126's password:

    /recalbox/scripts/upgrade/recalbox-upgrade.sh canupgrade

    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    curl: (60) SSL certificate problem: certificate is not yet valid
    More details here: https://curl.haxx.se/do



  • It appears that my date and time are very, very wrong on the PI.
    "# date Mon Dec 31 20:30:48 EST 1979"



  • Any reason why time would not be syncing? Thoughts? I never had an issue with it before.


  • Moderator
    Moderator
    Team

    @miso117 do you have a firewall (maybe on your box) that blocks ntp protocol ?



  • Not that I am aware of... And I don't think anything changed router-wise recently... Never had this issue before. What can I ping to test if it's being blocked?


  • Moderator
    Team

    @miso117 try 0.pool.ntp.org <hich is configured in Recalbox.

    Are you using a VPN somehow ?



  • No sir, no VPN.

    ping 0.pool.ntp.org

    PING 0.pool.ntp.org (162.210.110.4): 56 data bytes
    64 bytes from 162.210.110.4: seq=0 ttl=44 time=107.194 ms
    64 bytes from 162.210.110.4: seq=1 ttl=44 time=111.607 ms
    64 bytes from 162.210.110.4: seq=2 ttl=44 time=115.827 ms
    64 bytes from 162.210.110.4: seq=3 ttl=44 time=112.106 ms
    64 bytes from 162.210.110.4: seq=4 ttl=44 time=107.803 ms
    64 bytes from 162.210.110.4: seq=5 ttl=44 time=106.538 ms
    64 bytes from 162.210.110.4: seq=6 ttl=44 time=109.017 ms
    64 bytes from 162.210.110.4: seq=7 ttl=44 time=117.462 ms
    64 bytes from 162.210.110.4: seq=8 ttl=44 time=106.942 ms
    64 bytes from 162.210.110.4: seq=9 ttl=44 time=110.637 ms
    64 bytes from 162.210.110.4: seq=10 ttl=44 time=109.292 ms
    64 bytes from 162.210.110.4: seq=11 ttl=44 time=121.090 ms
    64 bytes from 162.210.110.4: seq=12 ttl=44 time=109.837 ms

    --- 0.pool.ntp.org ping statistics ---
    14 packets transmitted, 13 packets received, 7% packet loss
    round-trip min/avg/max = 106.538/111.180/121.090 ms

    looks like it is hitting it just fine.


  • Moderator
    Team

    @miso117 do you have a real recalbox and not some internet lousy image ?



  • I put the image directly on the SD card myself when 17.12.02 was released from the Recalbox site.


  • Moderator
    Moderator
    Team

    @miso117 can you connect with putty, and write:
    bash -x /recalbox/scripts/upgrade/recalbox-upgrade.sh canupgrade

    What's the result ?



  • looks like its hanging @

    login as: root
    root@192.168.2.126's password:

    bash -x /recalbox/scripts/upgrade/recalbox-upgrade.sh canupgrade

    • COMMAND=canupgrade
    • [[ -z canupgrade ]]
    • BINDIR=/recalbox/scripts/upgrade/
    • SYSTEMSETTINGS='python /usr/lib/python2.7/site-packages/configgen/settings/rec alboxSettings.pyc'
    • RECALBOX_SYSTEM_DIR=/recalbox/share/system
      ++ cat /recalbox/recalbox.version
    • INSTALLED_VERSION=17.12.02
      ++ cat /recalbox/recalbox.arch
    • ARCH=rpi3
      ++ python /usr/lib/python2.7/site-packages/configgen/settings/recalboxSettings.p yc -command load -key updates.type
    • UPGRADETYPE=stable
    • SERVICE_URL=https://recaleur-archive-prod.recalbox.com:9443
      ++ /recalbox/scripts/upgrade//../system/uuid.sh --uuid-file /recalbox/share/syst em/uuid
    • UUID=06ac36bf-6776-4102-bb73-773e11328db4
    • [[ stable == \b\e\t\a ]]
    • [[ stable == \u\n\s\t\a\b\l\e ]]
    • '[' canupgrade == canupgrade ']'
    • [[ stable == \s\t\a\b\l\e ]]
    • /recalbox/scripts/upgrade//recalbox-canupgrade.sh --from-version 17.12.02 --se rvice-url https://recaleur-archive-prod.recalbox.com:9443 --arch rpi3 --uuid 06a c36bf-6776-4102-bb73-773e11328db4
      % Total % Received % Xferd Average Speed


  • Putty sits there at % Total % Received % Xferd Average Speed - No blinking cursor, doesn't look like its doing anything...

    I have my ROMS folder pulled, I can just do a fresh image. No biggie... I can do that and let you know if I still see the weird date thing after.

    Let me know if you want to try to keep plugging at it or start fresh. I'm OK either way.

    <3


  • Moderator
    Team

    @miso117 you do have a problem somewhere ... As if port 9443 is locked. Let's force it another way :
    bash -x /recalbox/scripts/upgrade/recalbox-upgrade.sh upgrade

    Is it your first recalbox installation ?



Want to support us ?

Join us on :

308
Online

28074
Users

14385
Topics

108946
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.