Bandes noires sur certains émulateurs



  • Bonjour à tous,

    Je me permets de poster ce sujet, car après avoir fouillé un peu partout et essayé beaucoup de choses, je n’arrive pas à régler un problème.
    Pour vous dire le contexte rapidement, je viens de paramétrer un petit PC (un i5 7500) afin de m’en servir comme émulateur pour recalbox. Ce dernier est connecté à une TV 1080p par un câble HDMI (j’utilise le GPU du processeur) et j’ai installé sur un disque dur interne recalbox 4.1 (au passage merci pour ce petit bijou ).
    Tout fonctionne à merveille, hormis pour certains émulateurs où je n’arrive pas à enlever les bandes noires (en l’occurrence pour l’émulateur dreamcast, gamecube et n64).

    J’ai essayé de toucher aux options dans les menus en regardant sur les forums (option overscan, ratio de l’écran, pas de pixel perfect,…) et j’ai même commencé à modifier directement le fichier recalbox.conf.

    Pour le moment, la meilleure chose que j’ai trouvée est d’ajouté ces lignes de codes dans recalbox.conf :

    • global.videomode=CEA 16 HDMI (j’ai une télévision 1080p avec, si je ne me trompe pas, une résolution de 1920x1080 60Hz)
    • n64.videomode=CEA 1 HDMI (spécifique si j’ai bien compris pour l’émulateur n64)
    • global.ratio=16/9 (me permet d’avoir l’émulateur psx en plein écran)

    Sachant que

    • sur la wii et la psx j’ai dû plein écran,
    • le menu de emulstation est aussi en plein écran,
    • j’ai une vielle gamecube qui s’affiche en plein écran sur ma TV.

    Ma question est la suivante : est-il possible de faire mieux au niveau de la configuration pour éviter ces bandes noires ?

    Merci de votre aide précieuse



  • Sur une télé en 1080p et avec l'émulateur nintendo 64 j'ai également des bandes noires verticales et horizontales avec le réglage par defaut "n64.videomode=DMT 4 HDMI"
    Et c'est encore pire lorsque je passe au reglage "n64.videomode=DMT 9 HDMI". L'image est toute petite au milieu de la télé avec de grands bords noirs autour.

    En ce qui me concerne, le réglage qui m'offre une image au mieux est le mode ""n64.videomode=CEA 3 HDMI" (cf https://github.com/recalbox/recalbox-os/wiki/N64-retour-sous-ES-(FR) ) Dans ce mode, l'image rempli entièrement l'écran en 16/9. Elle est par contre légèrement coupé en haut et en bas mais ce n'est pas gênant.


  • Moderator
    Team

    @biboucover où sont les bandes noires ? Sur les côtés ? Tu sais que tout ce qu'on émule est à l'origine en 4/3, pas 16/9 ?


Log in to reply
 

Want to support us ?

Join us on :

219
Online

28111
Users

14403
Topics

109031
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.