N64 Black Screen



  • I'm pretty new to raspberry pi/recalbox, so I'm probably doing something wrong, but I can't get N64 games to play. I had no issue with other NES, SNES, or Sega Genesis, but when I try to start an N64 game, it briefly brings me to a black screen and then backs out to the games list. I tried looking at other peoples posts and tried to troubleshoot based off those recommendations but nothing seems to work. So far I've tried following the instructions at https://github.com/recalbox/recalbox-os/wiki/N64-%3A-return-to-ES-(EN). I ran the commands listed there and then ended up changing the recalbox.conf file by switching the n64 emulator setting from the default DMT 4 HDMI to n64.videomode=CEA 1 HDMI. Other suggestions mentioned making sure the controller settings had an L and R configured. It's basically the same as an original N64 Controller, except it connects with USB so I don't think that'd be the issue. Just in case, I went into the controller config and made sure. Still no luck.

    I'm not sure what all information is useful in troubleshooting this, so here's what I have:
    Pi Version:
    Raspberry Pi 3 (RPi3) Model B Quad-Core 1.2 GHz 1 GB RAM

    Controller:
    N64 USB Controller

    Output from the commands I ran on the Github link above:

    tvservice -m DMT

    Group DMT has 1 modes:
    mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive

    tvservice -m CEA

    Group CEA has 8 modes:
    mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
    mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
    mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
    (prefer) mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
    mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive
    mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive
    mode 34: 1920x1080 @ 30Hz 16:9, clock:74MHz progressive


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @kraethus it is probably related to your controller, but habe you tried this?
    https://forum.recalbox.com/topic/12223/n64-not-loading-games/2



  • @paradadf Yeah, I made sure all of the roms are unzipped.



  • @paradadf I have no idea how, but I just kept trying to launch the games hoping for the best and after about the 20th time now it works all of the sudden.


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @kraethus inexplicable things that make our life harder 😉



  • I'm facing exactly the same problem, do you have any clue what made it work for you? I also changed the aspect ratio in the config, but didnt not change anything "out of the box" beside that - only in the recalbox menu.

    Would love to hear your thoughts!

    Cheers,

    Yannic


Log in to reply
 

Want to support us ?

216
Online

81.4k
Users

22.2k
Topics

161.3k
Posts