Anyone have a SN30, Pro?



  • I have been having issues with pairing this controller.
    But the biggest problem is, after the controller is paired and working, when the Pi is restarted, the controller will pair/connect, but it doesn't work -- no input.

    It lists the device in bluetoothctl, and the controller indicates that it's connected, but I get nothing. Might there anything I can check to see why it's not sending input after the reboot?

    Also just wondering if I was not alone in this


  • Moderator
    Moderator
    Team

    @ignign0kt hey,

    Can you first take a look on this page and try again by reseting your pad first ?

    Then if it still doesn't work, please connect to the web interface of Recalbox with a browser, and in the last section, make a support archive ? Then paste the link here.

    Thanks.



  • @oyyodams hi, thanks
    The SN30 Pro does not have factory reset. Only a disconnect and force disconnect, and dedicating pairing button. I've removed and repaired it many times but the results are the same.

    I tried running the support script on the recalbox web console, but it throws an error: certificate is not yet valid

    I'm not sure what that means


  • Moderator
    Moderator
    Team

    @ignign0kt "certificate is not yet valid" means you may have a network issue, and the script is unable to upload the support archive on the server.

    Here is another -manual- way:

    1. You need to connect to Recalbox with a terminal
    2. Once connected write /recalbox/scripts/recalbox-support.sh and enter
    3. Go to the save folder of Recalbox, get the recalbox-support-****.tar.gz file, upload it somewhere, and then post it.


  • @OyyoDams
    https://nofile.io/f/D42mb5AjwQU/recalbox-support-19800101114625.tar.gz
    thanks!

    also, E4:17:D8:20:DF:DF the controller's address


  • Moderator
    Moderator
    Team

    @ignign0kt First of all, are you trying to mount an external USB key or hard drive ? Because it seems there is an is an issue, Recalbox can't mount this drive.



  • @oyyodams
    I don't think I've ever connected a USB drive to the Pi. Just a USB bluetooth dongle that I no longer use (don't think I've plugged that in for weeks)



  • I saw a reddit post recommending to use the Android mode on the SN30 Pro, and that seems to resolve my issue


  • Moderator
    Moderator
    Team

    @ignign0kt Good to see it's solved. Could you be kind to post the solution that solved your issue ?

    Also, I don"t understand why in your configuration sharedevice is on ANYEXTERNAL if you don't use any external USB drive. You should set it on INTERNAL.

    In the archive you've sent, I can't see any clue of your controller. That's why I had doubts about a drive issue.

    Anyway have fun :)


Log in to reply
 

Want to support us ?

Join us on :

234
Online

29907
Users

14909
Topics

112231
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.