Illegal command: IPXNET



  • Hi all,
    Trying to get IPX working on the latest version of Recalbox dosbox. Using a new Raspberry Pi 3.

    Here's what's worked so far:
    I've got latest version of dosbox on my PC. Configured it to use IPX by changing ipx=true in the PC's dosbox configuration. Works great - I can start two dosboxes on the PC, one as server and one as client, and play Doom multiplayer. So, I know Doom is working ok and that IPX is working on the PC version of dosbox.

    Now, when I copy Doom to the Recalbox, it fails. I added some pauses into the dosbox.bat so that I could see what was going on. I saw some "Illegal Command: IPXNET" errors after trying to start the server or client. So, I added a "dir z:" and a "pause" command at the beginning of dosbox.bat. IPXNET.com doesn't exist in Z:.

    I've tried several different things.

    1. Copied the default recalbox dosbox.conf in the server\config section (which looks very jumbled, not a lot of line breaks) to the DOOM.pc directory (and renamed to dosbox.cfg), and tried adding the following lines:
      [ipx]
      ipx=true

    2. Tried downloading the latest example dosbox.cfg from the recalbox site (which was much cleaner-looking), and added the same lines.
      [ipx]
      ipx=true

    3. All manner of edits to the dosbox.cfg file, trying to see if something was conflicting. Remarked out sections at a time and tested, no luck.

    4. Tried a second new Raspberry Pi 3 - same problems.

    I have network connectivity on the pi. I can copy files and and from it from my PC. I can access the internet (recently ran the latest update for Recalbox). Everything is working, but I can't get IPXNET.com to show up on z:.

    Is there some special configuration on dosbox for recalbox that I'm missing? Is something case-sensitive and I'm missing it or something? The one thing that seems odd to me is that I've had to add the [ipx] section to the recalbox config file, whereas the PC version had the section already included, with ipx orginally set to false. I don't see that on the Recalbox/dosbox.

    Any help would be greatly appreciated. I've been wrenching on this for a while...


  • Banned

    @Dragu maybe ?


  • Banned

    @voljega
    Sorry, I never tried this out. But IPX is as I know a TCP/IP emulation, so I doubt it will function under a linux system ?



  • Thanks to both of you. I've got a Ubuntu linux machine so I ran a test.

    1. Installed dosbox with default configuration. Started it - when I typed "dir z:", there was no IPXNET.com file.
    2. Modified the config, changing ipx=false to ipx=true
      3_ Restarted dosbox, ran the "dir z:" command, and the IPXNET.com file was now there.

    So, I can get it to work on Windows and Linux, but not on the Recalbox... I did quite a bit of web searching looking for similar problems, but couldn't find any solutions - a couple of sites had examples where people hadn't edited the config file, which I've already done.

    Again, it's strange to me that the recalbox default dosbox.conf file looks jumbled with no mention of IPX in the file.... I'm sure a lot of people are using Recalbox dosbox for multi-player LAN games over IPX - so I'm guessing that's normal...?


  • Banned

    @jimmc
    @voljega
    The command set just dont exist in our recalbox dosbox installation. It seems to me that we have included version 0.65 ? Should it not be time to include 0.74, what is rather old anyway ?



  • @dragu @voljega I think that is an excellent idea! Does this post serve as the request, or would I need to request it in some other way?


  • Revisor

    The IPX support of DosBox is optional.

    I think that the problem is that DosBox doesn't include SDL2_net at the compilation.


  • Banned

    @dragu I thought it was 0.74 in Recalbox already ? the original dosbox.conf you found in the file refer to mapper file containing 0.74 in its name


  • Revisor

    Yes, it is 0.74 (and even more ... because also contains "unstable" features)



  • This post is deleted!

  • Banned

    @lmerckx so ideally would it be possible to add IPX support through SDL2_net like you said ?


  • Revisor

    I will try ... next week.



  • @lmerckx Hi there, just thought I would see if you had success with it?


  • Revisor

    @jimmc Yes, indeed. I successfully played Doom in network (Recalbox vs my PC).

    This modification should be available in the next version of Recalbox, I suppose.

    You can find more information in the dedicated issue: https://gitlab.com/recalbox/recalbox/issues/311



  • @lmerckx Great news! Thank you very much! I look forward to configuring several games to use this feature. Thank you again!



  • @lmerckx I don't know if this would be helpful in the forum or not. And if so, maybe it should be a separate posting. But during my testing on a PC, I created this batch file which allows everyone joining a game to select which one will be the server, and then multiple clients can connect to that server as clients. I used a DOS utility called ask.com to get the Y/N answer, and then a DOS utility called answer.com to ask for an IP address.

    If you are going to change the port used to something other default, can you let me know? That way, I should be able to mix and match players from recalbox, windows dosbox, linux dosbox, etc.

    Thanks again for the help!

    @echo off
    😄
    cd\doom
    ask "Start network game? Y/N"
    if errorlevel 1 goto solo

    ask "Start as server? Y/N"
    if errorlevel 1 goto client

    :server
    ipxnet startserver
    setup
    goto end

    :solo
    doom
    goto end

    :client
    echo Enter IP address of server:
    answer
    echo.
    echo You entered an answer of %ANSWER%
    pause
    ipxnet connect %ANSWER%
    setup
    goto end

    :end


  • Revisor

    @jimmc I haven't changed the port in DosBox, but the ipxnet command requested me one.

    I used:
    ipxnet startserver 6969
    and
    ipxnet connect <server> 6969

    I had an error without the port. Perhaps the default one was used.
    I haven't checked further, in fact.


  • Revisor

    For more information on this modification, check here:
    https://forum.recalbox.com/topic/12481/testers-wanted-dosbox-update


Log in to reply
 

Want to support us ?

220
Online

81.5k
Users

22.3k
Topics

161.7k
Posts