Logitech F710 doesn't work in PS1 Super Robot War

  • I use Logitech F710 to play games in Recalbox, it always works great except any Super Robot Wars games on PS1. No matter SRW-F, SRW-Alpha...etc. None of them work.

    I already had use my F710 on playing lots of games of NES, SNES, GameBoy. Also played Castlevania-X of PS1. The F710 gamepad works perfect so far.

    I tried several different (PS1) SRW roms, Recalbox loads those roms smoothly and shows game title.(which screen ask player to 'PRESS START BUTTON'). In that screen, it is likely the game doesn't accept any input event(I tried both of XInput and DirectInput mode of F710). However I can still press Hotkey-B to toggle Retroarch-Menu and control cursor normally.

    It is pretty weird to me that my game-pad only not work in any SRW games.

    Since I don't have other gamepad yet, I am not sure whether this problem happens to F710 only or not.

    System: Recalbox 4.0.0
    Hardware: Raspberry Pi 3

  • Staff
    Global moderator

    Go to retroarch menu (hotkey+b) and in controls try analog stick or pad

  • Hi,

    Thanks for your reply!

    I tried: Quick Menu / Controls / User 1 Device Type.
    'None', 'RetroPad', 'RetroPad w/ Analog', none of them works.

  • I also tried another settings NOW IT WORKS!

    Retroarch Menu / Quick Menu / Options / Pad 1 Type -> change to 'standard', then it start working!

    Thank you arcis!

  • Staff
    Global moderator

    Good. Have fun

Want to support us ?