Compatibilité Hifiberry AMP+



  • Bonjour,

    je voudrais avoir un renseignement, est ce que recalbox est compatible avec une carte HIFIBERRY AMP+. Je sais que la compatibilité avec une carte DAC est avérée mais je n'ai pas trouvé de matière pour une carte AMP+.
    De plus, est ce que la configuration est la même que pour une carte DAC ?

    Merci d'avance,
    Florian



  • @fl0o1osmoz Salut,

    Il y a de grandes chances que oui. On a une petite vigilence malgré tout qui sera résolue quand on mettra à jour le kernel. Mais pas de raison que ce ne soit pas compatible



  • @substring Merci de ta rapidité, quand la MAJ du kernel est elle prévue ? au cas où 🙂



  • @fl0o1osmoz On a 2 évlutions majeures à faire, ca sera la 2e. Je doute que ce soit fait avant Noël. Mais comme je t'ai aussi dit : aucune raison que ca ne marche pas. Si ca ne marche pas, tu me ping ici et je te dirai quoi faire. On a eu le pb avec une carte DAC+ qui ne marchait pas en 4.1 alors que la mienne passait impec -> problème résolu en récupérant un driver plus ancien en attendant la pleine compatibilité out of the box. Donc si ca ne marche pas, cette solution devrait marcher pour toi aussi.



  • @substring Merci. De toute façon mon projet est en cours d'élaboration, j'achète le matos pour le moment donc la réalisation se fera vers mi-décembre au plus tôt.



  • @substring said in Compatibilité Hifiberry AMP+:

    @fl0o1osmoz On a 2 évlutions majeures à faire, ca sera la 2e. Je doute que ce soit fait avant Noël. Mais comme je t'ai aussi dit : aucune raison que ca ne marche pas. Si ca ne marche pas, tu me ping ici et je te dirai quoi faire. On a eu le pb avec une carte DAC+ qui ne marchait pas en 4.1 alors que la mienne passait impec -> problème résolu en récupérant un driver plus ancien en attendant la pleine compatibilité out of the box. Donc si ca ne marche pas, cette solution devrait marcher pour toi aussi.

    Salut, j'ai acheté le matos et je suis en train de configurer le rpi3. Il y a effectivement un soucis.
    Lors du premier démarrage j'ai modifié le fichier de config comme indiqué dans la doc hifiberry et aussi comme dans la doc recalbox et j'ai testé les différentes manipulations trouvées sur les supports mais rien ne fonctionne.
    La led verte du hifiberry ne s'allume plus.
    J'ai vu qu'il fallait prendre la version de mars ou alors prendre les drivers hifiberry qui étaient dispos en mars, mais je ne vois pas trop où trouver ça, j'ai regardé sur git mais ça ne me semble pas être ça car le commit est d'avril.

    Merci d'avance 😉


  • Banned

    @fl0o1osmoz
    Salut, il faut regarder dans
    https://forum.recalbox.com/topic/9368/no-more-sound-after-installing-v-4-1-in-recalbox/124
    ou est mention de "hifiberry-dacplus.dtbo ou hifiberry-amp.dtbo", driver qu'il faut récupérer sur l'ancienne version instable4.1 de mars.
    les driver sont ici :
    https://github.com/raspberrypi/firmware/tree/b4b1f641ba1290bdf275b99922e16c0194a8e54b/boot/overlays



  • @Dragu Merci beaucoup.
    Petite précision, pour remplacer les .dtbo je peux copier coller le fichier dans le repertoire boot/overlays et remplacer l'ancien avec winscp ou il faut le faire par une commande d'update spécifique ? et apres reboot je présume.
    Dernière précision, est-ce qu'il faut commenter la ligne dtparam=audio=on (dans la conf)? car quand elle est commentée kodi ne se lance plus pour moi.



  • @fl0o1osmoz il faut penser à mount -o remount,rw /boot avant de copier quoique ce soit. Pour Kodi : il refuse reuse peut-être de se lancer par abdence de carte son ?



  • @substring Je viens de faire le test sur une nouvelle install.
    De base dans les option audio de l'interface j'ai bien ma carte hifiberry qui s'affiche ou plus precisement le nom de toutes les cartes. De plus mon Hifiberry est allumé avec une led verte à cette étape mais pas de son sur mon enceinte et son sur le hdmi (televiseur).

    • J'ai dans un premier temps copié les fichiers dtbo.
    • reboot du raspberry. (toujours led verte)
    • Ensuite j'ai modifié le fichier de config comme expliqué dans les docs (ajout de la ligne dtoverlay=hifiberry-amp et commenter la ligne dtparam=audio=on)
    • puis j'ai créé le fichier asound.conf
    • reboot (pas de led verte)
      et dans les options du son il n'y a plus le choix de la carte hifiberry. juste "auto,jack,hdmi"

    Est ce que je dois faire les étapes dans le fichier de config et le fichier asound ?

    Merci d'avance



  • @fl0o1osmoz si la led est verte, rien à changer, juste sélectionner la carte dans es



  • @substring je vais repartir d'une config de base, est ce que tu peux me dire ce qu'est "es" (emulationstation?)? c'est le menu du son dans recalbox ?



  • @fl0o1osmoz oui cnest emulationstation. Et oui bouton start > options son et tu sélectionnes la hifiberry qui doit apparaître



  • @substring C'est pas zarb que le fichier de config ne soit pas modifié du coup ? il faut que je passe par alamixer en ligne de commande pour augmenter le volume et voir si mes enceintes fonctionnes du coup ?
    Par contre, je démarre du menu de recalbox -> je fait f4 et je bascule en ligne de commande -> je modifie le son dans alamixer -> je retourne sur le terminal. Comment je retourne sur recalbox sans reboot et perdre ma config ?



  • @Substring @Dragu Merci à vous 2, en fait dès l'install il n'y a rien à faire il faut juste modifier le volume dans alamixer avec la commande "amixer sset Digital -- -30dB" par exemple. Un grand merci pour la modification apportée au système pour prendre en charge les cartes et sorry pour le dérangement.
    Il me reste juste à faire un script à lancer au boot pour augmenter le volume.


  • Banned

    @fl0o1osmoz
    Tout ce que je sais, c'est @Substring.
    j'avais aussi pas de son avec led verte. Il m'avait dis de lancer TERM=xterm alsamixer et j'ai mis le son à 100%, puisque j'ai un ampli avec regulation volume derrière. Donc pas besoin de script.



Want to support us ?

253
Online

81.5k
Users

22.3k
Topics

161.6k
Posts