[Odroid UX4] probleme d'affichage



  • Bonjour a tous, je fini mon premier bartop et j'ai beaucoup de mal avec l'affichage des jeux et même de l'interface recalbox en général car l'image est décalé du centre.
    J'ai constamment une bar noir a gauche et mon jeux couper a droite.
    J'ai testé avec un écran led 22p, un écran pc 19P (wide 16/10) et un écran 19P (5/4) mais toujours le même résultat .
    J'ai aussi testé de modifier le "overscan" en ssh mais je stop sur (#) ....
    Mon matos: recalbox4.1, Odroid xu4
    Merci a vous



  • @anthony56 personne pour me venir en aide ? je pige vraiment pas -_-



  • @anthony56 quelle est la résolution de ton moniteur ? Est-ce qu'il est 1080p ou pas ? sinon faut lire le /boot/boot.ini pour choisir la bone résolution



  • Salut et merci pour le coup de mains, c'est un écran de pc non 1080p et la résolution est de 1440/900 . Branchement avec adaptateur hdmi coté xu4 et vga coté écran .



  • @anthony56 Oui donc exactement ce que je t'ai dit : il faut trifouiller dans le /boot/boot.ini, comme pour le Ubuntu de Hardkernel.



  • @Substring, vraiment désolé .. mais je ne comprend pas (boot,boot.ini) et le reset ^^ .
    Il n'y a pasplus simple?



  • @anthony56 non il n'y a pas plus simple. Il faut toucher au fichier de configuration qui détermine notamment en quelle résolution le XU4 boote vu qu'il ne gère pas les EDID (en tout cas dans notre version, je ne sais pas ce que ca vaut sur un kernel plus récent)



  • @Substring ok je commence a comprendre ! Le boot.ini je le chope en ssh ? Ou je peut le modifier autrement ?je vais testé ça dans 15-20min



  • @Substring je me suis connecter en ssh et j'ai ça : tvservice -m
    [
    { "code":1, "width":1920, "height":1080 } ??



  • @anthony56 non tvservice est une commande pour pi qu'on a simulée à minima sur pi pour éviter que ca pète de partout



  • En bidouillant c'est mieux... mais pas top top 0_1511205156136_received_10215049075364396.jpeg une solution svp ??



  • Toujours le même décalage même au lancement de recalbox ... je désespère🤕
    0_1511207128606_received_10215049377451948.jpeg



  • tu as regardé le fichier dont je te parle ?



  • Salut, @Substring, effectivement j'ai chercher mais je ne sais pas ou il se trouve.
    J'ai suivie plusieurs piste sur le fofo, mais en ssh avec puty je bloque au niveaux de «#», on me dit d'appuyer sur shift au démarrage de recalbox mais ça ne fonctionne pas .
    Dernière tentative avec f4 dans recalbox mais ca ne fonctionne pas également... si tu as une manip pour trouver le fichier je suis preneur. Merci



  • @anthony56 bon mes plates excuses, j'ai confondu le XU4 et le C2. Il faut que je cherche pour le XU4



  • @Substring no problemo je t'attend!!



  • @anthony56 bon ... au secours la doc ... https://wiki.odroid.com/odroid-xu4/troubleshooting/how_to_change_resolution qu pointe sur https://github.com/mdrjr/5422_bootini/blob/master/boot.ini

    Dégrossissons (en espérant que ca marchera): il faut que tu ajoutes une ligne genre setenv videoconfig "drm_kms_helper.edid_firmware=edid/1440x900.bin"dans /boot/boot.ini. Et oui, j ete vois venir d'ici "mais ma résolution n'y est pas" ... Je sais ... je sais ... pas moi qui décide :/



  • @Substring Okok donc la c'est plus une modif recalbox mais bien une modif odroid, je comprend ! Par contre ... je ne sais pas comment avoir le boot.ini



  • ok !...@Substring je viens de trouver le boot.ini

    ODROIDXU-UBOOT-CONFIG

    U-Boot Parameters (DO NOT MODIFY)

    setenv version 3.10
    setenv zimage zImage
    setenv fdtbin exynos5422-odroidxu3.dtb

    setenv zimage_addr_r 0x40008000
    setenv fdtbin_addr_r 0x44000000

    setenv fdt_high "0xffffffff"

    Default boot argument

    setenv bootrootfs "root=/dev/mmcblk0p2 rootwait ro"
    setenv console "console=ttySAC2,115200n8 consoleblank=0 vt.global_cursor_default=0"

    setenv bootargs "${bootrootfs} ${console}"

    boot commands

    fatload mmc 0:1 ${zimage_addr_r} ${zimage}
    fatload mmc 0:1 ${fdtbin_addr_r} ${fdtbin}
    bootz ${zimage_addr_r} - ${fdtbin_addr_r}"



  • @Anthony56 Problème résolu pour moi, en éditant le boot.ini :)


Log in to reply
 

Want to support us ?

Join us on :

551
Online

28843
Users

14649
Topics

110718
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.