Can't play any game in ADVMAME



  • Hi, I'm looking for some help and hopes that someone could help me.
    I have 3 sd cards w/ recalbox 4.1 two of then was made a fresh install but in none of the 3 sd cards I can play a game using Advance Mame as emulator.
    After choosing a game configurated to use advance mame as emulator my controller simply doesn't work, not a single button even using a keyboard nothing works, and I can't exit the game too, I have pressed all the keys on the keyboard but nothing happens.
    I tried with Xbox 360 controller, PS4 Hori Mini Fight Stick, GPIO, all configured thru the control menu but it was in vain,it doesn't work.
    Everything else works, all systems, all games.
    Somebody knows what could be causing this and what should I do to resolve?

    PS: Attaching the system log
    https://file.ac/CvMNhk0G9Cg/


  • Moderator
    Team

    @DJC Hello

    advance Mame require romset mame 0.106, have you ?
    Have you swith mame emulator to advance mame in Emulationstation Menu (game options) ?



  • @acris Yes I have made all of this.
    The game runs but the controller simply don't work even the keyboard.


  • Moderator
    Team

    Which game ?



  • I have tried 5 games.
    Daraku Tenshi
    The others I don't remember now.



  • @djc is it your x360 pad the only one that is plugged ?



  • @substring I have tried with 1 and 2 pads plugged.



  • I can confirm this is an issue. I attempted to load Terminator 2 Judgement Day with ADVMAME selected as the emulator for that particular game and it loads the game but then neither controller 1 or 2 work with buttons. You can see the "calibration" working on the X/Y axis for both controller but no buttons are mapped, you cannot HOME+Start out of the game either.

    If you go back and change to default for Emulator it works just fine (assuming its defaulting to Liberto)

    RPI2 - Latest 11/17 build.



  • @DJC @miso117 i need your support archives







  • @DJC @miso117

    Dareku worked fine for me, but T2, got the same problem. The wierd thing is that it onle happened with 2 players, the configuration worked fine for 1 player (but i got stuck at the P2 calibration). The weirdest is that pressing start brings the advancemame menu :s



  • ok, looks like daraku with 2 players has the same problem, i'll dig deeper



  • OK, looks like I have to rewrite the configgen for advmame https://gitlab.com/recalbox/recalbox-configgen/issues/142



  • @substring Thank you and sorry for not replying sooner.
    What exactly does it mean to rewrite the configgen to adv mame?
    If I understand you will make a new configuration file? If it is the case is it necessary to download this file and copy it to a folder or will it be necessary to wait for a new update?



  • @djc configgen = configuration generator. It gets information from ES (which pads are plugged, player order and a few more things) and configures emulators according to your current situation. Obviously something changed some time ago in the way advancemame handles pad numbering. I hope it won't give any problem to player ordering :/

    So, I have to rewrite the configgen for advancemame. Not much though, but it now requires some information we never used so far.



  • @substring Any News?



  • @djc no time to spend on that for now



  • Any update on this? I have the same controller issue. Thanks.



  • @jwmymy advancemame problem that i can't fix.


Log in to reply
 

Want to support us ?

Join us on :

192
Online

31080
Users

15117
Topics

113744
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.