[MD SNES ALL] Problème de son et sauvegarde



  • Bonjour à tous et à toutes,
    J'aimerai vous faire part d'un soucis qui peut paraître anodin mais qui me gêne sur mes parties.
    C'est au niveau du son dans tous les jeux ( megadrive et snes en particulier) où la musique du jeu se coupe sur de très courts moments, et les effets sonores sont transformés en bouillie inaudible. J'ai une megadrive chez moi ce qui me permet de comparer les sons et cela n'a rien à voir avec ceux de l'émulateur.

    J'ai également un soucis avec le système de sauvegardes, rien ne reste en mémoire, que ce soit les sauvegardes en jeu ou les statistiques ( nombre de fois où j'ai lancé le jeu par exemple).
    Les jeux freezent et ralentissent également, j'ai overclocké en High et ça à l'air de moins ralentir. Puis-je overclocker plus ou cela peut être dangereux ou inutile ?
    Je possède un raspberry pi 3 avec son boîtier et ses dissipateurs, une carte sd 16 go classe 10, la deniere version de recalbox ( à jour le 14 nov.). Le raspberry est branché via HDMI sur ma tv et le son est retransmis sur une barre de son via Jack. Je n'ai pas de pièces supplémentaires implémentées sur le raspberry.

    Merci pour votre aide !
    Enki



  • @Enki-Tomalak

    Tu sembles avoir un problème d'alimentation. Ralentissement sur des jeux SNES, le son coupe sur de très courts moments, je vis ça moi-même en ce moment sur mon Raspberry Pi 3. J'ai changé mon bloc d'alimentation et l'éclair jaune dans EmulationStation a disparu + les ralentissements + le son coupé, tout était réglé ! Tu peux aussi essayer de brancher ton alimentation directement dans la prise murale et ne pas passer par une barre de surtension (power bar).

    Étrangement, c'est un vieux bloc d'alimentation d'un téléphone Samsung (5V - 0.7 Amp) qui fonctionne le mieux chez moi, davantage que celui de 2 ampères que j'ai eu avec mon Raspberry Pi 3.

    patriccote



  • Merci pour ta réponse, mais je tiens à préciser que lorsque les effets sonores ( sauts, teleportations par exemple) sont '' en bouillie'' la musique ne l'est pas ! Je rentre chez moi et je teste avec un autre secteur



  • J'ai changé de bloc d’alimentation, je n'ai plus de ralentissements mais les bruitages sont toujours horribles à entendre (pas naturels, grésillements) une solution ? Il arrive parfois que les sons passent au dessus de la musique, comme sur des processeurs 8 bits ( gerer le son et la musique en meme temps )
    Peut être une configuration à apporter à picodrive ?


  • Themer

    @enki-tomalak si tu es branché sur le jack du raspberry pas la peine de chercher plus loin : c'est de la merde !
    Récupère le son sur la télé par l'hdmi



  • @voljega said in [MD SNES ALL] Problème de son et sauvegarde:

    @enki-tomalak si tu es branché sur le jack du raspberry pas la peine de chercher plus loin : c'est de la merde !
    Récupère le son sur la télé par l'hdmi

    Je suis en HDMI, branché sur la TV puis de TV je suis en jack vers ma barre de son


  • Themer

    @enki-tomalak mert' c'est pas ça alors



  • Voici un exemple concret :
    le son original : https://youtu.be/yS-F0UFezFA?t=224
    le son sur mon émulateur : https://youtu.be/ENZbwFQuXFM

    Bien évidement c'est le cas pour plusieurs sons sur différents jeux


  • Moderator
    Team

    @Enki-Tomalak
    essaie sans la barre de son avec le son de la tv directement
    Changer de core aussi peut aider.



  • @voljega said in [MD SNES ALL] Problème de son et sauvegarde:

    ché sur le jack du raspberry pas la peine de chercher plus loin : c'est de la merde !
    Récupère le son sur la télé par l'hdmi

    Tu vas (très) vite en besogne.

    Sur l'un de mes PI3 j'ai soudé un câble au niveau des pp6/25/26 (gauche, droite, terre)
    --> au bout de ce câble j'ai soudé une prise jack femelle récupérée sur un vieux PC portable
    ----> dessus, j'ai branché une rallonge jack --> vers une enceinte XIAOMI

    le son est impec. Pourtant, soudure sur soudure, récup, rallonge etc...

    J'ai un 2nd PI (un RPI2) branché en jack aussi, le son est impec.


  • Themer

    @unik314r donc ton premier truc n'est même pas branché sur la prise jack a priori déjà...

    Après c'e problème est évoqué sur tous les sites raspberry & co mais bon tu fais ce que tu veux.



  • @voljega said in [MD SNES ALL] Problème de son et sauvegarde:

    @unik314r donc ton premier truc n'est même pas branché sur la prise jack a priori déjà...

    Allez, admettons pour ce PI3...
    Cela dit, ça n'enlève rien au fait que sur mon PI2, pas de pb.
    Et (j'oubliais) sur mon 2nd PI3 (dans un bartop, enceintes USB/jack à 10€ directement branchées en jack) pas de pb non plus...

    Après c'e problème est évoqué sur tous les sites raspberry & co

    Et bien laisse moi jouir du bonheur d'être l'un des rares à ne pas avoir ce pb :D

    mais bon tu fais ce que tu veux.

    :D ce que je veux? ... euh rien à voir ici avec une quelconque volonté: je parlais de ce que je remarquais sur mes machines...

    Voljega, c'était un simple retour d'expérience. Que cela ne te convienne pas, pourquoi pas, après tout ce n'est pas mon problème.

    Mais ça ne devrait pas t'empêcher de rester courtois.



  • Merci pour vos réponses mais peut on revenir sur ma question ? Je suis en hdmi donc pas de problèmes avec le Jack 😁
    Comment fonctionne cette histoire de core ? A quoi sert-il ?



  • @enki-tomalak Tu as raison ;)

    le CORE d'un système = le programme utilisé pour faire tourner l'émulation.
    Changer ce programme a une certaine influence sur les jeux.
    Je te conseille cette vidéo https://youtu.be/GJDc_q3Elzw?t=15m28s


  • Moderator
    Team

    @Enki-Tomalak
    Selectionne ton jeu
    Puis bouton select
    Choisir editer les donnees du jeu.
    Mettre emulateur : libretro
    Changer le core

    @unik314r
    Il est rapporté partout que le jack sur rpi est de qualité tres mediocre qui se traduit pas des gresillements, souffle etc...
    Et il faut s attendre à des miracles non plus.



  • Merci pour vos réponses, je vous tiens au jus dès que je finis le boulot ☺️



  • Le changement de core a fonctionné ! je vous remercie pour vos réponses

    Bonne soirée !



Want to support us ?

Join us on :

238
Online

28885
Users

14657
Topics

110791
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.