PPSSPP Games load with sound but no video?



  • Just got into recalbox and trying out it's PPSSPP emulator. Tried a few games, such as Metal Slug Anthology, and with each one the screen goes blank upon gameplay. The sound is there and it sounds like i can control my character and do stuff just fine but, there is no video. Just black screen. I did some searching around and saw that this is a common issue but, saw no solutions for it. Anybody? Any help would be appreciated.



  • @skullgrin Hi
    What screen do you have ?



  • @substring No screen. It's blank.



  • @skullgrin I asked "what screen do you have" (i.e own) not "what happens on your screen" ;)



  • @substring You mean, what kind of display set-up am i using? I'm using a Proscsan LCD(LED?) HDTV.

    Again, the menus and cinematics seem to run fine. But when actual gameplay starts, the screen goes blank. I can still hear music and can control my character, and the game sounds like it's running well. I just can't see anything.



  • @skullgrin yeah display hehehe sorry ;)
    Well PPSSPP has nothing special regarding display. Are you using a vanilla Recalbox install ? Default theme ?



  • @substring I'm just using the latest, stock version of Recalbox. Which i believe is 4.1. Also default theme, as i have not learned how to add themes yet.



  • @skullgrin is your Pi overclocked ?



  • @substring Nope. Everything stock with stock Recablbox and default PPSSPP settings. The game sounds like it's working fine but, gameplay has no picture. It's like the video output just switches off the moment gameplay starts.



  • @skullgrin not normal at all ... Do you feel like you could edit a file on your Recalbox through commandline ?



  • @substring What would that do? And i don't know how to even access commandline though recalbox.



  • @skullgrin there are wiki entries that explain it



  • @substring
    Hi, you pointed me here from my thread https://forum.recalbox.com/topic/10554/psp-on-4-1-only-works-with-a-monitor-not-tv

    I can edit stuff through commandline, just tell me what to do / try



  • @fuzzy3000 so :

    mount -o remount, rw /
    rm /usr/lib/python2.7/site-packages/configgen/generators/ppsspp/ppssppGenerator.pyc
    nano /usr/lib/python2.7/site-packages/configgen/generators/ppsspp/ppssppGenerator.py
    

    last line, increase delay=1 to delay=2. Don't reboot, just try straight from ES a PSP iso.



  • @substring
    nope, unfortunately still takes me back to ES
    I actually don't think that me and op have the same problem, he at least has sound, in my case it just takes me back to es, nothing loads at all except when im using a monitor. Does the psp emulator use a special resolution or default 640x480? Thx



  • @fuzzy3000 it uses the default 720p



  • @substring Ok so i guess it turns out to be bad rom compatibility on PPSSPP's part. The whole time i was only trying out (1) game: Metal Slug Anthology. But when i finally tried other games (like Metal Slug XX and Capcom Classics collection), they seem to run great. I even tried multiple versions of MSAnthlogy to get it working, like European and Japan releases. Same thing. I only get sound and and no picture when gameplay starts.

    Anyone else have this problem when trying to run this game??



  • @skullgrin i know that ultimate ghouls'n'ghosts is pretty badly emulated for instance


Log in to reply
 

Want to support us ?

Join us on :

645
Online

30882
Users

15088
Topics

113605
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.