Recalbox et écran DVI 5/4 HYUNDAI X93S



  • Bonjour,

    Je me permet de vous adresser ce message suite a mon impossibilité de changer la résolution native de ma recalbox v4.02 pour la prise en charge sur mon ecran de bartop model Hyundai X93S en DVI.
    J'utilise un cable HDMI et adaptateur HDMI vers DVI.

    J'ai modifié le "hdmi group" en 2 et le "hdmi mode" en 35 suite a le lancement de la commande de reconnaissance sous SSH ( prefere mode 35),j'ai également modifié le global .videomode en DMT 35 HDMI mais vraiment rien a faire au démarrage mon écran reste noire avec le message "no input",j'ai un second ecran 19" et idem.

    Avez vous une solution a m'apporter? Sinon je pense passer en VGA ca parait beaucoup plus simple..

    D'avance merci, et voici mes lignes de configs :

    ------------ H - HERE IT IS - GLOBAL EMULATOR CONFIGURATION ------------

    The global value will be used for all emulators, except if the value

    is redefined in the emulator

    Set game resolution for emulators

    select your mode from the command : tvservice -m [MODE]

    CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced

    CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive

    use 'default' for using the default resolution

    (string)

    global.videomode=DMT 35 HDMI
    ![0_1509900154581_ssh hdmi 2.png](Envoi en cours 100%)



  • @sucrefreeman salut, une recherche sur google "recalbox ecran noir dvi" et tu tombes sur ce site :

    https://forum.recalbox.com/topic/10417/recalbox-et-écran-dvi-5-4-hyundai-x93s/1

    oups

    voila le bon ...

    https://github.com/recalbox/recalbox-os/wiki/Connectez-votre-recalbox-à-un-écran-DVI-(FR)

    je pense que ca devrait regler ton problème.



  • @snoopytfr
    Click sur ton lien juste pour rire...



  • @snoopytfr ,merci pour ta réponse,j'ai oublié de préciser que j'avais appliqué cette modif sur le hdmi drive 2,franchement j'ai tout essayé par rapport aux différents forum d'assistance que j'ai pu lire... J'ai meme forcé la résolution "safe" la plus basse mais toujours pas d'affichage... Aucun probleme sur mon écran 23" 16/9 qui lui aussi est en DVI, je pense que recalbox ne peut pas afficher sur du 19" 5/4.

    Je n'est plus qu'a détruire mon bartop!



  • @sucrefreeman J'ai egalement un ecran 5/4 en 19" connecté avec un convertisseur DVI dhmi. Pas de problème chez moi de pas la peine de détruire ton bartop



  • @snoopytfr ,je plaisantais au sujet de la destruction de mon bartop qui d'ailleurs n'est meme pas terminé! Super idée, le top serait que tu procede a un copier coller de ton fichier recalbox.conf comme ca j'identifierai vite d'où viens le probleme,enfin j'espere... Si tu retrouve un peu de courage d'allumer ta borne ce soir fais moi signe,je m'y acharne depuis hier apres midi en vain...

    Dans tout les cas merci a toi !



  • @sucrefreeman voila mon fichier config.txt

    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    disable_overscan=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # comment to get jack audio
    #hdmi_drive=2
    
    # Using /etc/modules is deprecated and no longer supported on 4.4 kernel
    # So manually enable audio
    dtparam=audio=on
    
    config_hdmi_boost=0
    
    # force hdmi while the tv can take time before sending the signal on the hdmi output
    hdmi_force_hotplug=1
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    # uncomment for lirc-rpi
    #dtoverlay=lirc-rpi
    
    # if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it
    boot_delay=3
    
    # uncomment if you don't want the rainbow at startup
    disable_splash=1
    
    

    et c'est les parametres dans mon fichier recalbox.conf

    ## Allow a specific resolution for ES only from the command : tvservice -m [MODE]
    ## Leave commented for the default usual behaviour
    ;system.es.videomode=CEA 4 HDMI
    
    ....
    
    # ------------ H - HERE IT IS - GLOBAL EMULATOR CONFIGURATION ------------ #
    ## The global value will be used for all emulators, except if the value
    ## is redefined in the emulator
    
    ## Set game resolution for emulators
    ## select your mode from the command : tvservice -m [MODE]
    ## CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 
    ## CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    ## use 'default' for using the default resolution
    ## (string)
    global.videomode=DMT 35 HDMI
    
    ## Shader set 
    ## Automatically select shaders for all systems
    ## (none, retro, scanlines)
    global.shaderset=none
    
    ## Once enabled, your screen will be cropped, and you will have a pixel perfect image (0,1)
    global.integerscale=0
    
    ## Set gpslp shader for all emulators (prefer shadersets above). Absolute path (string)
    global.shaders=
    
    ## Set ratio for all emulators (auto,4/3,16/9,16/10,custom)
    global.ratio=auto
    
    ## Set smooth for all emulators (0,1)
    global.smooth=1
    
    ## Set rewind for all emulators (0,1)
    global.rewind=1
    
    ## Set autosave/load savestate for all emulators (0,1)
    global.autosave=0
    
    ## Enable retroarchievements (0,1)
    ## Set your www.retroachievements.org username/password
    ## Escape your special chars (# ; $) with a backslash : $ => \$
    global.retroachievements=0
    global.retroachievements.hardcore=0
    global.retroachievements.username=
    global.retroachievements.password=
    
    ## Set retroarch input driver (auto, udev, sdl2)
    ## If you don't have issues with your controllers, let auto
    global.inputdriver=auto
    
    ## If you do not want recalboxOS to generate the configuration for all emulators (string)
    ;global.configfile=/path/to/my/configfile.cfg
    
    # ------------ I - EMULATORS CHOICES ----------- #
    ## You can override the global configuration here
    ## Here is the snes example
    ;snes.videomode=CEA 4 HDMI
    snes.core=snes9x_next
    ;snes.shaders=/recalbox/share/shaders/shaders_glsl/mysnesshader.gplsp
    ;snes.ratio=16/9
    ;snes.smooth=0
    ;snes.rewind=1
    ;snes.autosave=0
    ;snes.emulator=libretro
    ;snes.integerscale=0
    ## If you do not want recalboxOS to generate the configuration for the emulator : 
    ;snes.configfile=/path/to/my/configfile.cfg
    
    ## Default cores for RPi3
    snes.core=snes9x_next
    gba.core=mgba
    mame.core=mame078
    nes.core=fceunext
    
    ## NeoGeo emulator 
    ## You can use pifba or a libretro core (fba2x,libretro)
    neogeo.emulator=libretro
    ## If you set libretro as neogeo.emulator, the line below sets the retroarch core (fba,imame4all)
    neogeo.core=fba
    
    ## N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution)
    ## So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI).
    ## If your screen is not compatible with one of these video modes, please check the recalbox's wiki.
    n64.videomode=DMT 4 HDMI
    ## If you are using a CRT screen, please change the setting above with this one : 
    # n64.videomode=default
    
    ## Dreamcast emulator
    ## Like N64, such a CPU intensive emulator needs a small resolution
    ## Consider DMT 4 HDMI (640*480) or DMT 9 HDMI (800*600). If you have a black screen on dreamcast, try DMT 9 HDMI here
    dreamcast.videomode=DMT 9 HDMI
    
    ## Configurations generated by Recalbox
    
    

    En esperant que cela va t'aider

    et tiens pour la frime voici mes realisations.

    https://forum.recalbox.com/topic/7/your-recalbox-vos-recalbox/78



  • @snoopytfr ,trop fort le mec! Pour les fichiers envoyés et bien sur pour tes bornes!
    Tout correspond niveau config, sauf une que je ne trouve pas, dans ton config.txt, ;system.es.videomode=CEA 4 HDMI,
    comment faire pour la vérifier? Moi j'édite simplement avec le bloc note.



  • @snoopytfr ,autant pour moi j'ai retrouvé la ligne ,system es, et je suis également bien en CEA 4 HDMI, je comprends pas pourquoi ca fonctionne pas chez moi... Je vais essayer avec un adaptateur VGA je pense, Grand merci a toi pour ton aide et bonne continuation! A+



  • @sucrefreeman Tu confonds. Il y a 2 fichiers. le premier serre au systeme c'est le fichier config.txt.

    Le plus simple pour le modifier c'est de prendre ta sd card et la mettre dans un pc. ET la tu trouvera sur la partition boot ce fichier.

    C'est la qu'il faut mettre en commentaire : #hdmi_drive=2 comme ceci.

    Ensuite tu as le fichier avec les parametres de cecalbox. le fameux recalbox.conf que tu peux modifier une fois recalbox booté et connecté réseau en allant sur : \recalbox\share\system.



  • @snoopytfr , oui je confonds mais au final je l'avais bien modifié

    uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1

    disable_overscan=1

    uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1
    #hdmi_mode=1

    comment to get jack audio

    #hdmi_drive=2



  • Suite aux comparaisons de configs avec les fichiers de snoopytfr il s'avère que mon probleme est matériel, en effet l'adaptateur HDMI/DVI que j'utilise ne fonctionne pas sur mes 2 écrans 19", en revanche aucun probleme sur mon ecran 23" 16/9 surment plus récent,d'aspect les deux adaptateurs sont similaires donc attention a ceux qui pourait partir dans un délir de config comme je l'ai fais ces dernieres 24h!

    Merci a toi Snoopytfr,je vais pouvoir continuer mon bartop!



  • @sucrefreeman pour ma part c'est le cable HDMI2DVI d'amazon, aucun pb avec



Want to support us ?

Join us on :

159
Online

28851
Users

14651
Topics

110727
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.