SNES spiele ruckeln



  • Hi,
    hab ein kleines Performance-problem bei SNES spielen auf meinen Zero W.
    Die Spiele ruckeln leider etwas....teilw. ist es damit wirklich grenzwertig zu spielen.
    Über die config.txt habe ich den Zero W schon übertaktet.
    Dafür habe ich am Ende der Datei folgendes eingefügt:
    #Overclock Config
    arm_freq=1000
    gpu_freq=500
    core_freq=500
    sdram_freq=500
    sdram_schmoo=0x02000020
    over_voltage=2
    sdram_over_voltage=2

    Mit dem Befehl: vcgencmd measure_clock arm
    Wird mir folgendes angezeigt: frequency(45)=1000000000
    Scheint also zu funktionieren, löst nur leider das Problem nicht :(

    Oder sollte man hier eher mit dem Turbo-Modus in ES arbeiten?

    Kann man auch irgendwie die GPU auslesen?

    Macht es Sinn den raspberry über tvservice -m CEA auf den "prefered mode" zu stellen?
    Hilft das viell. etwas?

    Gruß
    matthias



  • @hagen_fenris

    Hallo,

    über tvservice den "prefered mode" zu stellen macht durchaus Sinn.
    Du könntest den "Core" wechseln, vielleicht hilft es etwas.
    Die "zurückspulen" Funktion im ES Menü kannst du auch mal auf "aus" setzen.

    Zur Übertaktung kann ich dir nichts sagen, noch nie gemacht.



  • In der Recalbox Oberfläche gibt es ja die Funktion Overclock.... welche Werte werden da bei Extrem angegeben?

    Aber ich denke das der PI1 da schon etwas schwach auf der Brust ist. ?????



  • @hagen_fenris

    EDIT:
    Ja, ich hätte das über das ES Menü gemacht.



  • Ich mach die händischen Änderungen in der config.txt mal rückgängig und schau dann, was sich durch die Einstellungen im ES tut.
    Was verbirgt sich denn hinter welcher Einstellung?
    Bzw. was genau steckt hinter Turbo > Extrem???

    Zurückspulen hab ich bereits aus...
    Was meinst Du mit "core" wechseln?



  • @hagen_fenris

    Ehrlich gesagt habe ich noch nie die "Übertaktung" genutzt.
    Das könntest du, bei Interesse, eventuell über den IRC erfragen.

    Zum Thema Core:
    Libretro hat verschiedene Cores (eigentlich Emulatoren würde ich sagen), welche man nutzen kann.
    Zum Testen:
    Gehe mal auf ein SNES Spiel (nicht starten), und drücke die "select" Taste.
    Jetzt auf "Metadaten Bearbeiten"
    "Emulator" stellst du auf "Libretro"
    Beim Core solltest du jetzt eine Auswahl haben (pocketsnes, catsfc, snes9x,..)
    Diese kannst du mal umstellen und testen (speichern nicht vergessen).
    Das gilt dann nur für das eine Spiel (vorerst).



  • Mit der Turbo-Einstellung aus Emulationstation läuft es jetzt etwas besser.
    Bei Turbo wird in die config.txt am Ende folgendes eingetragen:

    #Overclock Config
    arm_freq=1000
    gpu_freq=250
    core_freq=500
    sdram_freq=600
    sdram_schmoo=0x02000020
    over_voltage=6
    #sdram_over_voltage=6
    force_turbo=0
    over_voltage_sdram_p=0
    over_voltage_sdram_i=0
    over_voltage_sdram_c=0

    Dafür sind meine Einstellungen komplett gelöscht worden.
    Die GPU habe ich jetzt aber von 250 auf 500 erhöht.
    Auf dieser Seite hier finden sich auch noch Infos...leider nicht von recalbox.
    https://github.com/RetroPie/RetroPie-Setup/wiki/Overclocking



  • @hagen_fenris

    Guten Morgen,

    etwas besser ist aber noch nicht gut genug :)

    Hast du den "prefered mode" eingetragen?
    Hast du die "Cores" getestet?



  • Muss mich ja langsam rantasten.
    Jetzt läuft es erstmal etwas besser...beim nächsten reboot greift dann die Anpassung der GPU.
    Je nachdem, wie es dann läuft mach ich weiter :)



  • @hagen_fenris

    Ich bin gespannt.
    Halt mich auf dem Laufenden.



  • Schonmal versucht:

    force_turbo=1

    Du solltest jetzt schon über eine Kühlung nachdenken sonst brennt dir der Prozessor ein Loch in die Platine :)



  • @hagen_fenris said in SNES spiele ruckeln:

    Zero W

    Geht anscheinend noch mehr beim Zero

    Gerade im Netz gefunden....aber da würd ich schon sehr aufpassen das der nicht in die ewigen Jagdgründe abhaut...

    Vielleicht über einen pi3 kauf nachdenken :)

    There are some settings which flip a hardware switch inside the Pi and void the warranty, these are:

    over_voltage greater than 6
    force_turbo=1
    temp_limit greater than 85

    Here is my best settings. You can copy/ paste into your config.txt file.

    force_turbo=1
    arm_freq=1094
    gpu_freq=500
    core_freq=500
    sdram_freq=500
    sdram_schmoo=0x02000020
    over_voltage=7
    sdram_over_voltage=2

    Was mir noch eingefallen ist....welches Netzteil benutzt du? Wenn das zu schwach ist dann regelt der Raspi automatisch runter.



  • Also Netzteil hab ich eins mit 2,5A
    https://www.amazon.de/gp/product/B01DJEBOW6/ref=oh_aui_detailpage_o06_s00?ie=UTF8&psc=1

    Sollte genügen.
    Aktuell hat die CPU wohl "nur" ~50°C.
    Da wäre also noch Luft nach oben...wobei der Zero auch ohne Gehäuse etc. rumliegt.
    Wollt den eigentlich in ein NES-Cartridge einbauen...aber da wirds mit der Kühlung wohl nicht so leicht werden.


Log in to reply
 

Want to support us ?

Join us on :

173
Online

29688
Users

14865
Topics

111999
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.