Moga pro et hot key



  • Bonjour,
    Depuis la maj 4.1 ,plus moyen de configurer la hot key sur ma manette Moga pro qui fonctionnait très bien en 4.0.2...
    Dongle bluetooth CSL 4.0

    Quelqu'un à t'il eu ce soucis?

    Merci


  • Moderator
    Moderator
    Team

    Salut,

    Bienvenue au club, en fait c'est la touche select qui ne fonctionne plus...


  • Moderator
    Team

    Bonjour @nop001
    les protocoles bluetooth ont été modifié dans recalbox 4.1
    dommage ne n'a pas avoir testé recalbox 4.1 unstable.

    une fois dans le module de reconfiguration de la manette dans emulationstation
    si tu remontes ou passe cette touche, arrives tu à revenir dessus et valider ?

    il est demandé de fournir les archives de support afin d'y voir plus.

    as tu conservé les fichiers es_inputs.cfg de ta version recalbox 4.0.2 ?


  • Moderator
    Moderator
    Team

    @acris ça n'a pas été faut de se propose comme testeur à l'époque, mais la réponse était pas possible, on file pas la 4.1 unstable, etc. ;)


  • Moderator
    Team

    la version unstable a été disponible pendant un an, et indisponible pendant 2 mois passés à cause de changer d'infrastructure on ne peut pas founir de liens que nous disposons plus.

    Sur ce @nop001 j'attends tes réponses et ton archive de support.



  • En fait lors de la configuration de la manette , star est bouton 0 et select bouton 7.

    La hot key ne prends pas le commun des deux boutons start + select.
    Pire les boutons reste assigné à leur emplacements d'origines...

    Donc boutons avec fonctions simultanées, ex select et hot key = bouton 7.

    Peut être ai je encore le fichier je vais vérifier.
    Merci



  • Voilà j'ai regardé dans mon ancien fichier es.input.cfg la hot key ne prends pas la valeur id="10". Peut être que 9 boutons max ds la 4.1?!

    Édit les boutons n avaient pas les mm valeurs "id" ds la 4.02


  • Moderator
    Team

    @nop001
    Poste ton es_inputs.cfg version 4.0.2 et version 4.1

    la hotkey est uniquement un bouton et la plus part du temps on choisit select ou L3 ou jamais start


  • Moderator
    Team

    @nop001 et @OyyoDams

    bluetooth interne du raspberry ? ou dongle bluetooth ?



  • @acris

    Je pense que tu as raison au sujet des touches, tu mets le doigt sur mon problème!
    Je pense confondre hot key et combo start+ select.....
    Je passe pour un imbécile et je suis désolé.
    Très novice sur recalbox dû à une vie chargée et peu de temps à y consacrer...
    Je ferai un nouvel essai lundi, we full.

    Je vous tiens au courant de ma sottise ou non

    Merci à tous de votre aide


  • Moderator
    Moderator
    Team

    Ok je pense qu'on va pouvoir avancer.

    Alors déjà précision, ma manette est la Moga Pro Power, je le précise car la Moga Pro tout court n'est pas tout à fait la même, la différence est que la Power permet d'alimenter un smartphone pour le recharger quand tu joues avec. Mais en ce qui nous concerne ici, cela ne doit pas faire de grosse différence.

    J'ai viré tous mes périphériques BT de Recalbox, réassocié la Moga, et reconfiguré les boutons. Le bouton Select est bien capté par Emulation Station lui même, ça affiche bien le menu "Quitter" ou "Options" si on est dans une liste de jeux d'un émulateur". En revanche, dès qu'on lance un jeu type NES, Super NES, etc., il devient inopérant. Ce n'est donc à priori pas réellement un problème de bluetooth, mais plus un problème de paramétrage de retroarch.

    Extrait de es_input.cfg:
    <inputConfig type="joystick" deviceName="Moga Pro 2 HID" deviceGUID="05000000d62000007162000001000000">
    <input name="hotkey" type="button" id="0" value="1" code="158" />
    <input name="select" type="button" id="0" value="1" code="158" />
    </inputConfig>

    Extrait de retroarchcustom.cfg:
    input_player1_select_btn = 0

    Est-ce que c'est ça qui ne lui plait pas ? Aucune idée, je suis peut-être sur une fausse piste, mais ce qui est sur, c'est qu'une fois de retour dans ES, le bouton Select fonctionne de nouveau.

    A toute fin utile, mon fichier de support: https://www.dropbox.com/s/8ddjugxdbmy28ow/recalbox-support-19800101020427.tar.gz?dl=0

    es_input.cfg de la 4.0.2: https://www.dropbox.com/s/wj0w59diinyxvav/es_input_4.0.2.cfg?dl=0

    es_input.cfg de la 4.1: https://www.dropbox.com/s/zbt1dqxaelp8s6p/es_input_4.1.cfg?dl=0


  • Moderator
    Team

    @oyyodams A tout hasard, tu peux changer le input driver dans le recalbox.conf qui est sur auto, et le passer à sdl2 ? inutile de rebooter recalbox après.

    autre test a faire : tenter des émulateurs non retroarch : N64, FBA, Dreamcast, PSP


  • Moderator
    Moderator
    Team

    @substring génial!

    Avec sdl2 effectivement ça marche dans retroarch!

    Et je viens de faire un test N64, ça marche aussi.


  • Moderator
    Team

    c'était ma suggestion substring a été plus rapide.
    donc oui il faut modifier le pilote sdl2 comme les ipega.


  • Moderator
    Team

    @oyyodams tu peux faire une archive de support stp ? http://recalbox/help


  • Moderator
    Moderator
    Team


  • Moderator
    Team

    @oyyodams haha tu ne veux pas mettre le lien que le manager t'a donné ? ;)


  • Moderator
    Moderator
    Team

    @substring ah mais j'aimerais bien ça serait plus facile, seulement via l'interface web j'ai un beau "certificate is not yet valid"

    problème de certificat


  • Moderator
    Team

    @oyyodams ok. Par contre je ne vois pas ta moga pro dans les pads conenctés :/


  • Moderator
    Moderator
    Team

    @substring bizarre en effet, j'ai refait un support et là elle apparait: https://www.dropbox.com/s/ahte51n2wbeebwb/recalbox-support-19800101032152.tar.gz?dl=0

    Sinon tu sais pourquoi via l'interface il me jette cette erreur de certificat ? (désolé si je part en hors sujet par rapport au topic)

    edit: c'est bon c'était de mon côté ce problème de certificat, boulet geek que je suis :p


Log in to reply
 

Want to support us ?

Join us on :

254
Online

27406
Users

14110
Topics

107084
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.