[4.1-stable] Chargement des roms depuis smb



  • Bonjour,
    Tout d'abord bravo pour le boulot abattu avec la version 4.1.
    Je viens solliciter votre aide car je n'ai pas trouvé de solution à mon problème que ce soit en bidouillant moi même ou en cherchant sur le forum. Je m'excuse d'avance si c'est un problème déjà connu.

    Matériel : RPI3
    Réseau : wifi
    Version : 4.1-Stable (Installation complète)
    Problème : Je cherche à monter le dossier roms depuis mon NAS en SMB chose que je n'avais pas de problème à faire en 4.0.2 en utilisant le tuto suivant : https://github.com/recalbox/recalbox-os/wiki/Charger-ses-rom-depuis-un-partage-réseau-Samba-(par-exemple-un-NAS)-(FR).
    En 4.1 et en suivant la version mise à jour du tuto, le dossier n'est pas monté au démarrage. J'ai bien modifié le fichier recalbox-boot.conf mais que ce soit en utilisant la commande :
    sharenetwork_smb1=ROMS@192.168.1.51:recalbox/roms:username=recalbox,password=recalbox

    Ou la commande :
    sharenetwork_cmd2=mount.cifs //192.168.1.51/Recalbox/saves /recalbox/share/saves -o username=recalbox,password=recalbox,_netdev

    Cette dernière commande fonctionne pourtant parfaitement après le démarrage complet du système.
    En fouillant un peu dans le script de démarrage S11share, j'ai trouvé le fichier de log "mountNetwork.err" qui contient les infos suivantes :
    mount error(101): Network is unreachable
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

    Le réseau ne semble donc pas disponible à cette étape du démarrage.
    Est-ce parce que la machine est en wifi ?
    Avez vous une idée de solution, car mes bidouilles n'ont rien données -_-

    Merci d'avance pour votre aide.



  • Je viens de voir un sujet similaire ressortir : https://forum.recalbox.com/topic/9321/4-1-stockage-de-roms-sur-nas
    Désolé pour le doublon, j'avais pourtant fait une recherche.
    En tout cas, il confirme ce que je pensais, le wifi est bien la cause de mon problème. Mais je ne vois pas de solution.
    Est-ce qu'il est possible de faire en sorte que le wifi soit démarré plus tôt sans tout casser ?


  • Moderator
    Team

    es-tu en ethernet ?



  • Non, c'est ce que j'explique dans mes posts ^^
    Il n'y a pas moyen de modifier l'ordre de démarrage des services pour que le montage du dossier roms se fasse après le démarrage du wifi ?


  • Moderator
    Team

    @picrou le fait est que si tu montes toute la partie userdata par wifi, alors que la config de ton wifi est sur ton NAS ... ben zob, serpent qui se mord la queue, tu veux aller chercher en reseau comment configurer ton wifi ... Donc éventuellement ca peut etre amélioré, oui, mais ca va devenir contraignant. Et je plainds les accès par wifi sur un NAS ... à 200ko/s il va booter en une éternité



  • C'est juste le dossier de roms que je monte depuis mon NAS. La partie contenant les fichiers de configuration reste sur la SD.
    Je le faisais avec la version 4.0 et ça ne posait pas de problème.


  • Moderator
    Team

    @picrou si la même config marche sur ethernet et pas sur wifi ... tu devines la conclusion ;)



Want to support us ?

Join us on :

312
Online

28102
Users

14394
Topics

108987
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.