Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

4.1 Text No Longer Displays and Console Order Wrong

  • First off, I really appreciate the quality of life features that have gone into 4.1, they're great thanks!

    However, since upgrading this evening I can now no longer see any text at the bottom of the screen; it just displays as a series of blank yellow squares. This affects all normal hotkey shortcuts like save states (I no longer know which save state I'm using) as well as things like retroachievements.

    Also, the order consoles are displayed in has changed. Before, all my Nintendo consoles were together (SNES, NES, FDS, N64) then Sega (Megadrive, MegaCd, 32x, Master System, SG1000), then PC Engine, etc. Now they're all jumbled up!

    Are these bugs that need fixing or have I got a corrupted OS or some settings wrong somewhere?

  • @n0signal hi
    The yellow square boxes are supposed to be fixed for a long time now unless you use custom retroarch config files.

    For the emulators order, they are now sorted in the alphabetical order as in the roms directory. This is because the systems file is dynamically generated at build time depending on the board, and it is automatically sorted. I guess you can cope with that :)

  • Banned

    @substring is it dynamically generated in share_init and still overwritable in share ?

  • @voljega not dynamically in share_init, but in share. But we only updated the default RA config files, not the user ones

  • @substring if thats the new order for emulators then yeah i can live with it. ;) Shame though as I liked the manufacturer grouping before.

    Regarding the yellow boxes though... I'm not running any custom config files. I don't even know where I'd find them!? It just started displaying yellow boxes after I upgraded.

    Did I read somewhere that after updating it keeps old config somewhere alongside new config and I have to manually delete old ones and rename new ones? Or did I imagine that? Lol.

  • @n0signal The config file that is saved is only the recalbox.conf

    In your case, the file that needs editing can be reached through network at \\recalbox\system\configs\retroarch, the retroarchcustom.cfg and retroarchcustom.cfg.origin

  • Banned

    @substring oh ok so basically there's no way anymore to use a custom es_systems.cfg ? or you have to modify the on in share_init which will erase the one in share on boot ?

  • @voljega we've never recommended editing the es_systems.cfg because of upgrades ... But you can do as before, of course

  • Banned

    @substring I know but some of use like to do that :)

  • @voljega I wonder why ;)

  • @substring thanks, what do I do when I find those config? Delete them?

  • @n0signal if you're feeling almighty and invincible, rename that retroarch folder, reboot and report :)

  • @substring I tried using the 4.1 unstable fix but that didn't work. So I tried renaming the custom config file as you suggested and voila! I have text again... and even better than before as it's not pixellated! Thanks for your help!! You can mark this one as solved. ^_^

  • @n0signal have you updated from an unstable 4.1 ?

  • I just deleted the retroarch config file and got the Issue fixed immediatly. Did it with WinSCP. 4.1 is awesome by the way.

  • @substring no I updated from a stable 4.0.2 and hadn't ever gone near that config file. Very odd. Glad the fix was easy.

  • I once chanced something in the Retroarch menu. Nothing special. But that must have made the issue.

  • @el_vagabundo ah yeah I'm always fiddling in the retroarch menu once I have games running. Lol. Before 4.1 it was the only way to force 8/7 on SNES games! Maybe that did something.

  • @n0signal you can change the ratio in the ES menu, or even in the recalbox.conf

  • @substring yeah don't worry all sorted now thanks. :)

Want to support us ?





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.