Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

GPIO : controllers non reconnus


  • Moderator
    Moderator
    Team

    As tu configuré dans es ensuite ?
    Je vois que tu es en 4.0.1
    Fais la mise à jour en 4.0.2 peut etre.
    As tu bien relié la chaine de masse ?
    @Substring laisse entendre un soucis hardware
    Oui mais lequel gpio hs ?



  • @bandenklap tu peux donner le résultat de lsmodstp ?



  • @substring désolé pour la réponse tardive... Retour de boulot + enfants à gérer = manque de réactivité... ;-)

    La réponse de lsmod :
    0_1507744251767_e76f66ab-bebb-4478-bab8-b8171bfa58d8-image.png

    @Substring : merci pour les conseils sur le fait de plugguer seulement 1 seul btn, c'est une excellente idée que je n'aurai pas eue seule, je m'exécute de ce pas ! Je te tiens rapidement au courant des résultats



  • @Substring @acris PS : je me demande si une cause du problème ne serait pas un problème de réseau. Quand je me connecte à mon RPI depuis mon mac, peu importe que je change le controllers.gamecon.enabled=0 via l'accès à distance du finder de mon mac ou via l'interface navigateur (en saisissant l'IP de ma recalbox dans la barre d'URL), le controllers.gamecon.enabled revient toujours sur 0...

    J'avais fait les modifs ce matin pour le passer à 1, et il est revenu sur 0 quand je me suis reconnecté ce soir :
    0_1507744567696_5cf2c790-e27c-449b-bef6-ec95e5680726-image.png

    Idem, je n'arrive pas à uploader de roms sur la SD de mon RPI alors que celui-ci est bien connecté au réseau local... Une piste selon vous ?



  • @bandenklap ca sent l'extinction à l'arrache, donc partition remontée en lecture seule par sécurité

    gamecon ce n'est pas ele pilote qu'il te faut, c'est bien controllers.gpio que tu dois activé, et il est à zéro. C'est confirmé par ton lsmod qui n'indique aucun chargement du module attendu



  • @substring OK, merci pour l'info... Du coup, que me recommandes-tu pour régler ce problème ?



  • @bandenklap tu peux me générer une archive de support que je regarde tes logs ?



  • @substring Genre ça ? Les logs que je trouve sur l'IP de ma recalbox ?

    [ 10.02] : starting new log
    [ 10.03] : converting dos to unix carriage return characters
    [ 10.52] : starting xarcade2jstick
    [ 10.53] : setting audio to auto
    [ 10.53] : setting hostname to RECALBOX
    [ 10.54] : setting audio volume to 90
    ---- recalbox-config.sh ----
    ---- recalbox-config.sh ----
    [ 10.60] : xarcade2jstick : no official stick found, looking for keyboard encoder now ...
    [ 10.60] : setting audio output mode : auto
    [ 10.64] : setting audio volume : 90
    numid=3,iface=MIXER,name='PCM Playback Route'
    ; type=INTEGER,access=rw------,values=1,min=0,max=2,step=0
    : values=0
    Simple mixer control 'PCM',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback -10239 - 400
    Mono: Playback -663 [90%] [-6.63dB] [on]
    [ 10.70] : setting keyboard layout to en
    [ 11.08] : starting emulationstation with lang = en_US
    [ 11.10] : Starting emulationstation with command :
    [ 11.11] : HOME=/recalbox/share/system LC_ALL="en_US.UTF-8" SDL_VIDEO_GL_DRIVER=/usr/lib/libGLESv2.so SDL_NOMOUSE=1 /usr/bin/emulationstation; [ -f /tmp/shutdown.please ] && (shutdown -h now);[ -f /tmp/reboot.please ] && (shutdown -r now)
    ---- recalbox-config.sh ----
    udhcpc (v1.24.1) started
    Sending discover...
    Sending discover...
    Sending select for 192.168.1.26...
    Lease of 192.168.1.26 obtained, lease time 86400
    deleting routers
    adding dns 192.168.1.1
    ---- recalbox-config.sh ----
    [ 20.27] : wlan0 be used as wifi interface
    [ 22.04] : Starting S92switch
    [ 22.06] : script /recalbox/scripts/powerswitch.sh [ STARTED ]
    [ 22.34] : Starting S94manager
    Will not start pm2 : system.api.enabled is set to 0
    ---- recalbox-config.sh ----
    update available



  • @bandenklap viens sur irc va :) l'icone tout en haut avec la bulle de discussion



  • Hello @Substring , bon, je te tiens informé de la résolution de mon problème. J'ai donc racheté une SD sandisk de bonne facture, et tout est réglé, la recalbox fonctionne à merveille...

    Un grand grand merci pour ton aide de l'autre jour, et à bientôt !

    Thibaut



  • @bandenklap Magnifico !!!! Donc exit les QUMOX :o



  • @substring Of course... :-)
    Mille mercis encore !


Log in to reply
 

Want to support us ?

Join us on :

182
Online

45831
Users

17429
Topics

131439
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.