Can't use FBA custom configuration



  • Hi all. I'm trying to use a custom keys configuration for FBA. I've followed the instructions here: https://github.com/recalbox/recalbox-os/wiki/How-to-use-custom-config-for-emulators-(EN)

    But at the end my custom configuration is just not loaded. I've tried with all these configurations in recalbox.conf:

    fba_libretro.configfile=/recalbox/share/system/configs/retroarch/inputs/fba_custom.cfg
    fba-libretro.configfile=/recalbox/share/system/configs/retroarch/inputs/fba_custom.cfg
    fba.configfile=/recalbox/share/system/configs/retroarch/inputs/fba_custom.cfg
    retroarch.configfile=/recalbox/share/system/configs/retroarch/inputs/fba_custom.cfg
    neogeo.configfile=/recalbox/share/system/configs/retroarch/inputs/fba_custom.cfg

    But at the end, when I run it, this is what I can see in the logs:

    ['retroarch', '-L', '/usr/lib/libretro/fba_libretro.so', '--config', '/recalbox/share/system/configs/retroarch/retroarchcustom.cfg', '/recalbox/share/roms/fba_libretro/1942.zip']

    using the default configuration instead of mine.
    I'm using Recalbox 4.0.2 on Raspberry pi 2.

    What am I doing wrong?



  • Anyone helping here? I guess it should be something trivial, but I haven't found the solution in the docs or searching in the forum.


  • Moderator
    Team

    @lcapone32 lemme check


  • Moderator
    Team

    It does work the way intended. Can you do a hastebin of your recalbox.conf please ? are you sure the file you're referencing do exist ?



  • Sure!

    recalbox.conf
    https://hastebin.com/uxizififil.php

    /recalbox/share/system/configs/retroarch/inputs/fba_custom.cfg (with 666 permissions)
    https://hastebin.com/uhayulalaj.ini


  • Moderator
    Team

    @lcapone32 looks like someone decided to go full keyboard lol

    Well, it does work. Regarding your case, there was a fba-libretro bug for a while as the expected configfile would not match the system name. But anyway, it should work for neogeo at least



  • @substring Thanks! I only want to use it for fba_libretro. The multiple system overrides in the config are only failed attempts to make it work. Do you know what version of Recalbox / fba_libretro fixes this bug?



  • And... any trick I can do meanwhile? I have a cabinet with the buttons mapped to the keyboard, so I really need the keys configured to be able to play.


  • Moderator
    Team

    @lcapone32 we could consider a trick if you can force your "keyboard" (is it an encoder ?) To strictly follow the mame crappy mapping as seen on xarcade devices. This all depends on your experience with linux



  • @substring But the cabinet uses Mame keys!
    Mame works great with no need of a customization, it's fba_libretro who doesn't follow that mapping and uses the default retroarch keys.


  • Moderator
    Team

    @lcapone32 juste tell me : does neogeo work with a custom configfile ? Because it should.

    Have you tried fbalibretro.configfile ?



  • @Substring Ok, now I'm feeling very stupid. Yes, I had not tried using "fbalibretro", and it worked perfectly.

    Thank you very much!


  • Moderator
    Team

    @lcapone32 you can't feel stupid as it wasn't working the right way, as i told you on my forst post in your topic. Take care once 4.1 is out, you'll have to switch back to fba_libretro


Log in to reply
 

Want to support us ?

Join us on :

315
Online

27429
Users

14119
Topics

107154
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.