Bug d'utilisation Joystick/boutons en double joueur



  • Bonjour,

    Pas tout à fait le même souci mais même matériel que ce post :
    https://forum.recalbox.com/topic/8954/pb-configuration-avec-encodeur-usb-quimat-2-joystick-arcade

    J'ai un projet de borne d'arcade et souhaite remplacer mes manettes type SNES par des joysticks/boutons.
    Je précise : RAS avec mes manettes.

    Pour passer en mode bartop, j'ai commandé le kit Quimat chez Amazon.

    J'en ai pris 2 : 1 kit blanc + 1 kit noir (à 20,88 euros/kit)
    Pourquoi 2 kits ?
    Afin d'avoir une carte contrôle par kit et d'assigner 1 port usb par 1 kit ; ça me semblait plus logique.
    (et que le lot est plus cher)

    MAIS
    Les 2 kits ne fonctionnent pas ensemble !!!
    J'ai passé des heures à faire des tests dans tous les sens

    Le souci ?
    Un des joysticks s'inverse avec le bas en haut et la droite à gauche (et inversement) + modification des ordres des boutons.
    Malgré reconfiguration = ça replante en systématique.

    Testé sous RecalBox + RetroPie (Rpi2) + RetroPie sur LinuxMint

    --> Avec RecalBox
    Impossibilité d'avoir les 2 kits.
    C'est soit l'un, soit l'autre ; le 2ème joystick s'inverse et les boutons changent.
    Et il y a totale impossibilité d'utiliser le kit seul car "start" ne me lance pas le jeu voulu mais m'éjecte avec retour à la liste des jeux.
    Je suis donc obligé d'avoir une manette SNES en "maître" pour lancer le jeu.

    --> Avec RetroPie, un peu moins de souci car je peux vraiment jouer avec un seul kit puisque je peux lancer le jeu.

    • Le kit blanc fonctionne seul (reconnu comme DragonRize)
    • Le kit noir fonctionne (reconnu comme DragonRize)
    • Le kit blanc fonctionne en double avec une manette type snes
    • Le kit noir fonctionne en double avec une manette type snes
    • Les 2 kits ne fonctionnent pas ensemble ; jamais !

    --> Avec RetroPie sur un vieux PC avec LinuxMint.
    Quasiment comme avec RecalBox :
    Impossibilité d'utiliser le kit seul car "start" ne me lance pas le jeu mais m'éjecte.
    Il me faut une manette SNES pour lancer le jeu désiré.
    Et toujours impossibilité d'utiliser les 2 kits en même temps ; le joystick s'inverse et les boutons changent.

    J'avoue que j'ai fais plus de tests sur RetroPie car mon écran 19 pouces 4/3 n'est pas accepté par RecalBox qui m'oblige à passer sur TV 56 cm de format 16/9 (on pourra voir ça à un autre moment, dans un autre post).

    D'avance merci,



  • Re,

    Mise à Jour 4.0.2
    Je peux jouer en mono-joueur car le bug du "start" qui m'éjecte n'est plus présent.
    Mais la configuration du kit modifie le second ; à chaque fois.


  • Moderator
    Team

    @Nabla35
    As tu regardé si meme id vendor et id product
    As tu fait l effort de suivre la procedure du lien cité ?
    la config doit etre identique pour les deux joueurs cablage identique.
    le 2nd joueur na pas Besoin de hotkey.
    Archive de support? Sans clavier et ni souris à poster @Substring jetera un oeil



  • @acris

    Bonjour,

    Merci à toi ; je venais justement pour signaler un truc tout bête ...
    Je vais passer pour un "con", mais si ça peut aider la communauté ; j'en sortirais un peu moins honteux.

    Sans réponse du forum et sans logique informatique (pour moi), je suis parti faire une balade en famille.
    J'ai dû t'entendre pendant ma balade car, en rentrant, je suis allé directement tout démonter.
    Je confirme donc, ta ligne "la config doit être identique pour les deux joueurs câblage identique." ; tu avais bien vu ; je suis un blaireau.

    EN effet, après avoir TOUT décâblé puis tout recâblé bouton par bouton avec l'aide d'un des enfants et en étant au calme = OK
    Il devait y avoir 2-3 inversions (j'en ai vu au moins 1 avant de tout défaire).

    Surtout, le problème du Joystick était TOUT BÊTEMENT lié à une grosse erreur de ma part ; en modifiant mes fixations provisoires (je suis sur un prototype carton) d'un des Joysticks, je l'ai inverser entre dévissage et revissage.

    Pas toujours facile de bricoler avec 4 enfants dans les pattes (faut bien trouver une excuse ;-) Non ?!?)

    Bref, problème résolu ; j'étais l'unique responsable.

    Et même si je n'ai lu la réponse qu'à postériori = Tu avais bien vu ! = Merci,

    @+



Want to support us ?

Join us on :

231
Online

27477
Users

14134
Topics

107267
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.