Moonlight only shows black recalbox screen and sound



  • Hello, just yesterday I received my Pi 3 and started playing with it. I installed Recalbox and was impressed by how good it worked, but have one problem.

    I set up Moonlight properly via SSH, paired with my PC and initialized.
    So far, everything looks fine, every game is listed in the ES menu with cover and description.
    But if I select any game/program from the list, ES shows the default "zoom-in" animation like with any emulator.

    At this point, all I see is the screen that shows on boot, with the version number of Recalbox and the small logo in the bottom center. Also, I hear the game's sound so I know the stream is running.

    Regular Moonlight works fine on iOS and Win/macOS using the Chrome client,
    also Moonlight Embedded with Raspbian initially works with display and sound (but crashes quickly, controller sometimes disappearing and in general just a big hassle)
    Therefore I'm positive the fault is not my PC

    I have not changed any config.
    I would love to get it to run because choosing the game right from the menu seems very convenient and overall I like Recalbox very much!
    Any help would be greatly appreciated!

    I am using:

    • Recalbox 4.0.2 on RPi 3, Ethernet connection
    • Windows 10 Pro x64, probably newest, Windows Update is just a huge PITA, that's where macOS is genuinely far superior to Windows ;)
    • DS4 over USB
    • Newest GFE
    • 4K screen that goes down to 720p when a connection is established
      (The game gets displayed there just fine and changing the ingame resolution or fullscreen/window resolves nothing)

  • Moderator
    Team

    @florian-schmidt the newest gfe is the problem as recalbox 4.0.x version is getting rusty



  • @substring ok, I will downgrade GFE to 3.1.0.52 and report back



  • @substring Damn, NVIDIA loves to makes things complicated. I downgraded to GFE 3.1 first, then to 2.11.4 . It was hard enough to get them to not instantly update to the newest versions, but that's not the main problem.

    Apparently, my GTX 1080 Ti is too new for these versions, so 2.11.4 reports that my card is incompatible and 3.1 simply refuses to offer the GameStream option.

    Seems like Moonlight in Recalbox simply is incompatible with my setup and I really don't want to implement workarounds and hacks to bypass compatibility checks and auto updates, I guess I'll have to wait then.


  • Moderator
    Team

    @florian-schmidt the nex recalbox version has a more updated version. But as the version is frozen for a long time, still not yet the über last one, but it does work on my setup so far.

    Regarding GFE : don't get confused between the grahpics drivers (which should be enough for your card I believe) and GFE itself (the part that configures games, and allow streaming)



  • @substring Don't worry, I know the difference very well. GFE simply states that the 1080ti is too old, because GFE was released before the 1080ti so it isn't in the list of compatible devices.

    Also I would consider myself at least "enthusiast", as I have many years of experience and PC's are my main interest for years, although I don't play much.



  • Ethernet seems to be the problem. I'm using the newest Version of GFE with a GeForce 1070. And if I use my Edimax W-Lan Stick on my RPI2 with Recalbox 4.1.0. Moonlight works flawless.

    If I disable W-Lan and jackin Ethernet I have the same problem as Florian. So black screen with sound, sometimes I see also the Steam splash screen for some secons until it freezes or goes back to the Recalbox menu. So I'm happy that it works with W-Lan.



Want to support us ?

Join us on :

226
Online

25488
Users

13351
Topics

101185
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.