IPAC2 problem on emulators



  • Hello,
    I have read all topics about how to configure IPAC2 and still didn't found solution.

    I have 6 + 2 button setup for 2 players which makes total 16 buttons and 2 sticks. I have configured IPAC with Win IPAC according to wiki https://github.com/recalbox/recalbox-os/wiki/Keyboard-encoder-configuration-(EN) according to table 1

    Everything works fine in frontend. I can move between emulators and games with both sticks and menu\select works fine.
    When I try to play mame games, I can play only with one player so i went and configured retroarchcustom.cfg to be the same as in frontend.
    Still player two does not work. I tried as well to configure from retroarch GUI and saved file. MOdified recalbox.config and still same problem.

    Snes emulator as well doesnt work. I can't select any game with buttons.

    Can somebody please explain, which config needs to be edited for both emulators? What I'm doing wrong here?
    Or if someone can post config file so I can compare with mine.

    Thanks


  • Themer

    @northblue You shouldn't configure the ipac2 with win ipac juste leave it as default and do everything else on the wiki page.

    I guess you then didn't configure you controls throught emulation station ? You should do that and also attribute the two controllers to the right player

    And lastly you shouldn't touch at all to retroarch config, recalbox do all that by itself and it should then work fine



  • Ok I done eveything from begining :

    1. Installed image of recalbox
    2. Reseted IPAC2 to factory settings
    3. Transferred ROMS
    4. Boot up the system
    5. Done https://github.com/recalbox/recalbox-os/wiki/Keyboard-encoder-configuration-(EN)
    6. Enter the GUI and configured controller

    Now I can move only with one stick in GUI and select games, it can be one or other, not possible to move with two . In games nothing works. I can enter anz game.
    Im getting really frustrated


  • Themer

    @northblue did you try the creation of both files for your device two different names ?
    are you sure you don't have the "controllers.xarcade.enabled" parameter twice in your recalbox.conf ?



  • Okay, after 3 days finally solved the problem.
    Problem was in creation of touch /recalbox/share_init/system/configs/xarcade2jstick file. After several attempts it created correct file.
    So glad that its working fine now.
    Thanks voljega for help.
    What is the safest way now to remap the buttons? I want to swap A and B positions, and remap hotkey.


  • Themer

    @northblue just do it with EmulationStation it causes no trouble and you can do it as much as you like.

    Yeah IPAC2 gave me a lot of trouble too, I never upgraded my bartop from 4.0 for fear to not be able to configure it again !


Log in to reply
 

Want to support us ?

Join us on :

315
Online

26911
Users

13879
Topics

105477
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.