Moonlight Exit Game



  • The moonlight works very well, I connect with the pc play the game games normally but I have a big problem specifically when leaving the games the command I use to exit emulated games (Xbox + Start) does not work in Moonlight and when the PC game have the option "Quit game", I only get a black screen written "Nvidia Game Stream" being forced to move me to PC and press alt + F4 to the recalbox to return to the list of games, what would be the correct solution to close the game and back to Moonlight list ?



  • there are no answer to this simple question ? maybe the developers needs think in some basic things...



  • @TheSNKNeoGeo64 I'm so glad you're telling me what to do in such a kind way ...

    So let's debug the whole thing, ok ?

    1. You start moonlight with the expected game
    2. moonlight makes some https calls to your PC telling a few things like resolution, optimizations, inputs, sound management, some authtentication stuff
    3. GFE is aware of what it's supposed to do : start the game, encode video in H264, stream it to your Pi, creates some "virtual pads" that reproduce the pi's inputs
    4. you play

    ...

    1. you want to quit: you ask to quit the game like you'd noramlly do on the PC
    2. the game is supposed to close
    3. GFE is supposed to notice the game closed, so it should end the stream
    4. Moonlight gently closes itself right after

    Now let's say I add a HK+Start shortcut (which i already tried for testing purpose). This is how the story is rewritten :

    1. you ask to quit moonlight
    2. the GFE protocol has never been meant to handle user side quit
    3. moonlight does close, GFE can't tell the game you just quitted
    4. you're back to ES, the game still runs on your PC, you can't start any new streaming session unless you get up from your couch and close yourself the game that is still running on the PC.

    I don't find it quite "user friedly" or at least "recalbox mind". This is all a problem on the PC side, namely GFE, nothing more.

    I do agree that closing moonlight would at least unfreeze your recalbox, but this wouldn't solve the PC side of the problem (which is the origin of all).



  • if Recalbox Team create a "alft+f4" command button when using moonligh the problem is solved.



  • @TheSNKNeoGeo64 Hey man - I've had this issue before too - it is the PC end, not the fault of recalbox. Even if the devs put in an alt+F4 command, this would only stop your game, your issue is that your PC is not closing out of gamestream.

    Tried restarting your PC? Other things I tried were to use other versions of GFE, changing streaming settings the in the monlight.conf etc.



  • @TheSNKNeoGeo64 no no no, we can't send such a key combo as far as i know.



  • the SSH command "moonlight quit" closes the client and any program launched by moonlight on the server, however, the keyboard or controller input combination does not quit moonlight, or close anything out on the server.

    Why... I'm trying to figure out.

    See my topic on moonlight embedded github
    https://github.com/irtimmer/moonlight-embedded/issues/576



  • that is a moonlight bug, as stated by @Craciant


Log in to reply
 

Want to support us ?

Join us on :

218
Online

28775
Users

14633
Topics

110617
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.