advance mame 4.1



  • salut les recalboxiens , question advancemame sur recalbox 4.1 il fonctionne sur quel romset ? j'avais lu quelques part que c'était le 0.106 , j'ai pris le full sets , rien ne démarre ! vous pouvez m'aider ?



  • @alfacentory Il me semble que c'est la version MAME 0.139


  • Staff
    Global moderator
    Team

    AdvanceMAME is based on MAME 0.106 and it requires a romset aligned to that MAME version

    @substring aucunes infos dans le lisez-moi ?



  • c'est le 0.106



  • j'ai le set complet 0.106 je l'ai testé sur un mame32 0.106 il fonctionne mais sur recalbox en advancemame 0.106 ça ne passe pas



  • @ProfMielPops mame 0.139 non plus



  • Tu vas être bon à générer le dat manuellement en SSH et tester ton romset ... de mémoire il faut taper advmame -listxml un truc dans le genre



  • Essayes le 0.167
    Gardes celui qui marche.De toute façon c'est les même jeu dans les set.
    Et 5000 jeux y a des doublons.une fois dépolluer des majong et autre daubes 3000 bons jeux c'est suffisant


  • Staff
    Global moderator
    Team

    Il est bien indiqué sur le site du développeur que mame 106 doit être utilisé que si vous avez un romset plus haut vous devez l'adapter à la version de advance Mame avec clrmamepro
    le dat est dispo en téléchargement via clrmamepro : http://mamedl.esy.es/static1/clrmamepro#wwwmode



  • oula ça devient compliquer pour moi ! créer des dat et tout ça , je ne comprend absolument rien à clrmame ! et même en suivant un tuto , ça me génère des des roms fantôme ce truc
    je veux utiliser la version advancemame car il parait que c'est plus facile pour tourner l'image en vertical , sur mame 2003 quand je tourne l'image en passant par retroarch tout est en vertical



  • Bonsoir, cela fait un jour que je trime sur advancemame. j'ai peut-etre une piste pour le non foctionnement de advancemame. C'est lorsque le PI est connecté sur un ecran en DVI.
    Je m'explique Avec le PI3 branché en DVI les jeux avec l'emulateur Advancemame ne se lancent pas, par contre le meme PI3 connecté en HDMI sur ma tv les jeux se lancent.


  • Staff
    Global moderator
    Team

    @snoopytfr
    tu n aurais pas réglé le ratio ou la résolution des autres emulateurs dans recalbox.conf ?
    tu peux ajouter :

    advancemame.videomode=DMT 35 HDMI
    

    ou autre à toi de trouver la bonne résolution



  • Non je n'avais touché à rien dans le fichier recalbox.conf, par contre je viens de tester avec ton paramètre complémentaire, mais cela ne change rien . Toujours retour au menu après le lancement d'un jeu.
    pour info j'ai ceci dans le fichier log es_launch_stdout.log :

    ['/usr/bin/advmame', '-cfg', '/recalbox/share/system/configs/advancemame/advmame.rc', 'galaga88']
    Failed to initialize the video



  • @snoopytfr tu utilise quel romset avec advancemame ?


  • Staff
    Global moderator
    Team

    @snoopytfr à toi de trouver le bon mode video.

    as tu edité config.txt pour désactiver #hdmi_drive = 2 ?

    https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)



  • @snoopytfr ca me rappelle un certain @idarius qui essayait de faire marcher ca en RGB et qui avait le meme probleme ...

    Pour la rotation sous mame (parce que c'est le probleme d'origine) : il y a le TATE mode (inversion automatique abscisse et ordonnée) après ca ne gère pas les jeux qui sont soit tournés à 90° soit tournés à 270° faut finir à la paluche


  • CRT Fan

    oui je suis arrivé au même point, c'est à dire failed to initialize the video.
    Advancemame est sensé calculer tout seul la résolution des jeux, en se basant sur la résolution de lancement de l'émulateur.
    Dans mon cas, sur CRT, je n'ai pas réussi a lui trouver une résolution de base acceptable, donc evidemment ses résolutions de sorties ne passent pas.

    Par contre sur un écran normal, devrait pas y avoir de soucis, la résolution "default" devrait marcher comme les autres émulateurs ? 😕



  • @acris said in advance mame 4.1:

    @snoopytfr à toi de trouver le bon mode video.

    as tu edité config.txt pour désactiver #hdmi_drive = 2 ?

    https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)

    oui je l'ai fait.

    @alfacentory said in advance mame 4.1:

    @snoopytfr tu utilise quel romset avec advancemame ?

    Ce n'est pas un problème de romset sinon les jeux ne se lanceraient pas sur ma tv en hdmi. Mais j'ai bien le romset 0.106

    @idarius said in advance mame 4.1:

    oui je suis arrivé au même point, c'est à dire failed to initialize the video.
    Advancemame est sensé calculer tout seul la résolution des jeux, en se basant sur la résolution de lancement de l'émulateur.
    Dans mon cas, sur CRT, je n'ai pas réussi a lui trouver une résolution de base acceptable, donc evidemment ses résolutions de sorties ne passent pas.

    Par contre sur un écran normal, devrait pas y avoir de soucis, la résolution "default" devrait marcher comme les autres émulateurs ? 😕

    Resultat des commandes tvservice -m DMT et CEA

    # tvservice -m CEA
    Group CEA has 5 modes:
               mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
               mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
               mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
               mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
      (prefer) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive
    # tvservice -m DMT
    Group DMT has 12 modes:
               mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive
               mode 6: 640x480 @ 75Hz 4:3, clock:31MHz progressive
               mode 9: 800x600 @ 60Hz 4:3, clock:40MHz progressive
               mode 11: 800x600 @ 75Hz 4:3, clock:49MHz progressive
               mode 16: 1024x768 @ 60Hz 4:3, clock:65MHz progressive
               mode 18: 1024x768 @ 75Hz 4:3, clock:78MHz progressive
               mode 35: 1280x1024 @ 60Hz 5:4, clock:108MHz progressive
               mode 36: 1280x1024 @ 75Hz 5:4, clock:135MHz progressive
               mode 47: 1440x900 @ 60Hz 16:10, clock:106MHz progressive
               mode 51: 1600x1200 @ 60Hz 4:3, clock:162MHz progressive
               mode 58: 1680x1050 @ 60Hz 16:10, clock:146MHz progressive
               mode 85: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    #
    

    Voici un exrtait de mon recalbox.conf:

    # ------------ H - HERE IT IS - GLOBAL EMULATOR CONFIGURATION ------------ #
    ## The global value will be used for all emulators, except if the value
    ## is redefined in the emulator
    
    ## Set game resolution for emulators
    ## select your mode from the command : tvservice -m [MODE]
    ## CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 
    ## CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    ## use 'default' for using the default resolution
    ## (string)
    global.videomode=default
    
    ## Configurations pour advancemame
    advancemame.videomode=DMT 85 HDMI
    
    


  • @snoopytfr c'est pour moi que je posais la question de romset , moi j'ai le roms set 0.106 et ça ne démarre pas


  • CRT Fan

    J'imagine que oui, mais le mode vidéo 1280 x 720 est bien supporté par ton écran ?
    si tu met par exemple nes.videomode=DMT 85 HDMI, les jeux nes se lancent sans probleme ?


Log in to reply
 

Want to support us ?

360
Online

80.4k
Users

21.6k
Topics

157.8k
Posts