Recalbox 7.0

Probleme avec Clavier Maxxter en bluetooth



  • Salut,

    j'ai tenté d'associer mon clavier maxxter en bluetooth avec recalbox en 4.1 Unstable, et alors que celui ci semble reconnu, puisqu'il me donne une sorte d'adresse mac, il me dit que la manette est associé, mais lorsque je veux tester le clavier, rien ne réagit. J'ai été sur configuré une manette pensant voir le clavier et tenter de finir de configurer, mais rien. Je pense que j'ai encore omis une étape et je n'ai rien vu sur le forum capable de m'aider. A moins que ca soit un souci lié au clavier ?
    Voici le clavier en question.
    texte du lien



  • Alors alors alors .... Y'a un bug avec le BT : il dit systématiquement que c'est appairé, alors que ce n'est pas tjrs le cas.

    Question : as-tu déjà appairé ce clavier ailleurs ? Si oui, peux-tu annuler l'appairage ? Autre question : connais-tu le code PIN du clavier ? Me suis rendu compte hier que parfois, pour une raison inconnue, il me demandait un code PIN (pas dans ES hein, ce n'est pas prévu parce qu'on n'avait pas encore eu le cas jusqu'à présent)



  • @Substring Ok, oui j'ai un code a taper lorsque je veux l'appairer sur une tablette ou autre, je ne sais pas si c'est cela le code pin, mais c'est bien un code a 4 chiffres.
    Je comprends mieux les soucis liés au bluetooth, puisqu'il arrive même a trouver ma tablette en bluetooth, alors que j'ai désactivé le bluetooth sur celle ci... sinon mon clavier était bien appairé a une de mes tablettes, je l'ai désynchro, sauf que maintenant, recalbox ne veux plus détecter le clavier du tout, il ne le voit plus.



  • @lestatrico le truc c'est que pour les périphériques qui imposent un code PIN, va falloir le faire à la main



  • @Substring ok, je vais faire des recherches sur le forum, merci 🙂



  • @lestatrico tu ne peux pas faire la recherche sur le forum aprce que :

    • tu es le premier à avoir le cas en 4.1
    • et j'ai trouvé cette anomalie seulement hier + sa résolution 😄

    Donc de mémoire : /recalbox/scripts/bluetooth/simple-agent hci0 "AA:BB:CC:DD:EE:FF" les lettre de la MAC DOIVENT être en majuscules



  • @Substring J'ai vu ca, je tapais code pin, je ne tombais que sur mon sujet, et en approfondissant un peu, y compris sur le github, je n'ai rien trouvé. Merci de ton aide.
    J'ai tenté de faire la commande en SSH, mais j'ai un message: authentification failed
    J'ai tapé la commande, je lance la commande sur recalbox pour associer, la il me met un message comme quoi, est ce que je veux m'identifier avec un passkey, j'ai beau mettre YES ou NO, il me met erreur d'authentification, a mon avis il me manque une étape.



  • En insistant, j'ai trouvé ceci, mais d'une part, je ne sais pas vraiment si ca peux m'aider dans mon probleme, et de toute façon il me dit "command not found" quand je tape la commande
    hidd --connect aa:bb:cc:dd:ee:ff /etc/init.d/S31emulationstation start



  • @lestatrico hidd niet c'est bluez4 (sous recalbox 4.0), on est a bluez5 sous 4.1



  • @Substring Désolé, je saisi pas ta réponse, je dois changer la commande "hidd" par "bluez5" dans la ligne de commande ?
    je pourrai pas tester de suite, je ne suis plus chez moi pour l'instant.



  • @lestatrico non je dis que hidd est une commande de bluez4 (bluez version 4) mais pas de bluez5 (bluez version 5, il y a eu des changements pajeurs entre ces 2 versions, ce qui m'a obligé à tout réécrire le code recalbox en rapport avec du BT)



  • OK ok, ce sont des choses qui sont bien au dessus de moi, je vous les laissent ^^'.
    Pour en revenir a mon problème de clavier, j'ai restesté plusieurs fois, mais je vois pas ce que je fais mal et pourquoi il me dit que mon authentification n'est pas bonne. Tu as une idée ?



  • @Substring Excuse moi, mais pourrais tu me dire comment tu as fait pour l'authentification pour toi ? As tu eu la question ? J'ai beau tester, il me demande a chaque fois, mais que je mette "yes" ou "no", il me dit "authentification failed".



  • @lestatrico j'ai juste utilisé la commande que je t'ai donnée et il me dit "PIN request:" et hop je saisis. Tu peux me faire un copier/coller depuis la commande stp ?



  • @Substring Bon bah la loose complete, comme par hasard, au moment ou tu me demande de faire un truc, bizarrement, je vois ou je merdais, et franchement je suis juste désolé pour la perte de temps... Je me trompais dans les touches pour activer le bluetooth de mon clavier, c'est Echap+Q, je faisais Echap+A .... Encore désolé....
    Par contre, comment obtenir le code PIN du clavier a rentrer lors de la commande ? La j'y suis, mais je connais pas le code PIN, et a chaque association, il me donne un chiffre différent a 6 chiffres.



  • @lestatrico RTFM ? 😉 ca doit etre marqué dans la doc du clavier


  • Developer
    Global moderator
    Creator
    Team

    @lestatrico souvent c'est de codes bidon style 0000 ou 1234 etc...



  • @Substring je l'ai sous la main le "fucking" manuel ^^, mais rien n'y apparait a part un code PIN donné en exemple, mais il ne fonctionne pas. Je vous ai trouvé le manuel sur le net pour bien prouver qu'il n'y a pas de code pin dessus.
    texte du lien
    @ian57 j'ai testé 0000, 1234, et vu que pour le synchroniser sur les autres appareils, c'est souvent un code a 6 chiffre qu'il me donne, j'ai teste 000000 et 123456, mais rien n'y fait, il me dit "creating device failed: org bluez error: Authentification timeout: Authentification timeout:



  • @lestatrico la doc te dit de taper le code que Bluez est censé te donner ... cf page 7 du manuel



  • @Substring 6958 je l'ai testé, mais j'ai le même message d'erreur précédemment cité 😕



Want to support us ?

198
Online

79.1k
Users

20.3k
Topics

149.1k
Posts