NeoGeo mode AES



  • Bonjour,

    Je parviens à jouer aux jeux Neo Geo mais ceux-ci se lancent en mode arcade (MVS).

    Je place les roms dans le dossier neogeo ainsi que le bios neogeo.zip.

    J'utilise fba_libretro.

    J'ai vu que l'uni BIOS permettrait de choisir le mode mais ça doit se faire jeu par jeu à son lancement.

    Ce que je cherche à faire c'est que mes roms dans le dossier neogeo se lancent automatiquement en mode console (AES).

    J'imagine que remplacer neogeo.zip par aes.zip ne servira à rien.

    J'ai cherché sur le forum et sur Internet mais n'ai pas trouvé de solution.

    Est-ce que ce que je cherche à faire est impossible sous recalbox ?



  • @j2k15 je pense que c'est à faire rom par rom... Après tout y'en a que 162.



  • Moins dans mon cas. Je n'y mets que les jeux sortis sous AES en anglais. ;-)

    Donc la seule solution serait de passer via l'uni BIOS ?

    J'espère au moins qu'il retiendra la dernière config choisie et qu'il démarrera toujours en mode AES.


  • Moderator
    Team
    Creator
    Moderator

    @j2k15 dans le menu retroarch, core options, tu peux dire à fba_libretro de se mettre en mode AES



  • Ah génial ça.
    Il n'y a même pas besoin du bios aes.zip ou de l'unibios ? Tout est supporté en natif dans le core fba_libretro ?



  • @j2k15 Salut, as-tu résolu ton problème? Moi, j'essaie juste de jouer aux jeux neoogeo en version aes notamment pour pouvoir ajuster la difficulté de certains titres et bien que j'ai réglé aes à la place de mvs dans le menu de retroarch, ça ne prend pas effet (alors que l'option free play, elle, fonctionne par exemple...)
    J'ai bidouillé avec les bios mais sans succès...
    Je deviens fou, j'aurai bien besoin d'aide.



    • Make sure your Neogeo Bios contain the UNIBIOS files
    • Start a game
    • set retroarch to UNIBIOS mode
    • save changes to retroarch config file and exit retroarch
    • start a neogeo game
    • in unibios splash screen hold down A+B+C neogeo buttons to access unibios options
    • set unibios to AES/Console mode
    • Voilá
    • repeat last three points one time for each game u like in aes mode.


  • @supernature2k, j'ai testé ce que tu suggères et cela n'a rien donné. Les jeux sont toujours en mode AES.

    @guillaume-morvan, je n'y suis pas encore parvenu. Je vais m'y replonger ces jours-ci.

    @pepe, for my curiosity where would this config be saved ? Is it in the save file of the game ? I'll try what you recommend.



  • J’aie fait quelques tests et avancées hier.

    Il semblerait que le romset (y inclus le BIOS) que j’ai utilisé dans le dossier roms neogeo soit un mame et non un fba.

    Du coup, même si je force le mode à aes via le menu RetroArch Quick Menu -> Options, ça ne sert à rien. D’après ce que j’ai lu cette option aes ne fonctionne qu’avec le BIOS FBA.

    J’ai ensuite passé en mode unibios et mis le BIOS universe 3.2. Là j’ai bien le splashscreen mais la combinaison ABC ne fonctionne pas. Pour entrer dans le menu je devais appuyer sur ABCD.

    Après avoir vérifié le contenu de mon BIOS je remarque qu’il ne contient que l’unibios que jusque la version 2.3 (étonnant donc de me proposer le 3.2). Donc dans le menu RetroArch je choisis universe 2.3 comme BIOS et là ça fonctionne. La combinaison ABC sur le’ splash screen me permet d’entrer dans le menu de la région, du mode, ...

    Je suis donc capable de lancer les jeux en mode AES. La config se sauve dans le fichier de sauvegarde du jeu. J’ai essayé de l’effacer et le jeu s’est ensuite relancé en mode MVS.

    Mes prochaines étapes sont:

    • récupérer un romset FBA et essayer l’option via l’émulateur pour ne pas devoir le faire jeu par jeu
    • configurer les roms du dossier neogeo pour qu’elles ne se lancent qu’en mode aes
    • dans le dossier neogeo enlever les roms sorties exclusivement sur mvs et quand il existe utiliser le rom set ´h’ qui correspond à la version aes (home).

    Merci à tous pour votre aide en tout cas.

    Remarque : dans l’article wiki de l’Unibios il y a une erreur. CAB correspond à YBA du RetroPad / pad snes. Dans le wiki il est noté XBA.

    A gauche Neo-Geo, à droite RetroPad / snes :
    A —> B
    B —> A
    C —> Y
    D —> X



  • J'ai testé avec le bios FB Alpha 0.2.97.40.
    L'option fonctionne maintenant correctement. Plus besoin de régler jeu par jeu.



  • Salut comme à dit le modo mon VDD je confirme que c'est par le menu retroarch qu'il faut passer après l'avoir fait personnellement.



  • Après, je pense finalement lancer le mode AES via Unibios et non pas le menu RetroArch pour la raison suivante:

    Dans le folder neogeo, je compte y placer uniquement les romset sortis sur AES et les lancer en mode AES.

    Dans le folder fba_libretro, je compte y placer tous les Neo Geo et les lancer en mode MVS.

    Vu que j'utilise l'émulateur FBA_Libretro pour le folder neogeo, si je passe les roms en AES, toutes les roms placées dans FBA_Libretro vont aussi se lancer en AES. Ce que je ne souhaite pas.


Log in to reply
 

Want to support us ?

Join us on :

284
Online

29828
Users

14890
Topics

112135
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.