Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Update to latest stable fails



  • Hi guys,
    I'm currently on 4.0 build 15 2016-10-31 and my System keeps telling me "Update available". When applying the Update the System reboots, says "Upgrading the System" and after a few seconds reboots again without any error message and I'm back on 4.0 build 15 2016-10-31. Two questions:

    1. Is there anything I can do about it, besides doing a fresh start?
    2. If not, which folders and files should I backup in order to keep my current config when doing a fresh start with latest stable, besides savegames and roms obviously?

    Thanks for any help!

    edit: found 2 log files:
    upgrade.err.log:
    mount: mounting /dev/root on / failed: Invalid argument

    upgrade.out.log
    Thu Jan 1 01:00:02 CET 1970
    Upgrading /boot
    Thu Jan 1 01:00:04 CET 1970
    Thu Jan 1 01:00:04 CET 1970
    Upgrading /



  • @chaiuwe You have a very strange error ... were you using an official recalbox release ?

    Still, as we've always strongly suggested to use some external storage, you could read https://github.com/recalbox/recalbox-os/wiki/Use-an-external-usb-storage-device-on-recalbox-(EN)

    that's a good way for you to backup easily



  • Thanks for your fast replay @SUBSTRING! Yes I am using an official release, although if I remember correctly the last update I got was the one saying "yolo" in the changelog which was only live for a couple of hours, so dunno about that...
    Thanks for your advise on external storage, gonna look into it! chaiuwe



Want to support us ?

202
Online

55090
Users

18146
Topics

136647
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.