I cannot get wifi to work



  • I'm using recalbox 3.2.11, LAN works. I've tried setting up wifi (I've tried two different adapters) but I still don't get a connection. I've tried exiting emulationstation by pressing F4 but all it does is show me a black screen, pressing alt+F2 afterwards doesn't do anything either. I can SSH via putty though. Based on another post I read, I typed ifconfig -a and then mesg and this is the last few lines I get:   [   26.005793] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1 [  308.401551] usb 1-1.5: USB disconnect, device number 5 [  311.452385] usb 1-1.5: new high-speed USB device number 7 using dwc_otg [  311.570258] usb 1-1.5: New USB device found, idVendor=148f, idProduct=3070 [  311.570327] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3 [  311.570341] usb 1-1.5: Product: 802.11 n WLAN [  311.570352] usb 1-1.5: Manufacturer: Ralink [  311.570362] usb 1-1.5: SerialNumber: 1.0 [  311.652390] usb 1-1.5: reset high-speed USB device number 7 using dwc_otg [  311.762951] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 5390, rev 0502 detected [  311.792082] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 3070 detected [  311.793592] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht' [  311.796026] ieee80211 phy1: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin                          ' [  311.796210] ieee80211 phy1: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.29 [  312.129882] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready So it appears my adapter is detected but not ready, I've typed in the SSID and password in emulationstation but still nothing.   What am I doing wrong?   Also, in kodi I don't see any options to configure any networking type stuff nor do I see an option for bluetooth. Are these features that will be added later? I see the option to update emulationstation which is nice but what about updating kodi?   Thanks



  • Hello can you try to configure your wifi's settings in the recalbox.conf file ? Use a root acces, and edit it with nano (the file is here /recalbox/share/system). You will see a wifi section. you have juste to uncomment the lines SSID/key and add your informations. For information, your wifi key must be in WPA.



  • Yeah, I tried that and I get the same error.



  • Any ideas?



  • I believe the issue is quite simply drivers.  I have two Netgear Wi-fi dongles, one of which runs fine on Raspbian.  However neither of them work with Recalbox.  The simplest solution was to purchase the Edimax EW-7811UN (http://www.amazon.co.uk/gp/product/B003MTTJOY?psc=1&redirect=true&ref_=oh_aui_detailpage_o00_s00) Wi-Fi dongle which works flawlessly.   There may be other Wi-Fi dongles which work but I haven't seen a definitive list of them.  Hopefully however future releases will include more drivers.  If I knew how to port the working drivers from Raspbian to Recalbox (Archlinux) I would do this.  🙂   <p class="MsoNormal"></p>



  • I bought the edimax dongle and wifi still doesn't work.   [quote][    4.992254] smsc95xx 1-1.1:1.0 eth125: renamed from eth0 [    5.042654] udevd[105]: renamed network interface eth0 to eth125 [    5.042830] smsc95xx 1-1.1:1.0 eth1: renamed from eth125 [    5.112473] udevd[105]: renamed network interface eth125 to eth1 [    7.998387] usbcore: registered new interface driver rtl8192cu [    8.008604] rtl8192cu 1-1.2:1.0 wlan124: renamed from wlan0 [    8.032640] udevd[106]: renamed network interface wlan0 to wlan124 [    8.032804] rtl8192cu 1-1.2:1.0 wlan2: renamed from wlan124 [    8.062287] udevd[106]: renamed network interface wlan124 to wlan2 [   14.794051] smsc95xx 1-1.1:1.0 eth1: hardware isn't capable of remote wakeup [   14.794240] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready [   16.356857] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready [   16.357758] smsc95xx 1-1.1:1.0 eth1: link up, 100Mbps, full-duplex, lpa 0xC5E1 [   19.177763] IPv6: ADDRCONF(NETDEV_UP): wlan2: link is not ready [   31.042603] smsc95xx 1-1.1:1.0 eth1: hardware isn't capable of remote wakeup [   31.144387] smsc95xx 1-1.1:1.0 eth1: hardware isn't capable of remote wakeup [   32.803747] smsc95xx 1-1.1:1.0 eth1: link up, 100Mbps, full-duplex, lpa 0xC5E1 [ 1063.547887] Transfer to device 6 endpoint 0x1 frame 699 failed - FIQ reported NYET. Data may have been lost.[/quote]



  • Is the SSID or password anything special?  I changed mine so both only contained alphanumeric characters and that worked for me.



  • Yeah indeed, in the french section, we had a guy with wifi problems. He was using a Edimax EW-7811UN dongle and he couldnt connect to his network. The problem came from his wifi network. Your SSID must not be "invisible", must not contain special characters or spaces. Use the same rules for your wifi key (in my case, a WPA-PSK/TKIP).



  • Yeah, my wifi is hidden and my SSID includes and underscore. I tested the wifi with a less complex SSID and pass and it worked. Will wifi ever work with a hidden SSID and special characters?   Also, is there anyway to make wifi connect automatically? Wifi under network settings shows it's enabled but it never works unless I disable it first, exit out and then re enable it and exit using the onscreen menu button for "back", using "A" from the keyboard doesn't enable wifi when I exit.


Log in to reply
 

Want to support us ?

301
Online

81.4k
Users

22.3k
Topics

161.5k
Posts