Recalbox 7.0

N64 Emulator an DVI Monitor bleibt schwarz, Musik läuft weiter



  • Hallo,

    ich bin neu hier im Forum und auch mit der Recalbox. Ich habe an meinem Raspi 3 einen HDMI auf DVI Adapter und einen 19" DVI Monitor hängen. Wenn ich den N64 Emulator starte, bleibt dieser schwarz und ich höre nur die Musi. Will ich zurück zur Emulatorstation, so geht das über meinen Controler, aber auch hier bleibt der Bildschirm schwarz. Ich habe folgende Einstellungen:

    ## Set game resolution for emulators
    ## select your mode from the command : tvservice -m [MODE]
    ## CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 
    ## CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    ## use 'default' for using the default resolution
    ## (string)
    global.videomode=Default
    
    
    ## N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution)
    ## So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI).
    ## If your screen if not compatible with one of these video modes, please check the recalbox's wiki.
    n64.videomode=DMT 4 HDMI
    ## If you are using a CRT screen, please change the setting above with this one : 
    # n64.videomode=default
    

    Könnt Ihr mir weiterhelfen?

    Vielen Dank!


  • Developer
    Team
    Global moderator
    Translator

    Unbegründet sollte man nie irgendwelche Einstellungen ändern. Da steht eindeutig, dass default nur für crt's ist.

    https://github.com/recalbox/recalbox-os/wiki/Verbinde-deine-recalbox-mit-einem-DVI-Bildschirm-(DE)



  • In meiner Config.txt habe ich auch das so gemacht, wie es im link beschrieben ist. Darüber hinaus habe ich beider Group DMT verwendet und bei Mode 35, was zu einer deutlich besseren und schärferen Darstellung des Menüs geführt hat. Dennoch sobald ich den Nintendo N64 Emulator starte passiert es, dass er mir kurz das Bild mit der release von der recalbox zeigt, dann umschaltet und das war´s.



  • Moin @Onkel_Hotte.

    Als "Neuling" solltest Du dringend die WICHTIG - Bitte erst Lesen! Sektion verinnerlichen. Vor allem die REGELN und BENUTZUNG

    Danach solltest Du das Wiki richtig lesen 😉

    Ich möchte Dich bitten, den global.videomode auf den "prefered Mode" deines TV einzustellen und den n64.videomode in der Standard-Einstellung lassen. Siehe dazu DIESEN LINK (Englisch)

    Gib danach mal bitte eine Rückmeldung, oder gib Bescheid, wenn Du weitere Hilfe benötigst.



  • Hallo Nachtgarm,

    zunächst vielen Dank für Deine Antwort. Ich habe mich durch die Wikis gearbeitet und bin irgendwie nie zu irgendeinem Ergebnis gekommen. Ich habe nun die Einstellungen im Emulator zurückgesetzt und die globalen Einstellungen nach Auslesung mit tv mode herausgelesen. Es ist der DMT 35, den ich auch in den globalen Settings und der Config drinnen stehen habe. Sobald ich aber ein ROM über den N64 Emulator starte wird das Bild schwarz, die Musik läuft und ich muss das Netzteil ziehen, um einen Neustart zu generieren, den bei Rückkehr in die Emulationstation bleibt der Bildschirm auch schwarz.

    Ich bin nicht der, der sonst sofort einen Post aufmacht. Nur nach 3 Abenden und einer Menge Internet und viel Unwissenheit, was Linux angeht, war ich leider am Punkt angekommen, mal zu fragen. Wenn ich Regeln missachtet habe dann sorry. War keine Absicht.



  • Moin @Onkel_Hotte

    Der Hinweis auf die Regeln, etc. war nur ein Hinweis darauf, dass Dir eben genau das nicht passiert als Neuling, also keine Sorge: Alles gut 🙂

    Du sagst "in den globalen Settings und der Config". Was genau meinst Du damit?
    Den Video Modus trägst Du nur unter global.videomode in die recalbox.conf ein, sonst lässt Du alles auf Standard.

    Sprich global.videomode = DMT 35 DVI

    Hast Du die Modi mit DMT und CEA ausgelesen?



  • Ich habe beide Modi ausgelesen. Mir wurde der DMT 35 als Favorit vorgeschlagen. In der config.txt, die ich beim Booten editieren kann, habe ich nach Anleitung (ich glaube sogar von hier) folgendes stehen:
    hdmi_group=2
    hdmi_mode=35

    Ergebnis war dass die Schrift beim booten 4.0-rpi... plötzlich scharf ist.
    Starte ich aus dem es ein Rom, so sehe ich kurz nochmal den 4.0-rpi usw. Schriftzug und dann wird mein Bildschirm leider schwarz. Habe überlegt, nochmal das Image zurückzusetzen, um ggf. noch mal bei null auf Fehlersuche zu gehen.



  • So, ich habe den Raspi neu aufgesetzt. Leider ist das Phänomen immer noch das gleiche. Ich habe nix geändert. Wenn ich nun TV Service aufrufe bietet er mir im DMT nur den Mode 4 mit 640x480 an. Ich verzweifel langsam. Bin schon drauf und dran mir einen HDMI auf VGA Adapter zu kaufen, um dem Problem aus dem Weg zu gehen.



  • Moin!

    Das klingt alles sehr abenteuerlich. Ich nutze selbst auch ein HDMI -> DVI Kabel an meinem Bartop und habe auch DMT 35 aktiv und es lauft alles ganz hervorragend.

    recalbox.conf

    global.videomode=DMT 35 DVI
    ...
    n64.videomode=DMT 4 HDMI
    

    config.txt

    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    disable_overscan=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # comment to get jack audio
    #hdmi_drive=2
    
    config_hdmi_boost=0
    


  • Moin Moin,

    ich weiß, komische Sache. Habe auch das Kabel im Verdacht. Mal schauen was mit dem VGA Adapter passiert. Werde aber vorher nochmal deine Settings testen. Was mich am meisten wundert ist, dass ich mittlerweile nicht mal mehr die tvservice Werte ausgelesen bekomme. Denke da scheint die Kommunikation zwischen raspi und Monitor gestört zu sein.



  • @Onkel_Hotte Das klingt für mich nach defektem Adapter, oder Kabel. Stelle bitte sicher, dass dein HDMI ein ganz normales ist und nicht Netzwerk integriert hat, oder nimm gleich das hier: LINK



  • ich weiß nicht warum und ich kann es auch nicht erklären aber alles läuft auf einmal. Keine Ahnung. Danke für Eure Hilfe!!!



Want to support us ?

184
Online

79.1k
Users

20.3k
Topics

149.0k
Posts