Recalbox 7.0

Unable to save scrape results



  • Hello, First of all, thanks for creating Recalbox, it's really good 🙂 Only issue I've had so far it's that once I scraped the games, when I reboot the Raspberry, all the data it's lost. I think that I'm missing something... maybe it's very obvious, I don't know.



  • Are you doing this manually (pressing select) or via the scraper option in the menu?



  • Via the scraper option in the menu. Anyway, I've succeeded in doing it by modification of gamelist.xml. This is what I found in the file: <?xml version="1.0"?> <gameList /> I've replaced it with <?xml version="1.0"?> <gameList> </gameList> And then I was able to save the scrape results. Another problem was that I was unable to find the gamelist before because on a mac an EXT4 partition it's not recognized... I've solved it by using Fuse for OS X. But now I'm trying to scrape manually (pressing select), for a few games I could not scrape via the menu. And I failed to save the results again. Tried to edit the files directly on gamelist.xml, and failed again.



  • That's really interesting. There is a way to scrape using a PC and then save the results to Recalbox and this appears to work flawlessly. I even created a batch file to do this for all my roms but admit I haven't checked the output in gameslist.xml. I've not experience any issues using the scraper in the menu, however, I'm going to remove the scraped data for all my PSX games and then see what happens when you scrape the files manually. If you are correct in that it resulting gameslist.xml does not contain the line <gameList> this explains why it doesn't work when you reboot. 🙂



  • I've been running a few tests with interesting results. For me, scraping with the menu option works fine. I select the matching game and after exiting the scraper I can see the amendment in the gamelist.xml file. Cool. However, and this bit was quite interesting, if you scrape a game manually (via the select button) and you do the same it does not amend the gamelist.xml file or create one if you haven't scraped previously. If you then go back to the scraper in the menu and scrape just one game, the gamelist.xml updates with that game and the details of the games you scraped manually! Also saves manual scrapes of folders which is something that's bugged me for ages. So, in conclusion, the gamelist.xml file is only saving after a 'menu scrape'. 🙂 I've not been able to replicate the issue you experienced where either <gamelist> or </gamelist> was missing from the gamelist.xml file. Everything looks fine.



  • Well, it seems I was unable to save using the menu because it only works if you quit ES pressing F4 on the keyboard. I had not the keyboard attached the last time, quitting with the quitting menu doesn't save the scrapes (weird, if you ask me). Anyway now i can save the scrape either manually or using the menu, but I'm still unable to edit game list.xml, maybe because I should use a specific software, I don't know.



  • I have the same issue. When scrapping, either one game or one system, it no loner saves the results. I successfully scrapped snes, fba, genesis, but NES never saves the results after a reboot of my RPI2. Possibly related, maybe not, but when I use the GUI to change my wifi info it also doesn't save after a reboot. Manually editing the cfg file does work though.   I'd like to edit the gameslistxml file but it doesn't appear to be accessible from windows either via samba or directly reading the memory card. I also cannot exit to a command prompt although I can connect via putty.



Want to support us ?

189
Online

79.1k
Users

20.3k
Topics

149.1k
Posts