Recalbox 7.0

Keyboard default mapping issue



  • Hi everyone!

    I noticed while playing textadventures using a usb-keyboard that the Q and W keys seem to be mapped very strangely by default. In some emulators like the zx spectrum they just don't work at all, in others like the amstrad cpc pressing Q types in "CAT" and W resets the emulator. All the other keys work fine it is just Q and W.

    Anyone knows what causes this?


  • Banned

    @boelze the emulators are configured like that by defaut but I agree it's not good at all for computer games... Especially for the CPC emulator which already allow us to use the virtual keyboard to type special commands like CAT.



  • @voljega thank you for the quick response!
    I see. Is there a way I can remap those two keys by myself? I looked through the config files but could not find anything regarding keyboard inputs besides the emulation station menu.


  • Banned

    @boelze If it is possible it would be into the specific configuration files for the emulator, not into recalbox itself.

    And those files would possibly be generated automatically by configgen at each launch of the emulator... so it seems pretty difficult.

    Maybe @rockaddicted or someone else from the team could tell us if it is feasible or not...

    Also you could enter an issue in the emulator github to ask if it is feasible or if it coule be implemented :
    https://github.com/libretro/libretro-cap32



  • Humm it is a known problem with retroarch about keyboard/gamepad management.
    Maybe by deactivating all gamepads in retroarch and allocating keyboard on player could solved this issue... Don't know, must be tried.
    You can ask to libretro/retroarch team/community, they will be more informed that me.
    The have have a forum/irc channel.

    If you find informations to solve this issue, make us a feedback 😉



Want to support us ?

122
Online

79.1k
Users

20.4k
Topics

149.2k
Posts