PS3 Gasia controller not pairing with RB 4.0.0

  • Hi everyone,

    Thanks for this amazing project!

    I'm trying to pair my PS3 Gasia controllers with Recalbox 4.0.0, and facing some difficulties. Those controllers worked fine with RB 3.2 with some adjustments 😉

    What I have done:

    • reset the controllers
    • edited recalbox.conf for Gasia controllers (see below)
    • followed pairing process

    Am I missing something obvious? Thanks in advance for the support!


    Dec  6 21:17:27 RECALBOX kernel: [ 1168.127425] usb 1-1.2: new full-speed USB device number 14 using dwc_otg
    Dec  6 21:17:27 RECALBOX kernel: [ 1168.230708] usb 1-1.2: New USB device found, idVendor=054c, idProduct=0268
    Dec  6 21:17:27 RECALBOX kernel: [ 1168.230743] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    Dec  6 21:17:27 RECALBOX kernel: [ 1168.230756] usb 1-1.2: Product: PS(R) Gamepad
    Dec  6 21:17:27 RECALBOX kernel: [ 1168.230767] usb 1-1.2: Manufacturer: Gasia Co.,Ltd
    Dec  6 21:17:27 RECALBOX kernel: [ 1168.241859] input: Gasia Co.,Ltd PS(R) Gamepad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0/0003:054C:0268.000B/input/input9
    Dec  6 21:17:27 RECALBOX kernel: [ 1168.245920] sony 0003:054C:0268.000B: input,hiddev0,hidraw2: USB HID v1.11 Joystick [Gasia Co.,Ltd PS(R) Gamepad] on usb-3f980000.usb-1.2/input0
    Dec  6 21:17:43 RECALBOX kernel: [ 1184.021206] usb 1-1.2: USB disconnect, device number 14
    Dec  6 21:17:51 RECALBOX daemon.err bluetoothd[309]: Refusing input device connect: No such file or directory (2)
    Dec  6 21:17:51 RECALBOX daemon.warn bluetoothd[309]: Can't find device agent
    Dec  6 21:17:51 RECALBOX daemon.err bluetoothd[309]: input: authorization for 00:1A:7D:DA:71:0E failed: Operation not permitted (-1)

    recalbox.conf (controller section):

    # -------------- D - Controllers ----------------- #
    # Enable support for standard bluetooth controllers
    ## Please enable only one of these
    # -------------- D1 - PS3 Controllers ------------ #
    ##Enable PS3 controllers support
    ## Choose an driver between official, shanwan and gasia if you have dualshock clones (official,shanwan,gasia)
    # ------------ D2 - XBOX Controllers ------------ #
    ## Xbox controllers are already supported, but xboxdrv can solve some compatibility issues
    ## Enable xboxdrv driver, disable this if you enabled ps3 controllers (0,1)
    ## Set the amount of controllers to use with xboxdrv (0..4)
    # ------------ D3 - GPIO Controllers ------------ #
    ## GPIO Controllers
    ## enable controllers on GPIO with mk_arcarde_joystick_rpi (0,1)
    ## mk_gpio arguments, map=1 for one controller, map=1,2 for 2 (map=1,map=1,2)
    ## DB9 Controllers
    ## Enable DB9 drivers for atari, megadrive, amiga controllers (0,1)
    ## db9 arguments
    ## Gamecon controllers
    ## Enable gamecon controllers, for nes, snes psx (0,1)
    ## gamecon_args
    ## XGaming's XArcade Tankstik and other compatible devices

  • I would love to provide more information if you point me where to find it.
    Feel free to ask for details, as I said, I'm probably missing something.


  • @leriton Check all the drivers. GAsia pads are the most complicated ones as they really have their very own protocol that only partly complies with the genuine PS3.

    Remember to plug the pad on USB for a good 10 seconds. The pad should rumble after a while. Once it rumbles, unplug it, and press the home button.

    Please try the official driver as it has a few hacks for gasia.

  • Will try this, thanks for your suggestion.

    Those exact same controllers works with Recalbox 3.2 using Gasia sixad binaries, see this thread (french) :

    Is it possible that Gasia drivers suddenly stopped to work for my controllers?

  • @leriton the drivers evolved since 3.2, that is the real reason. The official driver works with my gasia pad, i guess ypu are not as lucky as me

  • And now it works with official drivers! Thanks a lot for your help, really appreciate.


Want to support us ?