Recalbox qui s'allume tout seul...



  • Bonjour,

    J'ai créé un bartop arcade avec à l'intérieur un raspberry pi3 et Recalbox v4.

    Pour une question pratique, j'ai cablé le gpio 5-6 avec un simple bouton poussoir. (j'appuie = fermé, je relache = ouvert)
    J'ai activé le script pushMACHINCHOSE dans recalbox.conf et tout fonctionne convenablement sauf que de temps en temps ben mon bartop s'allume tout seul sans que j'appuie sur le bouton.

    C'et très variable, cela peut tenir quelques jours éteint jusqu'à quelques heures...

    Bref, une idée, une piste ?


  • Staff
    Developer
    Team
    Creator
    Global moderator

    @tong-man

    Un petit problème de masse?

    Tu as bien activé le script pin56push et non pas pin56onoff?



  • @tong-man le premier cas de possession d'un pi Recalbox ...

    En général c'est plutôt l'inverse : le bartop qui s'éteint tout seul 😮



  • lol, dans ce cas je vais de ce pas faire venir un exorciseur !

    oui j'ai bien activé le script pin56push...

    J'ai essayé le pin56onoff au cas ou ca créé un autre bug : quand je veux redémarrer recalbox par les menus, il s'éteint, ce qui semble normal étant donné que le bouton est relâché il considère la machine éteinte... ^^

    j'ai vérifié et je n'ai pas de pb de masse non plus.

    et pas d'extinction inopiné à déplorer.

    Je vais essayé de remplacer le bouton



  • @tong-man
    Salut,
    un peu pareil chez moi (mais avec un swith configuré "pin56onoff") la borne s'allume toute seule si un autre appareil est démarré en même temps. Même en ayant repiqué la masse du Pi à plusieurs endroits dans la bartop, changé la multiprise qui accueille les différents éléments à l'intérieur, branché ailleurs chez des potes,...
    Le plus dérangeant est surtout qu'elle s'éteint toute seule aussi quand on branche un appareil sur le même réseau électrique, en résulte un grand moment de désolation...

    Ce qui est pratique par contre, c'est que quand je veux boire un jus de fruits frais et
    faire une partie, il me suffit de mettre mon mixer en route. 1min plus tard quand les fruits sont mixés, Recalbox a pris le temps de démarrer et tout est prêt pour jouer !

    Remarque c'est mieux comme ça plutôt qu'à l'inverse : ça me prendrait la tête si mon four se mettait en route à chaque fois que je veux jouer.
    🙂


  • Banned

    @poumtaq ah ouais quand même :)))



  • @poumtaq tu n'aurais pas des micro coupures sur ton secteur ?



  • @Substring je ne pense pas, tout fonctionne normalement, je ne suis pas sûr d'avoir le matos pour détecter ça, si tu as une piste je peux essayer.
    Ca arrive uniquement quand un appareil est branché sur le même circuit électrique que la borne (ex: toutes les prises du salon sont concernées, pas celles des chambres).
    Ca vient vraiment de la borne car c'est pareil à chaque fois que je l'emmène chez des potes...

    Par contre cela cesse quand je déconnecte les gpio.



  • @poumtaq effectivement, je n'avais pas fait le rapprochement, mais dés que j'allume un chauffage par exemple, un coup sur 2 ma borne s'allume lol

    c'est peut être un léger bug dans le script....

    lorsque je désactive le script du gpio, jamais la borne ne s'allume seule... xD

    EDIT : je ne sais pas comment est codé le script d'allumage, mais ne peut on pas y ajouter une tempo sur le temps d'appui sur le bouton ? genre on appuie 2 secondes dessus pour l'allumer. cela contournerai peut etre le problème des micros impulsions généré par d'autres appareils à proximité de la borne.



Want to support us ?

224
Online

82.0k
Users

22.5k
Topics

162.9k
Posts