Recalbox 7.0

Bloquear opcines



  • Existe alguna opción para bloquear opciones. Tengo una máquina con Recalbox 4.0 y el problema es que cada 2x3 llegan los pequeños y se meten donde no deben. Vamos que me montan unos líos importantes. Por ejemplo eliminar , acceder a los menús de configuración...
    0_1484262027351_Arcade 3.jpg
    Gracias por adelantado


  • Developer
    Team
    Global moderator
    Translator



  • Muchas gracias. Ya he quitado el menú principal y he tenido que desactivar el Hotkey para que no accedieran a Retroarch. Ahora el problema es que no puedo salir sin un teclado. ¿Se puede configurar un botón (ahora me "sobra el que hacia de Hotkey) para que haga esa función?

    Gracias


  • Developer
    Team
    Global moderator
    Translator

    La funcion para salir del emulador no se desactiva. Tiene que seguirte funcionando a menos que hayas hecho algo mal.

    For emulators :
    By setting the system.emulators.specialkey to nomenu you will disable the access to emulators menus
    By setting the system.emulators.specialkey to none you will disable all specials keys in games except the exit combination.



  • Esto son los camibios que hice:

    1.He dejado recalbox.conf de la siguiente forma:

    EmulationStation menu style

    default -> default all options menu

    none -> no menu except the game search menu

    bartop -> less menu, only needed for bartops

    system.es.menu=none

    Emulator special keys

    default -> default all special keys

    nomenu -> cannot popup the emulator menu

    none -> no special keys in emulators

    system.emulators.specialkey=none (también usé nomenu)

    Show or hide kodi in emulationstation (0,1)

    kodi.enabled=0

    Start kodi at launch (0,1)

    kodi.atstartup=0

    set x button shortcut (0,1)

    kodi.xbutton=0

    Se supone que así no se habilitan los menús, ni kodi y no se puede acceder a los menús de retroarch. Pues me acceden a Retroarch.

    1. Configuré los botones sin habilitado ninguno para HOTKEY, pero sigue activo, con lo que pueden acceder a Retroarch.

    3.Accedí a /recalbox/share/system/configs/retroarch/retroarchcustom.cfg y lo que hice fue cambiar la línea input_enable_hotkey_btn = 8 por 9 (botón que no existe), quedando input_enable_hotkey_btn = 9. Con ello se deshabilita la opción de HOTKEY y de acceder a retroarch, pero sigo teniendo el problema de salir de las emulaciones, ya que ESC tiene que ser por teclado.

    ¿Existe algún archivo donde pueda indicar que ESC es el botón 8 (ahora lo tengo libre), haciendo la función del teclado?


  • Developer
    Team
    Global moderator
    Translator

    Para empezar, no entiendo como podrias acceder al menu de retroarch si no tenes una HK asignada...??? Si pretendes poder salir de los emuladores con el combo, si o si necesitas configurar la HK. Ponela sobre SELECT. La HK es el unico "boton" que puede ser asignado sobre otro ya existente.
    Sobre la edicion manual de la configuracion, no tengo idea. Nunca lo he tocado.


  • Banned

    This post is deleted!


  • @paradadf pues en esas estóy. No entiendo cómo dejando el archivo recalbox.conf de la siguiente manera:

    EmulationStation menu style

    default -> default all options menu

    none -> no menu except the game search menu

    bartop -> less menu, only needed for bartops

    system.es.menu=none

    Emulator special keys

    default -> default all special keys

    nomenu -> cannot popup the emulator menu

    none -> no special keys in emulators

    system.emulators.specialkey=nomenu (he usado none)

    me accede al menú de retroarch.


  • Developer
    Team
    Global moderator
    Translator

    @jfmonge yo creo que desconfiguraste algo haciendo el mapeo manualmente. Antes me dijiste que habias quitado la HK pra no acceder al menu de retroarch y que necesitabas ESC para salir. Deja la configuracion de la HK como viene por defecto.
    Y me sigue quedando ma duda... que apretas para entra al menu de retroarch (HK+B) si no tenes la HK configurada? Estas hablando de algun emulador en especial? Mame2003 por ejemplo tiene el menu de configuracion presionando R2 o TAB en el teclado. Estoy empezando a suponer que te referis a ese menu y no asi al de retroarch. Si ese fuera el caso, no se si hay alguna opcion para desactivarlo, probablemente si.



  • @Phantis nada. Pensé que al tocar ahí se modificaba algo pero no. Ahora lo tengo todo bloqueado y sólo me quedaría poder configurar el botón que tengo libre (el que hasta ahora servia para acceder a Hotkey) para que haga la función de escape



  • @paradadf me refiero al menú retroarch. Finalmente he configurado los botones sin poner ningún HK y dejado recalbox.conf sin menús. Así no acceden ;). Ahora buscaré alguna manera para configurar la GPIO de Raspberry para que interprete el botón que me queda libre como ESC.


  • Banned

    This post is deleted!

Log in to reply
 

Want to support us ?

133
Online

79.1k
Users

20.3k
Topics

149.1k
Posts