Moonlight - Black screen



  • Hi guys. Sorry if this has been answered already. My internet connection sucks and I cant do a good search for potential answers. I'm running GEForce Experience 3.2.0.96, latest stable Recalbox on an RPi3. I have followed the tutorial to get moonlight paird and scraped. I have paired successfully and scraped successfully. Moonlight now shows in the menu of Recalbox and it has a 'Steam' entry there. Going into Steam I get only a black screen on the rpi3 recalbox end. My computer opens Steam in big pic mode and I can control it with the controller and also get audio.

    The connection between RPi3 and computer is rubbish though. WiFi with not much throughput. I cant cable at the moment. Before I get too invested in trying to troubleshoot things, is the poor connection the likely cuplrit? Or is the version of moonlight (2.2.2) not compatible with this version of GFE (3.2.0.96), which is what I have read elsewhere?

    Thanks in advance.


  • Moderator
    Team

    @spastic Hi
    You need to downgrade GFE, this version is not compatible with moonlight 2.2.2



  • Thank you. Can you advise a suitable version? I did try downgrading to 2.2.2.0, 2.2.3.0 and 2.11.4.0 but my video card doesnt seem to be supported in these versions. Video card is fine in 3.2.0.96 though.



  • Update: Version 3.1.2.31 works fine. Thank you @Substring



  • @spastic said in Moonlight - Black screen:

    3.1.2.31

    I'm having the same issue as above. Does anyone have a good link for downloading the older 3.1.2.31 version? The oldest one I'm finding on nvidia's site is 3.2.0.96.



  • @trantornator http://www.filehorse.com/download-nvidia-geforce-experience/old-versions/ here you can find all old version from GFE, if testet. 5 of them

    GeForce_Experience_v2.11.4.0,
    GeForce_Experience_v3.0.5.22
    GeForce_Experience_v3.0.6.48
    GeForce_Experience_v3.0.7.34
    GeForce_Experience_v3.1.2.31

    No one works with Moonlight Embedded 2.2.2 for me. Evertime i get the same Error :

    Failed to initialize libcec interface
    Initializing platform...done
    Resolving host name...done
    Starting RTSP handshake...RTSP: Failed to connect to UDP port 48010
    failed: -1

    I got a blackscreen on my Pi and that erroro in mit SHH Putty Client.

    Using Windows 10 x64 and a new installation off Recalbox 4.0 Final.



  • Hello,

    Sorry for bringing this topic back to life.

    I am currently running recalbox 17.12.02 and moonlight 2.2.2

    I have tried GEF 2.11.2 up to and currently 3.0.4. In total I have tried about 8 different versions. This includes 3.11 which works just the same.

    If I click on the moonlight emulator and the stream file inside the emulator. It will take me to the loading screen which is black, recalbox logo at the bottom and the version to the left. This is then stuck on that screen.

    I am however able to then log into the Pi 3 using putty and run the command "moonlight stream"

    For me this gets everything how I would expect it to be. Screen on, controller working and sound. If I then leave the stream, I go back to the black screen, at this point I have to re-start the Pi in under to go back to the emulation selection screen.

    Is there a command I can create which would run the "moonlight stream" when I click on a file inside the moonlight emulator folder. The only issue is that it needs to enter the loading screen for it to show the screen.

    If I just ran the "moonlight stream" command anywhere such as the home screen, the sound will come through, the computer and controller will kick in to play but the screen won't show. I can just leave the stream and everything works fine again.


  • Moderator
    Team

    @squeekjjy you should have started your own topic ... The real deal would be to find why moonlight doesn't launch your games.


Log in to reply
 

Want to support us ?

Join us on :

303
Online

26884
Users

13857
Topics

105396
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.