Hotkey not working in N64 emulation



  • Hello everyone,

    I am using recalbox since this day and so far am really loving it on my RP3.b.

    As my BT Dongle (Delock Bluetooth 4.0 USB Adapter) is still on its way, I am using my 8bitdo NES Pro controller connected to USB. I configured the Hotkey to be L3.

    Everything seems to be working really good, but the Hotkey seems not be recognized when running the N64 emulation. This really sucks, as the only way to go back to the recalbox main menu is cutting the power of the Rasperry Pi.

    I would really appreciate any advice, what I should change to get the thing working.

    Another question that arose is, if it is possible to select the shader to be used in the Archretro menu (I really hate click through all 60 available shaders...).

    Thanks for your help!

    Merry Christmas and happy Retro Gaming!



  • @Ares2502 hi !
    I have no problem with the hotkey in N64. Is your pad the only one ? No.other is plugged ? We never set hotkeys for olayers ither than the first one



  • @Substring

    Thanks for answering.

    Yes, the Controller is the only gamepad connected at the moment.



  • @Ares2502 need to see your ~/configs/mupen/mypen64config.ini, something like that



  • Could you explain me how to get this information after I connected to recalbox using putty?

    0_1482664586212_upload-17521c01-406a-47c3-bd3d-1fb54cebcb3f



  • Found it. There is no such file in that directory.

    0_1482664899936_upload-1fa0880f-db17-4839-b89e-101b56e67bdc



  • @Ares2502 i said "something like that" because i don't quite remember the name of the file. But it's for sure in ~/configs/mupen or ~/configs/mupen64



  • Hmm... There is no directory ~/configs/mupen. And in the mupen64 is no files like this (See screenshot above).

    Found this:

    0_1482670915999_upload-bf47c8fd-ee1e-4b92-b6fd-7d1ad67dc209

    in recalbox/system/configs/mupen64

    Is there the file you need?



  • This is the InputAutoCfg.ini

    [Bluetooth Wireless Controller ]
    plugged = True
    plugin = 2
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    Mempak switch =
    Rumblepak switch =
    mouse = False
    A Button = button(1)
    B Button = button(4)
    C Button D = axis(3+)
    C Button L = axis(2-)
    C Button R = button(0) axis(2+)
    C Button U = axis(3-) button(3)
    DPad D = hat(0 Down)
    DPad L = hat(0 Left)
    DPad R = hat(0 Right)
    DPad U = hat(0 Up)
    L Trig = button(6)
    R Trig = button(7)
    Start = button(11)
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)
    Z Trig = button(8)

    Other files in the directory would be:

    0_1483460424568_upload-13645fcc-93f9-4db8-a92b-9876d1bba51d

    Any help would be great... What I tried was renaming the CFG to *.bak to see if a new created one would solve the issue. (Without success).

    Btw: The controller settings seem to be messed up quite a bit... Left on the left analog stick is not working neither....

    Other emulators are still running great.



  • My response I'm sorry won't be helpful, I'm hoping you may have stumbled across the answer.. I deleted my n64 setup after dealing with this problem for a while. Even after I edited the config with root access and terminal, the config always reverted to its defaults. I hope someone helps us.


Log in to reply
 

Want to support us ?

228
Online

81.5k
Users

22.3k
Topics

161.7k
Posts