Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[Moonlight] You must pair with the PC first



  • Bonjour,

    Moonlight fonctionnait très bien jusqu'à aujourd'hui.

    En effet, depuis recalbox, lorsque je lance un jeu, il revient de suite sur le menu moonlight

    Je me suis connecté en shh sur mon rpi2, pour réapairer GFE et moonlight, aucun soucis :

    # ./Moonlight.sh list
    Moonlight Embedded 2.2.2 (EMBEDDED;CEC;PI)
    Too many options: No such file or directory
    Moonlight Embedded 2.2.2 (EMBEDDED;CEC;PI)
    Searching for server...
    Connect to 192.168.1.22...
    NVIDIA GeForce GTX 950, GFE 3.1.2.31 (protocol version 7)
    1. Steam
    2. Injustice: Gods Among Us
    3. Bastion
    4. Mortal Kombat X
    5. No Man's Sky
    6. Batman: Arkham Knight
    7. Battlefield 1
    8. Child of Light
    9. Trine 2
    10. Heroes of the Storm
    11. Project CARS
    12. Overwatch
    13. Guild Wars 2
    14. Project Zomboid
    15. Battlefield 3
    16. Project Zomboid
    17. Street Fighter V
    18. Tom Clancy's The Division
    

    Pourtant lorsque je lance un jeu voici les logs :

    # sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)
    You must pair with the PC first
    

    Merci par avance pour votre aide.

    Ce que j'ai tenté :

    • effacer tous les périph depuis GFE
    • effacer le dossier keydir dans recalbox
    • réapairer le tout en suivant la procédure du wiki avec succés
    • init moonlight avec succés
    • rebooter tous le pc et recalbox
    # avahi-browse -prt "_nvstream._tcp"
    +;eth0;IPv4;3\.1\.2\.31-HTPC-SALON-PC\.f136fd1f-2384-4f00-a5fa-18718e71bbfc;_nvs                                              tream._tcp;local
    =;eth0;IPv4;3\.1\.2\.31-HTPC-SALON-PC\.f136fd1f-2384-4f00-a5fa-18718e71bbfc;_nvs                                              tream._tcp;local;HTPC-Salon-PC.local;192.168.1.22;47989;
    

    Pourtant tout semble nickel 😞

    idem je tourne en boucle.

    EDIT : Je viens de désinstaller/réinstaller GFE et idem.

    Voici mon fichier moonlight.conf, y voyez vous une erreur svp ?

    ## Hostname or IP-address of host to connect to
    ## By default host is autodiscovered using mDNS
    #address = 
    
    ## Video streaming configuration
    width = 1920 height = 1080fps = 60
    
    ## Bitrate depends by default on resolution and fps
    ## Set to -1 to enable default
    ## 20Mbps (20000) for 1080p (60 fps)
    ## 10Mbps (10000) for 1080p or 60 fps
    ## 5Mbps (5000) for lower resolution or fps
    bitrate = -1
    
    ## Size of network packets should be lower than MTU
    #packetsize = 1024
    
    ## Default started application on host
    #app = Steam
    
    ## Default used mapping for streaming
    ## Searched for in $XDG_DATA_DIRS/moonlight or /usr/share/moonlight and /usr/local/share/moonlight
    ## Mapping can also be user overrided in $XDG_CONFIG_DIR/moonlight or ~/.config/moonlight or current directory
    #mapping = mappings/default.conf
    
    ## Enable selected input devices
    ## By default all available input devices should be used
    ## Only evdev devices /dev/input/event* are allowed
    ## To use a different mapping then default another mapping should be declared above the input
    #input = /dev/input/event1
    
    ## Let GFE change graphical game settings for optimal performance and quality
    sops = true
    
    ## Play audio on host instead of streaming to client
    #localaudio = false
    
    ## Select audio device to play sound on
    #audio = sysdefault
    
    ## Select the audio and video decoder to use
    ## default - autodetect
    ## omx - hardware video decoder for Raspberry Pi
    ## imx - hardware video decoder for i.MX6 devices
    ## sdl - software decoder
    ## fake - save to file (only available in debug builds)
    #platform = default
    
    ## Directory to store encryption keys
    ## By default keys are stored in $XDG_CACHE_DIR/moonlight or ~/.cache/moonlight
    keydir = /recalbox/share/system/configs/moonlight/keydir
    
    ## Load additional configuration files
    #config = /path/to/config
    

    EDIT 2 : J'ai testé Moonlight sur android, il fonctionne nickel, le problème provient donc de Moonlight sur Recalbox 😞



  • Bonjour !

    Essaie : /recalbox/scripts/moonlight/Moonlight clean ; /recalbox/scripts/moonlight/Moonlight pair a^près avoir supprimé les appareils appairés sur GFE



  • @Substring said in [Moonlight] You must pair with the PC first:

    Bonjour !

    Essaie : /recalbox/scripts/moonlight/Moonlight clean ; /recalbox/scripts/moonlight/Moonlight pair a^près avoir supprimé les appareils appairés sur GFE

    Bonjour,

    Tout d'abord merci pour la mise en page de mon post, je n'ai pas trouvé les balises adéquates..

    Ensuite, j'avais tenté ces deux commandes et tout se passe correctement puis pareil au lancement d'un jeu, dans les logs sous ssh :

    "you must pair with the PC first"

    Bref, j'ai fini par trouver le bug !!!

    Dans le dossier : \RECALBOX\share\system\configs\moonlight

    il y a :
    /K2QEA8~W
    /keydir
    gamelist.txt
    mappingP1.conf
    mappingP2.conf
    moonlight.conf

    Alors me suis posé la question de ce qu'était le dossier /K2QEA8~W
    Je l'ai donc déplacé, puis fait un ./moonlight.sh clean ce qui a pour effet de supprimer le dossier /keydir et enfin j'ai réapairé recalbox sur GFE en faisant ./moonlight.sh pair blablabla ! tout se passe bien, il recréé le dossier /keydir.

    et bien quand je lance un jeu, il me créé le dossier /K2QEA8~W jusqu'au message d'erreur en objet !
    à l'interieur il y a exactement les mêmes fichiers que dans le dossier /keydir...

    J'ai donc copié les fichiers de /keydir vers /K2QEA8~W et bingo, le streaming remarche !!!

    Par contre, expliquer moi ou est le chisme ?? je pense que mon moonlight.conf a un problème sur le codage des caractères, j'essaye de récupérer le fichier original, d'où ces messages d'erreur à la lecture de ce dernier :

    sh: warning: setlocale: LC_ALL: cannot change locale (fr_FR.UTF-8)

    Merci



  • BINGO c'était bien ça !!

    Quelle idée de l'avoir éditer avec wordpad aussi ???

    Désolé pour ce long monologue en tout cas, vous pouvez passer en résolu.



  • on a toujours conseillé un editeur qui gere les fichiers LINUX, pas wordpad ...



  • je sais bien mais bon, cela fait un moment que j'avais pas éditer un fichier linux depuis windows !

    Petite suggestion néanmoins, est t'il possible de rajouter l'édition de ce fichier "moonlight.conf" à l'identique du recalbox.conf, donc depuis l'interface de recalbox sur navigateur ?



  • @tong-man si @MikaXII voulait bien s'en donner la peine 😛


  • Global moderator
    Team

    Où qu'il est le fichier ? ^^



  • ben la pardi !!

    \RECALBOX\share\system\configs\moonlight\moonlight.conf

    Ca serait vraiment plus pratique pour les utilisateurs de moolight 😃


  • Global moderator
    Team

    Le temps que tu répondes j'ai fini de faire les modifs 🙂



  • @MikaXII Ah ben merci c'est cool !!!



  • Bonjour, est ce cette modif sera disponible dans la prochaine version de recalbox ?


Log in to reply
 

Want to support us ?

111
Online

78.5k
Users

20.1k
Topics

147.5k
Posts