MAME config display volume menu when B+Y are pressed.



  • When playing MAME games if I ever press B and Y button together (could happened is many games where Y is used for jump and B for shoot), I can see in the bottom of the screen a mame menu where I can change the volume. As soon as the menu appear, when going right, the volume increase and left it decrease. Going up and down change the menu entry that is beeing configure to gamme or brigthness.... All that while I am still trying to play. The only way to remove it is too press again B + Y (still while playing...)
    Anyone reproduce the issue ?
    It only happen with player 1 controller (I use PS3 controller). pressing the same 3 keys on player 3 controller has no issue.
    Maybe I messed up the map key in MAME config by mistake so is there a way to clean any specif config I could have change ?

    Thanks.


  • Moderator
    Team

    Errrrr ... Have you edited your keys configuration inside mame itself ?



  • Not editing a file but I could have reached the MAME menu and tune the joystick config by mistake by changing ~ to B+Y but even that I doubt I could have done that without remembering.
    If noone can reproduce my issue and there are no easy way to clean any specific config I could have done by mistake, I wil probably reinstall everything from scratch but I fear to get the same result.


  • Moderator
    Team

    it happened quite often to me to mess MAME inputs. I never found where its dedicated file is located.

    Anyway : does this happen on any game ? When you say B+Y, are these SNES button names ?



  • yes any MAME games give me the same result (annoying menu).
    Yes this is the SNES button names. the PS3 equivalent are X Cross and Square.
    Do you have the same issue (using last 4.0 official release with default MAME 2003 0.78 version) ?


  • Moderator
    Team

    I don't have that issue. Just tried double dragon, worked as expected



  • Do you know how to disply the MAME menu in order to check the key mapping.
    I can only manage to open the libretro menu but can't manage to access MAME menu itself.


  • Moderator
    Team

    @Benoit-Caroline-Dumont just press R2. If your pad doesnt have such a key, plug a usb keyboard and press TAB



  • Hello, I just rebuild my PI3 from scratch and all went back to normal.
    I guess my kids messed the config.
    In order to avoid that to happen again, I activated the parameter :
    system.es.menu=none

    Thanks for the support.


  • Moderator
    Team

    @Benoit-Caroline-Dumont this must have happened with the R2 button where you can change MAME specific button layout



  • This topic is old, but as I have faced what I believe to be the same issue, and managed to SOLVE IT, I would like to share my solution with you.
    I have had kind of the same issue, and never understood how it happened. The result/problem was that as soon as I touched the "right direction" button of my D-pad, or right direction of the Joystick of my arcade cabinet (my RaspberryPi is installed in an arcade cabinet), a Mame settings menu appeared on screen. Or, to be more precise and exact, the following settings bars would appear alternatively (depending on my pressing the "up" or "down" buttons, then) at the bottom of the screen, while I was still playing: "Gamma correction", "Volume", "Brightness", "Contrast", etc.
    Here is how I have got rid of those annoying settings bars, although I confess I do not understand quite well why it works.
    As I have said, my RasberryPi is inside an arcade cabinet, so I have to access it via "My Local Networks" in my Windows Explorer. The exact path I have followed is:
    "My Local Networks/RECALBOX/Share/roms/mame/mame2003/cfg.
    Once I arrived in that "cfg" folder, I noticed there was a ".cfg" file for each game that I had been playing (or simply tried) on Mame since I owned my arcade cabinet. I simply deleted all such .cfg files, went back in front of my arcade cabinet, launched a game, and miraculously it worked i.e. the annoying settings menu would no longer display when I would press the "right" direction on the D-pad, or joystick !!!
    I hope this description will help those of you which have the same problem.



Want to support us ?

480
Online

24267
Users

12899
Topics

97720
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.