Is wifi possible?



  • I was wondering if recallboxos is wifi compatible?


  • Staff
    Developer
    Global moderator
    Team

    Hi, i'm working on that right now 🙂 Maybe in the next release !



  • cool.



  • I'm using the latest 3.2, and I am having trouble with the wifi. I enabled it and type in my ssid info and passcode, and nothing is happening.


  • Staff
    Developer
    Global moderator
    Team

    Ok maybe the wifi dongle is not compatible, maybe it's the recalboxOS. Could you wire a usb keyboard and press F4 to quit the frontend, then ALT+F2 to get the prompt, then use "root" "recalboxroot" to connect. Can you tell me the output of the following command : ifconfig -a Then unplug and replug your USB wifi dongle and give me the 10 last lines of the followiing : dmesg



  • It's saying the loading firmware file rt2870.bin was failed.



  • My wifi dongle is detected, but still getting wifi error. It's renaming the wlan from wlan125 to wlan1. Is that okay?


  • Staff
    Developer
    Global moderator
    Team

    That's not ok. I think it does the same think that caused the issue for the ethernet. eth0 was renammed eth1 and was not configured because the interface configured needs to be called eth0... Same for wlan0. Try to edit /etc/network/interfaces and change wlan0 to wlan1 That should work until I correct this issue.



  • I did the edit. Still does not work. i notice when i boot, it comes up with the firmware error. But if I remove the dongle and plug it back in, it gets detected.


  • Staff
    Developer
    Global moderator
    Team

    Super weird. Could you add an issue to https://github.com/digitalLumberjack/recalbox-os/issues with all info you can give ? Like dmesg output, ifconfig -a output etc ?



  • I'm having the same issue, all fine with lan connection, but no wifi.... [ 3.339654] usbcore: registered new interface driver rtl8192cu [ 3.344159] rtl8192cu 1-1.4:1.0 wlan125: renamed from wlan0 [ 3.376407] udevd[113]: renamed network interface wlan0 to wlan125 [ 3.376518] rtl8192cu 1-1.4:1.0 wlan2: renamed from wlan125 [ 3.416293] udevd[113]: renamed network interface wlan125 to wlan2 [ 5.310985] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1 [ 10.753236] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup [ 15.928330] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup [ 17.473519] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1 [ 116.319324] usb 1-1.4: USB disconnect, device number 5 [ 126.536267] usb 1-1.4: new high-speed USB device number 7 using dwc_otg [ 126.637754] usb 1-1.4: New USB device found, idVendor=0bda, idProduct=8176 [ 126.637790] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3 [ 126.637801] usb 1-1.4: Product: 802.11n WLAN Adapter [ 126.637812] usb 1-1.4: Manufacturer: Realtek [ 126.637823] usb 1-1.4: SerialNumber: 00e04c000001 [ 126.788783] rtl8192cu 1-1.4:1.0 wlan124: renamed from wlan0 [ 126.826406] udevd[360]: renamed network interface wlan0 to wlan124 [ 126.826530] rtl8192cu 1-1.4:1.0 wlan2: renamed from wlan124 [ 126.856321] udevd[360]: renamed network interface wlan124 to wlan2 Do you want me to move this to https://github.com/digitalLumberjack/recalbox-os/issues


  • Staff
    Developer
    Global moderator
    Team

    Ok i see the problem. There is an issue with udev where it create several entries in /etc/udev/rules.d/70-persistence-net-rules for the same card. If you see /lib/udev/rules.d/75-persistent-net-generator.rules it the one who create the /etc/udev/rules.d/70-persistence-net-rules. If it see an interface plugged but the name already exists (wlan0 for example), it should not write it to the file. But if you check your /etc/udev/rules.d/70-persistence-net-rules file you will see 2 or 3 rules for wlan. Remove the rule for wlan1 and 2 and restart your recalbox. That should do the trick until i find why udev act like this.



  • Thanks, but not sure what I should do... I am struggling (as only used to using NOOBS Linux Shell) to work out how to do anything when I SSH in... I dont recognise any of these commands 🙂 I also want to know how to do shutdown.... Built-in commands: ------------------ . : [ [[ alias bg break cd chdir command continue echo eval exec exit export false fg getopts hash help history jobs kill let local printf pwd read readonly return set shift source test times trap true type ulimit umask unalias unset wait


  • Staff
    Developer
    Global moderator
    Team

    I corrected that in the next release. I hope the release will be online today, i'm testing it right now.



  • I am using the 3.3.o beta17 and I am having this problem with the raspberry pi 2 and the official pi wifi dongle. I tried retropie and wifi on that works fine



  • I had the same issue. I was able to fix it by editing the config file via putty from my computer (using ethernet for the connection of course). Whenever I typed my wifi-password in, it was gone the very next moment, so was my ssid. I was able to fix this by doing the following:

    1. connect your Pi with your desktop-computer via ethernet
    2. edit the config file manually by typing in your ssid, your wifi password and setting wifi.enabled=1
    3. remember 2 things:
      1. delete the ";" infront of those lines, thats the reason why it didnt work for me the first time
      2. after you get an recalbox update, the config file is NOT getting updated automatically (as far as I can say), thats the reason why it didnt work for me the second time 🙂

    I hope I could help.


Log in to reply
 

Want to support us ?

310
Online

82.0k
Users

22.5k
Topics

162.9k
Posts